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SWEPP Assay System
Software Test Plan and Report

1. INTRODUCTION

The Idaho National Engineering Laboratory (INEL) Stored Waste Examination
Pilot Plant (SWEPP) operations staff use nondestructive analysis methods to characterize
the radiological contents of contact-handled waste containers. Containers of waste from
Rocky Flats Environmental Technology Site and other DOE sites are currently stored at
SWEPP. Before these containers can be shipped to the Waste Isolation Pilot Plant
(WIPP), SWEPP must verify compliance with storage, shipping, and disposal
requirements. This program has been in operation since 1985 at the INEL Radioactive
Waste Management Complex (RWMC).

One part of the SWEPP program measures neutron emissions from the containers
and estimates the mass of plutonium and other transuranic (TRU) isotopes present. A
Passive/Active Neutron (PAN) assay system developed at the Los Alamos National
Laboratory [1]! is used to perform these measurements. A computer program named
NEUT?2 was originally used to perform the data acquisition and reduction functions for the
neutron measurements. This program was originally developed at Los Alamos and was
extensively modified by a commercial vendor of PAN systems and by personnel at the
INEL. NEUT2 uses the analysis methodology outlined in [1], but no formal
documentation exists on the software itself. The SWEPP Assay System (SAS) computer
program replaced the NEUT?2 software in early 1994. The SAS software was developed
using an "object model" approach and is documented in accordance with ANSI/IEEE
standards. The new software incorporates the basic analysis algorithms found in NEUT2.
Additional functionality and improvements include a much improved user interface, the
ability to change analysis parameters without having to modify the code, and other
features designed for flexibility and maintainability.

This document supersedes the original SAS Software Test Plan and report (STP)
[5]. This document contains the testing requirements and results for the SAS computer
program (Version 2.0). Companion documents include a software requirements
specification [2], a software design description [3], a software verification and validation
plan [4], and a software configuration management plan [6]. Following the release of the
SAS Version 2.0, subsequent work is anticipated in order to continue developing this
assay technology.

Version 1.0 of the SAS was developed by staff from the INEL Scientific
Computing unit under the technical direction of the Nuclear and Radiation Physics unit.
Version 2.0 is under development by staff from the INEL Nuclear Physics and Radiation

I References cited in this document are listed in Section 1.4.
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Chemistry Department, with documentation and testing assistance provided by personnel
from the Software and Electronics and the Engineering Analysis departments. Funding for
this work has been provided through the INEL Transuranic (TRU) Waste Programs
department.

1.1 Purpose

The primary purpose of this test plan and report is to document the test process
and to verify that the requirements for the SAS are implemented correctly. It is guided by
the format and content guideline suggested by the ANSI/IEEE software engineering
standards [8]. This test plan and report satisfies the testing requirements of ASME NQA-
1-1994 Supplement 11S-2 [10] for a Quality Level 2 application.

The intended audiences for this test plan are the developers and verification and
validation analysts for the SAS.

1.2 Scope

This document specifies the software tests to be performed by the SAS at the
INEL.

1.3 Definitions, Acronyms, and Abbreviations
Reference [12] provides, in general, definitions, acronyms, and abbreviations

typical to the life cycle approach to software development. The following are specific to
this document:

CAMAC computer aided measurement and control

DMS data management system

GPIB general purpose interface bus

INEL Idaho National Engineering Laboratory

RWMC Radioactive Waste Management Complex -

SAS SWEPP Assay System, the name of the computer program
SGRS SWEPP Gamma-Ray Spectrometer [13]

SWEPP Stored Waste Examination Pilot Plant

WIPP Waste Isolation Pilot Plant

1.4 Overview

Section 2 provides the list of references. Section 3 identifies the items required to
conduct the testing. Section 4 lists the features to be tested, and section 5 lists the
individual tests to be conducted. Section 6 lists the features that are not to be tested.
Section 7 describes the approach to testing. Section 8 specifies the suspension criteria and
the resumption requirements for the testing. Section 9 describes the environmental needs.
Section 10 provides a detailed description for each test. Section 11 provides the
requirements traceability matrix. Regarding the execution of the test plan, Section 12
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‘ describes the results, Section 13 discusses the anomalous events, Section 14 provides a
summary, and Section 15 gives an evaluation.

2. REFERENCES

[1] J. T. Caldwell et. al., The Los Alamos Second-Generation System for Passive and
Active Neutron Assays of Drum-Size Containers, LA-10774-MS, Los Alamos
National Laboratory, September 1986.
[2] S. D. Matthews, L. V. East, E. S. Marwil, and J. J. Ferguson, SWEPP Assay
System Version 2.0 Software Requirements Specification, INEL-96/0046,
- Lockheed Idaho Technologies Co., March 1996.
[3] L. V. East and E. S. Marwil, SWEPP Assay System Software Version 2.0 Design
Description, INEL-96/0057, Lockheed Idaho Technologies Co., May 1996.
[4] S. D. Matthews, SWEPP Nondestructive Assay Software Verification and
Validation Plan, INEL-96/0008, Lockheed Idaho Technologies Co., March 1996.
[5] S. D. Matthews, E. S. Marwil, and B. G. Gilbert, SWEPP Assay System Software
Test Plan and Report, EGG-RAAM-10425 , EG&G Idaho, Inc., September 1993.
[6] J.J. Ferguson, K. D. Boyd, and E. S. Marwil, SWEPP Assay System Version 2.0
Software Configuration Management Plan, INEL-96/0007, Lockheed Idaho
Technologies Co., March 1996. A
[7] Quality Assurance Management Manual, PDD-1, Lockheed Idaho Technologies

Co., November 1995.
‘ [8] ANSI/IEEE Std. 829-1983, IEEE Standard Jor Software Test Documentation,

Institute of Electrical and Electronic Engineers, Inc.

9] ANSI/IEEE Std. 610.12-1990, IEEE Standard Glossary of Software Engineering
Terminology, Institute of Electrical and Electronic Engineers, Inc.

[10] ASME NQA-1-1994 Supplement 118-2, "Supplementary Requirements for
Computer Program Testing,” American Society for Mechanical Engineers.

[11] RWMC QPP-130, Revision 3.

[12] ANSI/IEEE Std. 610.12-1990, IEEE Standard Glossary of Software Engineering
Terminology, Institute of Electrical and Electronic Engineers, Inc.

[13]1 T.E. Curry, SWEPP Gamma-Ray Spectrometer System Software Requirements
Specification, EG&G Idaho, Inc. internal document ES-5 1544, September 1994.

[14] L. V. East, System Change Request for PAN Software Upgrade, Lockheed Idaho
Technologies Co. internal document 13623, February 1996.

[15]1 DOE Carisbad Area Office (CAO) Quality Assessment Program Description
(QAPD), Revision 1, Interim Issue, May 22, 1995, Section 6 - Quality Assurance
Software Requirements.

3. TEST ITEMS

This test will address SAS Version 2.0. The SAS executable code must reside on
the hard disk of the platform connected to the CAMAC crate. The software requirements
specification document [2] must be available prior to testing. Specific environmental

‘ needs are described in Section 9.
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4. FEATURES TO BE TESTED

This test plan will address the following:

® Ensure that no problems were introduced in moving from Version 1.0 to
Version 2.0.

® Determine that the concerns outlined in the System Change Request (SCR)
[14] covering the Version 2.0 revisions were properly addressed.

Version 2.0 of the SAS includes the following additional functionality which must
be tested: -

e Reporting of individual plutonium isotopic masses.

¢ Implementation of ?°U corrections to active assay results using SGRS and
reporting ?°U mass based on SGRS results.

Use SGRS results, if available, to determine 2*! Am mass.
Ability to reanalyze saved data using new calibration, matrix or SGRS data.
Calculation of TRU activity, total activity, plutonium equivalent Curies and
fissile gram equivalent (FGE).

® Assay results and other information needed during data reviews added to data
files.

e Additional "data integrity" checks added to minimize the possibility of
performing assays when the system hardware is not functioning properly.

S. TEST IDENTIFICATION ‘

The following outline lists the major test categories. Subsections are provided for
both valid and invalid test cases. The individual test cases are listed here for reference.
Specific details for each test are provided in Section 10.

User Access
VALID
Operator login UA.l
Operator logout ‘ UA2
Physicist login UA3
Physicist logout UA4
Administrator login ' UAS
Administrator logout UA.6
Close chamber window and log out UA.7
INVALID
Invalid user ID UA.8
Valid user ID, invalid password UA.9
Administrator Functions
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VALID
Log file manipulation AF.1
Add operator AF2
Add physicist AF3
Add administrator AF 4
Change operator's user ID AFS5
Change operator's user password AF.6
Change operator's access level AF7
Change physicist's user ID : AF.8
Change physicist's user password AF9
Change physicist's access level AF.10
Change current administrator's user ID AF.11
Change administrator's user ID AF.12
Change current administrator's password AF.13
Change administrator's password AF.14
Change administrator's level AF.15
Delete operator AF.16
Delete physicist AF.17
Delete administrator AF.18
INVALID
Adding duplicate operator ID AF.19
Adding duplicate physicist ID AF.20
Adding duplicate administrator ID AF.21
Changing current administrator's access level AF.22
Debating current administrator's user ID AF.23
Container List
VALID
Adding container CL.1
Changing container CL.2
Deleting container CL3
INVALID
Adding duplicate container CLA4
Adding container, volume =0 CL.S5
Adding container, volume <0 CL.6
Adding container, volume > 10,000 CL.7
Adding container, then canceling CL.8
Changing container, volume =0 CL.9
Changing container, volume < 0 CL.10




Changing container, volume > 10,000
Changing container, then canceling

Matrix List
VALID .
Adding matrix, not sludge

Adding matrix, sludge, not Americium sludge
Adding matrix, Americium sludge

Deleting matrix

Setting matrix attributes

INVALID
Adding duplicate matrix

Setting invalid matrix attributes
Chamber Calibration

VALID
Chamber calibration parameters

Mass fractions

INVALID
Chamber calibration parameters /

Mass fractions, negative value
Mass fractions, sum different from 1.0

Waste Attributes
VALID
File name (alpha)

File name (numeric)

File name (special characters)
Valid matrix codes

Valid container net weight
Run/New Assay

Switch between windows

INVALID
File name (invalid special characters)
Invalid net weight

Toggle Switches
VALID

Auto Summary Report on, Auto Data Save on

Auto Summary Report off

Auto Summary Report on, Background Correction on

Auto Summary Report off .

Auto Summary Report on, Background Correction off
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CL.11
CL.12

ML.1
ML.2
ML.3
ML.4
ML.5

ML.6
ML.7-9

CC.1
CCz2

CC3
CC4
CCs5

WAl
WAZ2
WA3
‘WA4 -7
‘WA A4-7
WA
WA.9

WA.10 - 14
WA.15-19

TS.1
TS.2
TS.3
TS.4
TS.5



INVALID
none

Processing Options
VALID _
Background Count Time = 10 sec

Background Count Time = 200 sec
Background Count Time = 300 sec

Active Pulse Verification = 100 counts
Passive Count Time Verification = 10 sec
Active Pulse Verification = 2,000 counts
Passive Count Time Verification = 200 sec
Active Pulse Production = 100 counts
Passive Count Time Production = 10 sec
Active Pulse Production = 5,000 counts
Passive Count Time Production = 300 sec

INVALID
No options file present

Invalid background count time
Invalid active pulse verification
Invalid active pulse production
Invalid passive count time verification
Invalid passive count time production

CAMAC Interface
VALID
CAMAC operational

INVALID
No CAMAC power

No active CAMAC configuration
No passive CAMAC configuration
No controller

Time and Date of Data Acquisition
VALID
Time and date of passive assay

Time and date of active assay
INVALID

none

Passive Signals
VALID
Passive data acquisition
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Cp.1
Cp2
CP3
Cpr4
Cpr4
CP.5
CP5
CP.6
CP.6
CP.7
Cp.7

CP.8
CP9-11
CP.12-14
CP.15-17
CP.18 -20
CpP.21-23

ClL1

Cl2
CIL3
Cl4
CL5

TDDA.1
TDDA.2

PS.1




INVALID
Invalid passive counts

Active Signals
VALID
Active data acquisition

INVALID
Tnvalid active counts

Data Reduction
VALID
Measurement computation

INVALID
" none

Chi-square
VALID
Normal chi-square

INVALID
Chi-square parameter file not available

DMS Interface
VALID
Receive request from DMS to perform new assay

Acknowledge DMS data

Send results to DMS

Receive acknowledgment from DMS

Receive request from DMS to perform recalculation
Receive request from DMS to perform recalculation

Verification of current data during remote recalculation

INVALID
none

Version 2.0 Modifications
VALID
Corrupted data file

Background data with passive assay
Missing passive background data
Window placement and color information
Reanalyzing saved data
Background data integrity
Closing windows after aborting assay
"Keyboard accelerators"

INVALID

none
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PS.2-4

AS.1

AS2-3

DR.1-2

CS.1

CS.2

DMS.1
DMS.1
DMS.1
DMS.1
DMS.2
DMS.3

DMS.37

VM.1
VM.2
VM.3
VM.4
VM5
VM.6
VM.7
VM.8
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6. FEATURES NOT TO BE TESTED

This test plan will not address the following items:

e DMS. DMS is a separate software system that transmits requests to, and
receives responses from SAS and, thus, will not be tested. Only the
interface will be tested.

e SGRS. SGRS is a separate software system that transmits requests to,
and receives responses from SAS and, thus, will not be tested. Only the
interface will be tested.

e CAMAC crate. The test will address the CAMAC crate only insofar as it
' interfaces with SAS. No additional testing will be performed.

e DOS 6.0, Windows 3.1, or the Microsoft Visual C++ 1.51 development
environment. SAS testing will not directly address the operating system
or compiler environment.

° Eqdation validity. Testing will not address whether the equations are
valid for the application. The methodology used is as described in
reference [1].

e Portability to other IBM compatible platforms. Because present plans call
for the SAS to be installed on an IBM compatible 486 platform, all testing
will be for the target environment. Because there is no present need for
portability, testing will not address portability.

7. APPROACH

The SAS testing will address the functions formally provided by NEUT2, as well
as improvements from SAS Version 1.0. The following paragraphs describe-the testing
approach for each of these functional areas.

7.1 Data Acquisition and Data Reduction

The SAS acquires passive and active assay data through the CAMAC crate
system. For the passive assay, neutron detectors on all six sides of the assay chamber
count the neutrons emitted from the waste container. A neutron generator injects
neutrons into the container for the active assay, and the detectors count neutrons from
induced fissions. The detectors are connected to a CAMAC crate. The SAS controls the
CAMAC crate during the acquisition process and requests the counts needed to perform
the assay at the completion of the data acquisition. The CAMAC crate interface with SAS
shall be tested by () not having any power to the CAMAC crate and (b) not having
controller access to SAS. The corresponding data reduction of the counts will be tested
by a combination of valid and invalid count data.

7.2 Calculated Quantities

The SAS estimates the masses of both plutonium (Pu) and americium (247)
contained in a waste drum, and computes the thermal power, thermal power error, thermal
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power density, thermal power density error, total alpha activity, total alpha activity error,
activity concentration error, total Pu mass and error, individual plutonium isotopic masses
(238, 239, 240 and 241), the mass of 2°U when its presence is indicated by gamma ray
measurement results, TRU activity, TRU activity concentration, total activity, plutonium
equivalent curies, and fissile gram equivalent. These tests will also test the assay
recalculation from existing signal data and the production of the measurement summary.
The test cases will address combinations of valid/invalid content matrixes.

7.3 Remote and LLocal Modes of Opei'ation

The test cases will address both remote and local modes of operation of SAS.

7.4 DMS Interface i

The SAS receives assay requests from the DMS. To test the DMS interface, all
the acknowledgments and transmissions between the SAS and DMS will be tested.

7.5 SGRS Interface

The SWEPP Gamma-Ray Spectroscopy System (SGRS) will be tested separately,
and the results will be stored in files which will be utilized by the SAS system during
testing.

7.6 Administrative Control/Modification of Parameters

All administrative functions in the SAS must be tested. Both the list of available
container types and the list of available matrix types must be tested to ensure that they can
be modified successfully.

8. SUSPENSION CRITERIA AND RESUMPTION REQUIREMENTS

If SAS failure occurs as a result of a test, all testing should be suspended until the
defect is corrected or evaluated. If testing reveals an error in the SAS, but the SAS
continues to respond, testing can continue until completion. Any anomalies should be
recorded in the Test Execution Log, Appendix A.

If a CAMAC crate error is encountered, all testing should be suspended until the
CAMAC crate error can be eliminated.

9. ENVIRONMENTAL NEEDS
The SAS must execute on an IBM compatible PC using at least an INTEL 386

CPU. A mouse, VGA color monitor, HP LaserJet III compatible printer, at least DOS
5.0, and Windows 3.1 are also required. At least 8 megabytes of memory, a floppy disk

10
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(either a 5.25-inch or 3.5-inch) and a hard disk (120 megabytes capacity, minimum) are

needed.

The SAS program accesses signal data from a CAMAC crate. The required crate,
modules, and controller are specified in Table 1.

Table 1. CAMAC crate module configuration.

Station Module type Module name
01-02 2323 LeCroy 2323A Gate Generator
03-04 2323 LeCroy 2323A Gate Generator
05 2551 LeCroy 2551 Scaler

06 2551 LeCroy 2551 Scaler

07-08 2323 LeCroy 2323 A Gate Generator
09-10 2323 LeCroy 2323A Gate Generator
11 2551 LeCroy 2551 Scaler

12 2551 LeCroy 2551 Scaler

13 450 DSP 450 Gated Quad Scaler
14-15 2323 LeCroy 2323A Gate Generator
16-17 2323 LeCroy 2323A Gate Generator
18 2551 LeCroy 2551 Scaler

19 2551 LeCroy 2551 Scaler

20 450 DSP 450 Gated Quad Scaler
21 217 Jorway 217 Gated Clock Generator
22 202 Jorway 202 Dataway Display
23 2551 LeCroy 2551 Scaler

24-25 8901 LeCroy 8901 A GPIB Interface

11
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10. TEST PROCEDURE

The test analyst should have a working knowledge of a windows environment,
including push buttons, radio buttons, and scrolling lists. Familiarity with Microsoft
Windows is desirable, as is facility in using a mouse. All procedure steps are described in
terms of the mouse input device, although it is possible to operate the SAS program
without using a mouse. All tests shall be documented in the Test Execution Log,
Appendix A, identified by test category and test case number.

The.SAS supports the drum assay chamber. For clarity in most screen images, the
windows for the drum assay chamber are not shown.

Operator:|operator_name

Drum Assay Chamber

The SAS root directory is defined in the file AS.INI. This file is located in the
working directory for the program. The working directory can be located using the
Properties function in Windows.

12
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10.1 User Access

10.1.1 Introduction and Description

These tests address operator, physicist, and administrator login and logout capability of
SAS.

10.1.2 Special Requirements

Windows shall be operating. The SWEPP Assay System icon or main window must be
visible.

10.1.3 Procedure Steps

1) Double click on the SWEPP Assay System icon with the left mouse button.

R
SWEPP Assap
System,
Yersion 2.0

2) The login dialog is displayed.

el BWERP Azsay Bysiem, YWercipn 2.8 -
Exit Log In...
%}

3) After logging in, inspect the menu items to confirm that all menu choices
shown in the following figures are displayed. For each item in the menu bar,
pull down the menu by clicking the mouse button. These menus will be used
throughout the remainder of the tests.

13
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10.1.4 Valid Test Cases

UA.1
Purpose .
This test addresses operator login requirements, 3.1.2.2 M.1 and 3.1.2.2 M..2.
Input Description

1) In the login dialog, enter valid operator ID and password.
2) Click on OK.
3) Confirm the archive disk reminder window by clicking the OK button.
4) Pull down the File, Run, Options, Window, and Help menus.
Expected Results
The archive disk reminder window is displayed. (The actual archive drive is specified in
the file AS.INL.)

Reminder

Operator} operator_name
File Run Options Window Help -

Drum .&}ssay Chamber

14
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The Operator's File menu is displayed as shown.

Operator: operator_name

Ctrl+E

/g/ o
‘Bac g'rod'lid
Yerification
Chi-Square

Remote Ctri+R

VR

i

15




The Operator's Options menu is displayed as shown.

File BRun

Sumniar
Vv Auto Data Save

IR T TP S S PSP
V Eaengreand Dorreniion

Color...
Assay Times...

Options

Errange

+/1 Drum Assay Chamber

16
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The Operator's Help menu is displayed as shown.

Operator: operator_name
Options - Window 7Hein

Pass/Fail Criteria
Test passes if the operator menus are displayed as indicated.

17
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UA2
Purpose .
This test addresses the operator logout requirement, 3.1.2.2 M.3. -
Input Description '

1) If notlogged in, log in to the SAS as an operator.
2) Pull down the File menu.
3) Select Log Out.
Expected Results .
The initial SAS window is displayed. This window provides functions to log in as another
user and to exit the SAS program. - *

SWEPP Assay|System, Yersion 2.0

Pass/Fail Criteria
Test passes if the initial SAS window is displayed.

18
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UA3
Purpose
This test addresses physicist login requirements, 3.1.2.2 M.1 and 3.1.2.2 M.2.
Input Description ‘

1) Inthe login dialog, enter valid physicist ID and password.
2) Click on OK.
3) Confirm the archive disk reminder window by clicking the OK button.
4) Pull down the File, Run, Options, Window, and Help menus.
Expected Results
The archive disk reminder window is displayed.

Reminder

Drum Assay Chamber @

19
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The Physicist's File menu is displayed as shown.

Physicist:|physicist_name
Run _thions-_W_indo Help

Drum Agsay Chamber
Open... Ctrl+0

e

PO F
Liess

Print...

Log Out
Exit CtrI+E

say Chamber
Background

Yerification
Chi-Square

Remote Ctri+R

20



The Physicist's Options menu is displayed as shown.

File BRun

v Auto Data Save
v Background Cerrection

Color...
Assay Times...

Calibration...
Matrix List...
Container List...

Options }

Arrange

v 1 Drum Assay Chamber

21
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The Physicist's Help menu is displayéd as shown.

Physicist:|physicist_name
File Run Options - Window

Pass/Fail Criteria
The test passes if the physicist menu is displayed.

22
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UA4 .
Purpose
This test addresses the physicist logout requirement, 3.1.2.2 M.3.
Input Description .

1) Ifnotlogged in, log in to the SAS as a physicist.
2) Pull down the File menu.
3) Select Log Out. .
Expected Results
The initial SAS window is dlsplayed This window prov1des functions to log in as another
user and to exit the SAS program.

SWEPP Assay System, Version 2.0

Pass/Fail Criteria
Test passes if the initial SAS window is displayed.

23
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UAS
Purpose
This test addresses administrator login requirements, 3.1.2.2 M.1 and 3.1.2.2 M.2.

Input Description ) )
1) In the login dialog, enter valid administrator ID and password.
2) Click on OK.
3) Pull down the File and Help menus.

Expected Results

The Administrator window and menu items are displayed.

Administrator. administrator_name

B

24
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L

Log Fi
Print...

Pass/Fail Criteria
The test passes if the administrator menu is displayed as indicated.

25
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) UA.6
Purpose
This test addresses the administrator logout requirement, 3.1.2.2 M.3.
Input Description ‘

1) If notlogged in, log in to the SAS as an administrator.
2) Pull down the File menu.
3) Select Log Out.
Expected Results
The initial SAS window is displayed. This window provides functions to log in as another
user and to exit the SAS program.

SWEPP Assay|System, Yersion 2.0

Exit Loglin... Help ] .
: - 7

Pass/Fail Criteria
Test passes if the initial SAS window is displayed.

UA.7
Purpose

This test addresses the logout requirement, SCR User Interface Problems, Item 6 [14], to
ensure that the "Chamber Window" can not be closed without first performing a user
logout operation.

Input Description .
1) Log in to the SAS as an operator. .
2) Close the "Chamber Window."
3) Click on Yes.
4) Login to the SAS as a physicist.
5) Close the "Chamber Window."
6) Click on Yes.

26
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Expected Results
"Do you really want to..." dialog is displayed each time the user attempts to close the
chamber window. : .

The initial SAS window is displayed. This window provides functions to log in as another
user and to exit the SAS program.

SWEPP Assay System, Version 2.0

Pass/Fail Criteria
Test passes if the confirmation dialog and the initial SAS window are displayed.
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10.1.5 Invalid Test Cases

UA.8
Purpose
This test addresses the requirement to permit only users with a valid user ID to access
SAS, requirement 3.1.2.2 M.1. This test enters an invalid user ID.
Input Description
1) In the login dialog, enter an invalid operator ID and valid operator password.
2) Click on OK.

Expecteti Results
"Invalid ID or Password" dialog is displayed.

Pass/Fail Criteria
The test passes if the error dialog is displayed.

28
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UA.9
Purpose
This test addresses the requirement to permit only authorized users to access the system,
requirement 3.1.2.2 M.1. This test enters a valid user ID, but invalid user password.
Input Description
1) In the login dialog, enter an valid operator ID and invalid operator password.
2) Click on OK. -

Expected Results
"Invalid ID or Password" dialog is displayed.

Pass/F ail Criteria
The test passes if the error dialog is displayed.

29
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10.2 Administrator Functions

10.2.1 Introduction and Description

These tests address modifying the list of users who have access to.the system, as well as
manipulating the log file.

10.2.2 Special Requirements

The user list dialog will be visible for the test cases dealing with the user list. The dialog
inputs are described for each test. Optionally, following each test, the file USER.LST in
the assay system root directory may be printed to verify that the user list is stored with
appropriate data.

10.2.3 Procedure Steps

1) Log in as an administrator.
2) Pull down the File menu.
For user list test cases:
3) Select User List.
4) The user list dialog is displayed.
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10.2.4 Valid Test Cases

AF.1
Purpose
This test addresses manipulation of the log file, requirement 3.1.2.2M.2. -
Input Description

1) Pull down the File menu.
2) Select Print Log Files.
3) After the file prints, pull down the File menu.
4) Select New Log Files.
Expected Results
The log file should print.
Pass/Fail Criteria
Test passes if the log file prints successfully.

AF2
Purpose .
This test addresses adding an operator, requirement 3.1.2.2 M 4.
Input Description

1) In the user list dialog,
® Enter valid user ID {[A-Z | a-z 1 0-9]}6
e Enter user name {[A-Z | a-z10-9]}32
e Enter password {[A-Z | a-z | 0-9]}6
® Select Operator access level.
2) Click on Add.
3) Click on OK.
Expected Results
When the user list dialog is displayed again, the entered user ID appears in the list of
users. When that user ID is selected, the user name is displayed, operator access level is
indicated, and the password is hidden.
Pass/Fail Criteria

Test passes if the operator is added to the list, and the attributes previously entered are
displayed when the ID is selected.

AF3
Purpose
This test addresses adding a physicist, requirement 3.1.2.2 M 4.
Input Description

1) Inthe user list dialog,

Enter valid user ID {[A-Z | a-z | 0-9]}6
Enter user name {[A-Z | a-z |1 0-9]}32
Enter password {[A-Z | a-z | 0-9]}6
Select Physicist access level.
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2) Click on Add.
3) Click on OK.

Expected Results
When the user list dialog is displayed again, the entered user ID appears in the list of

users. When that user ID is selected, the user name is displayed, physicist access level is
indicated, and the password is hidden.

Pass/Fail Criteria
Test passes if the physicist is added to the list, and the attributes previously entered are

displayed when the ID is selected.

32
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AF4
Purpose
This test addresses adding an administrator, requirement 3.1.2.2 M.4.
Input Description .

1) In the user list dialog,
e Enter valid user ID {[A-Z | a-z10-9]}6
® Enter user name {[A-Z|a-z | 0-9]}32
® Enter password {[A-Z | a-z 1 0-9]}6
~® Select Administrator access level.
2) Click on Add.
3) Click on OK.

Expected Results
When the user list dialog is displayed again, the entered user ID appears in the list of
users. When that user ID is selected, the user name is displayed, administrator access level
is indicated, and the password is hidden.

Pass/Fail Criteria
Test passes if the administrator is added to the list, and the attributes previously entered
are displayed when the ID is selected.

AF.S5
Purpose
This test addresses changing an operator's user ID, requirement 3.1.2.2 M 4.
Input Description

1) Inthe user list dialog,
® Select an existing user ID from the pull down mehu.
2) Change the user ID.
3) Click on Change.
4) Click on OK.
Expected Results
When the user list dialog is displayed again, the entered user ID appears in the list of
users. When that user ID is selected, the user name is displayed, operator access level is
indicated, and the password is hidden.
Pass/Fail Criteria
Test passes if the operator's user ID is changed.

AF.6
Purpose .
This test addresses changing an operator's user password, requirement 3.1.2.2 M 4.
Input Description

1) Inthe user list dialog,
® Select an existing user ID from the pull down menu.
2) Change the password.
3) Click on Change.
4) Click on OK.
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Expected Results
When the user list dialog is displayed again, and that user ID is selected; the user name is
displayed, operator access level is indicated, and the password is hidden.

Pass/Fail Criteria ]
Test passes if the operator's user password is changed; the operator must login with the
new password.

AF.7
Purpose
This test addresses changing an operator's access level, requirement 3.1.2.2 M 4.
Input Description '

1) In the user list dialog,
e Select an existing operator user ID from the pull down menu.

o Select Physicist access level radio button.
2) Click on Change.
3) Click on OK.
4) In the user list dialog, ’

e Select an existing operator user ID from the pull down menu.

e Select Administrator access level radio button.
5) Click on Change.
6) Click on OK.
7) Return the access level to its original status when the test is complete.
Expected Results
‘When the user list dialog is displayed again, and that user ID is selected, the user name is
displayed, the appropriate access level is indicated, and the password is hidden.
Pass/Fail Criteria
Test passes if the access level is changed.

AF.8 j
Purpose
This test addresses changing a physicist's user ID, requirement 3.1.2.2 M 4.
Input Description

1) In the user list dialog,
e Select an existing physicist's user ID from the pull down menu.
2) Change the user ID.
3) Click on Change.
4) Click on OK.
Expected Results
When the user list dialog is displayed again, the entered user ID appears in the list of
users. When that user ID is selected, the user name is displayed, physicist access level is
indicated, and the password is hidden.
Pass/Fail Criteria
Test passes if the physicist's user ID is changed.
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AF9
Purpose
This test addresses changing a physicist's user password, requirement 3.1.2.2 M4.
Input Description ’

1) In the user list dialog,
® Select an existing physicist's user ID from the pull down menu.
2) Change the password.
3) Click on Change.
4) Click on OK.
Expected Results
When the user list dialog is displayed again, and that user ID is selected, the user name is
displayed, physicist access level is indicated, and the password is hidden.
Pass/Fail Criteria
Test passes if the physicist's user password is changed; the physicist must login with the
new password. '

AF.10
Purpose
This test addresses changing a physicist's access level, requirement 3.1.2.2 M 4.
Input Description

1) In the user list dialog,
® Select an existing physicist user ID from the pull down menu.

® Select Operator access level radio button.

2) Click on Change.

3) Click on OK.

4) In the user list dialog,
® Select an existing physicist user ID from the pull down menu.
® Select Administrator access level radio button.

5) Click on Change.

6) Click on OK.
7) Retumn the access level to its original status when the test is complete.

Expected Results
When the user list dialog is displayed again, and that user ID is selected, the user name is
displayed, the appropriate access level is indicated, and the password is hidden.

Pass/Fail Criteria
Test passes if the access level is changed.
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AF.11
Purpose
This test addresses changing the current administrator's user ID, requirement 3.1.2.2 M.4.
Input Description ' )

1) In the user list dialog,

e Select the current administrator's user ID from the pull down menu.
2) Change the user ID.
3) Click on Change.
4) Click on OK.
Expected Results
When the user list dialog is displayed again, the entered user ID appears in the list of
users. When that user ID is selected, the user name is displayed, administrator access level
is indicated, and the password is hidden.
Pass/Fail Criteria
Test passes if the administrator's user ID is changed.

AF.12
Purpose '
This test addresses changing an administrator's user ID, requirement 3.1.2.2 M 4.,
Input Description

1) In the user list dialog,

e Select an existing administrator's user ID from the pull down menu (other
than the current administrator's). "
2) Change the user ID.
3) Click on Change.
4) Click on OK.
Expected Resulfs
When the user list dialog is displayed again, the entered user ID appears in the list of
users. When that user ID is selected, the user name is displayed, administrator access level
is indicated, and the password is hidden.
Pass/Fail Criteria
Test passes if the administrator's user ID is changed; the administrator must logm with the
new password.

AF.13
Purpose
This test addresses changing the current administrator's user password, requirement
3.1.2.2MA4.
Input Description
1) In the user list dialog,
e Select an existing administrator's user ID from the puil down menu.
2) Change the password.
3) Click on Change.
4) Click on OK.
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5) Return the access level to its original status when the test is complete.
Expected Results
‘When the user list dialog is displayed again, and that user ID is selected, the user name is
displayed, administrator access level is indicated, and the password is hidden.

Pass/Fail Criteria '
Test passes if the administrator's user password is changed.

AF.14
Purpose
This test addresses changing an administrator's user password, requirement 3.1.2.2 M 4.
Input Description

1) Inthe user list dialog,

e Seclect an existing administrator's user ID from the pull down menu (other
than the current administrator's).
2) Change the password.
3) Click on Change.
4) Click on OK.
5) Retumn the access level to its original status when the test is complete.
Expected Results '
When the user list dialog is displayed again, and that user ID is selected, the user name is
displayed, administrator access level is indicated, and the password is hidden.
Pass/Fail Criteria
Test passes if the administrator's user password is changed.

AF.15
Purpose
This test addresses changing an administrator's access level, requirement 3.1.2.2 M 4.
Input Description

1) In the user list dialog,
e Select an existing administrator user ID from the pull down menu.
® Select Operator access level radio button.

2) Click on Change.

3) In the user list dialog,
e Select an existing administrator user ID from the pull down menu.
e Select Physicist access level radio button.

4) Click on Change.

5) Click on OK.

6) Retumn the access level to its original status when the test is complete.

Expected Results
When the user list dialog is displayed again, and that user ID is selected, the user name is
displayed, the appropriate access level is indicated, and the password is hidden.

Pass/Fail Criteria
Test passes if the administrator's access level is changed.
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AF.16
Purpose
This test addresses deleting an operator user ID, requirement 3.1.2.2 M 4.
Input Description ;

1) In the user list d1a10g, select a user ID with operator access.
2) Click on Delete.
3) Click on OK.
Expected Results
‘When the user list dialog is displayed again, the deleted user ID does not appear in the list.
Pass/Fail Criteria
Test passes-if deleted user ID does not appear in the list.

AF.17
Purpose
This test addresses deleting a physicist user ID, requirement 3.1.2.2 M 4.
Input Description

1) In the user list dialog, select a user ID with physicist access.
2) Click on Delete.
3) Click on OK.
Expected Results
‘When the user list dialog is displayed again, the deleted user ID does not appear in the list. '
Pass/Fail Criteria
Test passes if deleted user ID does not appear in the list.

AF.18
Purpose
This test addresses deleting a administrator user ID, requirement 3.1.2.2 M 4.
Input Description

1) Inthe user list dialog, select a user ID with administrator access. The
administrator selected must be different from that of the administrator who is
performing this test.

2) Click on Delete.

3) Click on OK.

Expected Results
When the user list dialog is displayed again, the deleted user ID does not appear in the list.

Pass/Fail Criteria
Test passes if deleted user ID does not appear in the list.
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10.2.5 Invalid Test Cases

AF.19
Purpose
This test addresses adding a duplicate operator ID, requirement 3.1.2.2 M 4.
Input Description )

1) In the user list dialog, select an operator user ID already in the list.
2) Click on Add.

Expected Results
"Duplicate ID not allowed!" dialog is displayed.

Pass/Fail Criteria
Test passes if dialog is displayed.

AF.20
Purpose
This test addresses adding a duplicate physicist ID, requirement 3.1.2.2 M 4.
Input Description

1) In the user list dialog, select a physicist user ID already in the Iist.
2) Click on Add.

Expected Results
"Duplicate ID not allowed!" dialog is displayed.

Pass/Fail Criteria
Test passes if dialog is displayed.
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AF.21
Purpose
This test addresses adding a duplicate administrator ID, requirement 3.1.2.2 M 4.
Input Description

1) Inthe user list dialo;g, select an administrator user ID already in the list.
2) Click on Add.

Expected Results
"Duplicate ID not allowed!" dialog is displayed.

Pass/Fail Criteria
Test passes if dialog is displayed.

AF22
Purpose
This test addresses changing the current administrator's access level, requirement 3.1.2.2
M4.
Input Description

1) In the user list dialog,
e Select the current administrator's user ID from the pull down menu.

® Select Operator access level radio button. ‘
2) Click on Change.
3) In the user list dialog,

® Select the current administrator's user ID from the pull down menu.

‘ e Select Physicist access level radio button.
4) Click on Change.
5) Return the access level to its original status when the test is complete.

Expected Results
"You cannot change your own level" dialog is displayed.
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Pass/Fail Criteria
Test passes if dialog is displayed.

AF23
Purpose
This test addresses deleting the current administrator's user ID, requirement 3.1.2.2 M.4.

Input Description

1) Inthe user list dialog, select the user ID of the administrator performing this

test.

2) Click on Delete.

Expected Results

"You cannot delete yourself!" dialog is displayed.

Integrity Yislation

Pass/Fail Criteria
Test passes if dialog is displayed.
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10.3 Container List

10.3.1 Introduction and Description

These tests address modifying the list of containers that the assay system can process by
adding containers to and deleting containers from the container list.

10.3.2 Special Requirements

The container list dialog will be visible. The dialog inputs are described for each test.
Optionally, following each test, the file CONTAIN.LST in the assay system root directory
may be printed to verify that the container list is stored with appropriate data. The file
CONTAIN.LST must be write-enabled in order to perform the following tests.

10.3.3 Procedure Steps

1) Login as a physicist.

2) Pull down the Options menu.

3) Select Container List.

4) If the file CONTAIN.LST allows write access, the container list dialog is
displayed as shown:
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If the file CONTAIN.LST does not allow write access, the container list dialog
is displayed as shown (addresses SCR User Interface Problems, Item 11):
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10.3.4 Valid Test Cases

CL.1
Purpose .
This test addresses adding a container to the list, requirements 3.1.4.2 M.1,3.1.4.2 M 5,
and SCR User Interface Problems, Item 11.

Input Description
1) In the container list dialog,

e Enter a container description.

e _ Enter a volume in the range > 0.00 and < 1000.00.
2) Click on Add.
3) Click on OK.
Expected Results
When the container list dialog is displayed again, the entered container description appears
in the list of containers and the volume agrees with the volume entered to two digits after
the decimal.
Pass/Fail Criteria
Test passes if the entered container appears in the list.

CL.2
Purpose
This test addresses changing a container in the list, requirements 3.1.4.2 M.1, 3.1.4.2M.5,
and SCR User Interface Problems, Item 11.
Input Description
1) In the container dialog, select the container description entered in the previous
test.
2) Modify the container volume to a different volume in the range > 0.00 and <
1000.00.
3) Click on Change.
4) Click on OK.
Expected Results
When the container list dialog is displayed again, the modified container description
appears in the list.
Pass/Fail Criteria
Test passes if the modified container is in the list.
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CL3
Purpose
This test addresses deleting a container from the list, requirements 3.1.4.2 M.1,3.1.4.2
M.5, and SCR User Interface Problems, Item 11.
. Input Description
1) In the container dialog, select the container description modified in the
previous test.
2) Click on Delete.
3) Click on OK.
Expected Results
When the container list dialog is displayed again, the deleted container description does
not appear in the list. -

Pass/Fail Criteria
Test passes if the deleted container is not in the list.
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10.3.5 Invalid Test Cases

CLA4
Purpose
This test addresses adding a container to the list, requirements 3.1.4.2 M.1, 3.1.4.2 M.5,
and SCR User Interface Problems, Item 11.
Input Description
1) In the container list dialog, select a container description from the container
list.
2) Click on Add.
Expected Results
"Duplicate description” dialog is displayed. -

Pass/Fail Criteria
Test passes if dialog is displayed.

CL.5

Purpose
This test addresses adding a container to the list, requirements 3.1.4.2 M.1, 3.1.4.2 M.5,
and SCR User Interface Problems, Item 11.
Input Description
1) Inthe container list dialog,
e Enter a container description
e Enter a volume of 0.0. .
2) Click on Add.
Expected Results
"Volume must be > 0" di\alog is displayed.
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Pass/Fail Criteria
Test passes if dialog is displayed.

CL.6
Purpose
This test addresses adding a container to the list, requirements 3.1.4.2 M.1, 3.1.4.2 M.5,
and SCR User Interface Problems, Item 11.
Input Description
1) In the container list dialog,
e Enter a container description
¢ Enter a volume of -10.0.
2) . Click on Add.
Expected Results
"Volume must be > 0" dialog is displayed.
Pass/Fail Criteria
Test passes if dialog is displayed.

CL.7
Purpose
This test addresses adding a container to the list, requirements 3.1.4.2 M.1, 3.1.4.2 M.5,
and SCR User Interface Problems, Item 11.
Input Description
1) Inthe container list dialog,
e Enter a container description
e Enter a volume of 999999.99.
2) Click on Add.
3) Click on Yes to add container.
Expected Results
"Volume seems excessive" dialog is displayed.

Pass/Fail Criteria
Test passes if dialog is displayed.
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CL.8 . :
Purpose
This test addresses adding a container to the list, requirements 3.1.4.2 M.1, 3.1.4.2 M.5,
and SCR User Interface Problems, Item 11.
Input Description
1) Inthe container list dialog,
e Enter a container description
e Enter a volume of 999999.99. :
2) Click on Add. : :
3) Click on No to cancel container addition. -~
Expected Results
"Volume seems excessive" dialog is displayed.

Pass/Fail Criteria
Test passes if dialog is displayed.

CL.9

Purpose
This test addresses changing a container in the list, requirements 3.1.4.2 M.1, 3.1.4.2 M.5,
and SCR User Interface Problems, Item 11.
Input Description
1) In the container list dialog,
e Select any container
e Enter a volume of 0.0.
2) Click on Change.

Expected Results
"Volume must be > 0" dialog is displayed.
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Pass/Fail Criteria
Test passes if dialog is displayed.

CL.10
Purpose )
This test addresses changing a container in the list, requirements 3.1.4.2 M.1, 3.1.4.2 M.5,
and SCR User Interface Problems, Item 11.
Input Description
1) Inthe container list dialog,
¢ Enter a volume of -10.0.
2) Click on Change.
Expected Results
"Volume must be > 0" dialog is displayed.
Pass/Fail Criteria
Test passes if dialog is displayed.

CL.11
Purpose
This test addresses changing a container in the list, requirements 3.1.4.2 M.1, 3.1.4.2 M.5,
and SCR User Interface Problems, Item 11.
Input Description
1) Inthe container list dialog,
e Enter a volume of 999999.99.
2) Click on Change.
3) Click on Yes to change container.
Expected Results
"Volume seems excessive” dialog is displayed.

Pass/Fail Criteria
Test passes if dialog is displayed.
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CL.12
Purpose
This test addresses changing a container in the list, requirements 3.1.4.2 M.1, 3.1.4.2 M.5,
and SCR User Interface Problems, Item 11.
Input Description
1) In the container list dialog,
e Enter a volume of 999999.99.
2) Click on Change.
3) Click on No to cancel container modification.
Expected Results
"Volume seems excessive" dialog is displayed.

Pass/Fail Criteria
Test passes if dialog is displayed.
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10.4 Matrix List

10.4.1 Introduction and Description

These tests address modifying the list of matrixes that the assay system can process by
adding matrixes to and deleting matrixes from the matrix list.

10.4.2 Special Requirements

The matrix list dialog will be visible. The dialog inputs are described for each test.
Optionally, following each test, the file MATRIX.LST in the assay system root directory
may be printed to verify that the matrix list is stored with appropriate data. The file
MATRIX.LST must be write-enabled in order to perform the following tests.

10.4.3 Procedure Steps

1) Login as a physicist.

2) Pull down the Options menu.

3) Select Matrix List.

4) If the file MATRIX.LST allows write access, the matrix list dialog is displayed
as shown:

wed s Bngnown
age Sludge / Combined Sludge
Second-Stage Sludge
Drganic Setups
Special Setups
Evaporator Salts
Wet Sludge [Process Sludge)

Junque
Roaster Oxide

i

If the file MATRIX.LST does not allow write access, the matrix list dialog is
displayed as shown:
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5) If the file MATRIX.LST allows write access, when required by specific tests,
clicking on Add or Change, or double-clicking on an item in the list will display
the matrix parameters dialog:

If the file MATRIX.LST does not allow write access, when required by
specific tests, clicking on Params, or double-clicking on an item in the list will
display the matrix parameters dialog but will not allow changes to be made
(addresses SCR User Interface Problems, Items 10 and 11):
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000 - Not Recorded - Unknown

10.4.4 Valid Test Cases

ML.1
Purpose :
This test addresses adding a matrix to the matrix list, requirements 3.1.4.3 M.3 and M.4.
Input Description

1) In the matrix list dialog,
e Enter anew code in [0, 999]
e Enter matrix description.
2) Click on Add.
3) In the matrix parameters dialog, click on OK to accept the default values.
4) In the matrix list dialog, click on OK.
Expected Results
When the matrix list dialog is displayed again, the entered code and matrix description
appear in the list of matrixes. When that item is selected, the code and description are
displayed, and the word Non-Sludge appears as the matrix type.

Pass/Fail Criteria
Test passes if the entered matrix appears in the list.
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ML2
Purpose
This test addresses adding a matrix to the matrix list, requirement 3.1.4.3 M.3 and M 4.
Input Description

1) In the matrix list dJalog,
e Enter a code in [0, 999]
" o Enter matrix description.
2) Click on Add.
3) Inthe matrix parameters dialog, select the Sludge radio button, then click on
OK to accept the default values.
4) In the matrix list dialog, click on OK.
Expected Results
‘When the matrix list dialog is displayed again, the entered code and matrix description
appear in the list of matrixes. When that item is selected, the code and description are
displayed, and the word Sludge appears as the matrix type.
Pass/Fail Criteria
Test passes if the entered matrix appears in the list.

ML.3
Purpose
This test addresses adding a matrix to the matrix list, requirement 3.1.4.3 M.3 and M 4.
Input Description

1) In the matrix list dialog,
e Enter a code in [0, 999]
e Enter matrix description.
2) Click on Add.
3) In the matrix parameters dialog, select the Am Sludge radio button, then click
on OK to accept the default values.
4) In the matrix list dialog, click on OK.
Expected Results
When the matrix list dialog is displayed again, the entered code and matrix descnptlon
appear in the list of matrixes. When that item is selected the code and description are
displayed, and both Siudge and Am Sludge appear as the matrix types.
Pass/Fail Criteria
Test passes if the entered matrix appears in the list.

54



INEL-96/0058

ML.4
Purpose
This test addresses deleting a matrix from the matrix list, requirement 3.1.4.3 M.3 and
M4. . :

Input Description
1) Inthe matrix list dialog, select one of the matrix codes added in the previous

tests.
2) Click on Delete. The matrix code will be removed from the list.
3) Click on OK.
Expected Results
When the matrix list dialog is displayed again, the deleted code and matrix description do
not appear in the list of matrixes
Pass/Fail Criteria
Test passes if the deleted matrix code no longer appears in the list.

ML.5
Purpose
This test addresses setting the matrix attributes for a matrix in the list, requirement 3.1.4.3
M.3 and M.4. Note that the coefficients for the active self-absorption correction factor
correlation do not have range restriction, and thus are not tested.
Input Description
For each input field and data value listed in,

1) Inthe matrix list dialog, select one of the matrix codes added in the previous
tests.

2) Click on Change.

3) Inthe matrix parameters dialog, enter the value specified in Table 2 for the
field.

4) Click on OK.

Table 2. Valid Matrix Parameter Values.

Field Value
Mass selection Active
(select only one) Passive
Default
Moderator index 0.5
Active correction factor 1.0
Passive shielded correction factor 5.0
Passive system correction factor 10.0
Matrix Type Non-Sludge
(select only one) Sludge
Am Sludge
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Expected Results
The system returns to the matrix list dialog in each case. The input value or selection is
retained when the matrix parameter dialog is reentered by clicking on Change again.
Pass/Fail Criteria
Test passes if each changed value or selection is retained in the matrix parameter dialog on
the next entry into the dialog.

10.4.5 Invalid Test Cases

ML.6

Purpose
This test addresses adding a matrix to the matrix list, requirement 3.1.4.3 M.3 and M 4.
Input Description

1) In the matrix list dialog,
e Select a code and description from the list
< Enter a different matrix description.

2) Click on Add.

Expected Results
"Duplicate Content Code" dialog is displayed.

Pagss/Fail Criteria
Test passes if dialog is displayed.

ML.7
Purpose
This test addresses adding a matrix to the matrix list, requirement 3.1.4.3 M.3 and M 4.
Input Description

1) In the matrix list dialog,

e Enteracode of -10

e Enter a matrix description.
2) Click on Add.

Expected Results i
"Content Code must be in the range 0 to 999" dialog is displayed.
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Pass/Fail Criteria
Test passes if dialog is displayed.

ML.8

Purpose

This te’:t addresses adding a matrix to the matrix list, requirement 3.1.4.3 M.3 and M 4.
Input Description

In the matrix list dialog, attempt to enter more that three digits in the code field.
Expected Results

No more than three digits may be entered.

Pass/Fail Criteria
Test passes if no more than three digits can be entered.

ML.9

Purpose
This test addresses setting the matrix attributes for a matrix in the list, requirement 3.1.4.3

M.3 and M 4.

Input Description
For each input field and data value listed in Table 3,

1) Inthe matrix list dialog, select one of the matrix codes added in the previous
tests.

2) Click on Change.

3) In the matrix parameters dialog, enter the value for the data field from Table 3.

4) Click on OK. ‘
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Table 3. Invalid Marix Parameter Values.

Field Value Expected Result

Moderator index . -0.5 moderator index must be in [0.0,1.0]
Moderator index 2.0 moderator index must be in {0.0,1.0]
Moderator index 0.0 (resets value, continue to next test)
Active correction factor -1.0 correction factors must be = 0.0
Active correction factor 1.0+-1.0 uncertainty must be positive

Active correction factor 0.0 (resets value, continue to next test)
Passive shielded correction factor -1.0 correction factors must be > 0.0
Passive shielded correction factor 1.0+-1.0 uncertainty must be positive

Passive shielded correction factor 0.0 (resets value, continue to next test)
Passive system correction factor -1.0 correction factors must be = 0.0
Passive system correction factor 1.0£-1.0 uncertainty must be positive

Passive system correction factor 0.0+0.0 (resets value, continue to next test)
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Expected Results
As indicated in Table 3, either the "Moderator index ..." dialog is displayed,

Pass/Fail Criteria
Test passes if each invalid value entered produced an error dialog.
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10.5 Chamber Calibration

10.5.1 Introduction and ﬁesc’ription

These tests address the modification of the chamber calibration parameters.

10.5.2 Special Requirements

The chamber calibration dialog will be visible. The dialog inputs are described for each
test. Optionally, following each test, the file .NDAC\CALIB.DAC from the assay system
root directory may be printed to verify that the chamber calibration data are stored
appropriately. The file CALIB.DAC must be write-enabled in order to perform the
following tests.

10.5.3 Procedure Steps

1) Login as a physicist.

2) Pull down Options menu.

3) Select Calibration. .

4) If the file CALIB.DAC allows write access, the chamber calibration dialog w
be displayed as shown.

e

i AR

oo

00024

PR

If the file CALIB.DAC does not allow write access, the chamber calibration
dialog will be displayed as shown, but no changes can be made (addresses SCR
User Interface Problems, Item 11):
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10.5.4 Valid Test Cases

cC.1
Purpose
This test addresses setting the chamber calibration parameters, requirement 3.1.3.3 M.3.
Input Description

For each input field and data value listed in Table 4,
1) Inthe chamber calibration dialog, enter the data value in the field.
2) Click on OK.

Table 4. Valid chamber calibration parameter values.

Field Value
Shielded detector efficiency ' . 0.055
System detector efficiency 0.178
Active zero matrix calibration factor 154
Shielded coincidence zero matrix calibration factor 95.0
System coincidence zero matrix calibration factor 3.67 -

Expected Results
The system returns to the main window in each case. The value is retained when the
calibration dialog is reentered.

Pass/Fail Criteria
Test passes if each value is retained in the calibration dialog.

cCc2
Purpose
This test addresses setting the chamber calibration parameters, requirement 3.1.3.3 M.3.
Input Description
1) In the chamber calibration dialog,
Enter Pu 238 mass fraction 0.01
Enter Pu 239 mass fraction 0.92
Enter Pu 240 mass fraction 0.05
Enter Pu 241 mass fraction 0.015
Enter Pu 242 mass fraction 0.005.
2) Click on OK.
Expected Results
The system returns to the main window. The values are retained when the calibration
dialog is reentered.
Pass/Fail Criteria
Test passes if each value is retained in the calibration dialog on the next entry into the
dialog.

o o ¢ @
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Purpose

cCc3
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This test addresses setting the chamber calibration parameters requirement 3.1.3.3 M.3.

Input Description
For each test case in Table 5,

1) In the chamber calibration dialog, enter the value for the field from the table.

2) Click on OK.

Table 5. Invalid chamber calibration parameter values.

Field Value Expected Result

Shielded detector efficiency -0.5 detector efficiency must be in {0.0,1.0]

Shielded detector efficiency 2.0 detector efficiency must be in [0.0,1.0]
" Shielded detéctor efficiency 0.5£-1.0 uncertainty must be positive

Shielded detector efficiency 0.029+0 (resets value, continue to next test)

System detector efficiency -0.5 detector efficiency must be in [0.0,1.0]

System detector efficiency 2.0 detector efficiency must be in [0.0,1.0]

System detector efficiency 0.5%-1.0 uncertainty must be positive

System detector efficiency 0.1265+0 (resets value, continue to next test)

Active zero matrix calibration factor -1.0 calibration factor must be = 0.0

Active zero matrix calibration factor 05%-1.0 uncertainty must be positive

Active zero matrix calibration factor 435+0 (resets value, continue to next test)

Shielded coincidence zero matrix calibration factor -1.0 calibration factor must be = 0.0

Shielded coincidence zero matrix calibration factor 05+-1.0 uncertainty must be positive

Shielded coincidence zero matrix calibration factor 28.1%0 (resets value, continue to next test)

System coincidence zero matrix calibration factor -1.0 calibration factor must be = 0.0

System coincidence zero matrix calibration factor 0.5+-1.0 uncertainty must be positive

System coincidence zero matrix calibration factor 1.28+0 (resets value, continue to next test)

Expected Results

As indicated in Table 5, either the "Detector efficiencies ..." dialog is displayed,
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or the "Calibration factors ..." dialog is displayed.

Pass/Fail Criteria
Test passes if each value entered produces the appropriate error dialog.

CcCH4
Purpose
This test addresses setting the chamber calibration parameters, requirement 3:1.3.3 M.3.
Input Description. .

1) In the chamber calibration dialog,
o Enter Pu 238 mass fraction 0.01
o Enter Pu 239 mass fraction 0.92
+ Enter Pu 240 mass fraction -0.05
+ Enter Pu 241 mass fraction 0.015 )
o Enter Pu 242 mass fraction 0.005.

2) Click on OK.

Expected Results
"Fraction must be in the range 0 to 1." dialog is displayed.

Pass/F ail Criteria .
Test passes if error.dialog is displayed.
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CC.S5
Purpose .
This test addresses setting the chamber calibration parameters, requirement 3.1.3.3 M.3.
Input Description .

1) In the chamber calibration dialog,
Enter Pu 238 mass fraction 0.1
Enter Pu 239 mass fraction 0.92
Enter Pu 240 mass fraction 0.05
Enter Pu 241 mass fraction 0.015
Enter Pu 242 mass fraction 0.005.
2) Click on OK.

Expected Results
"Sum of fractions greater than..." dialog is displayed.

Pass/Fail Criteria
Test passes if error dialog is displayed.
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10.6 Waste Attributes

10.6.1 Introduction and Description

These tests address choosing a file name, setting container identification, selecting the container
type, selecting the matrix type, and entering the container's the net weight. These elements
constitute the waste attributes.

10.6.2 Special Requirements
The new file dialog will be visible.
10.6.3 Procedure Steps

1) Log in as an operator.

2) Pull down File menu.

3) Select New.

4) The new file dialog is displayed.

= project
[ assaysys

Data Files (*.%)

5) When valid file names are entered for specific tests, clicking on OK will display the
waste attributes dialog.

~
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C EPROJECT‘ASSAYSYS%DAC\F‘ROD\X 001

10.6.4 Valid Test Cases

WA.I
Purpose
This test addresses setting the waste attributes, which include file name, container identification,
matrix type, and container net weight, requirements 3.1.4.2 M.1 and M.3 and 3.1.4.3 M.1 and
M.3. This test is particularly aimed at testing valid file names.
Input Description
1) Inthe new file dialog, enter file name WA_1.
2) Click on OK.
3) In the waste attributes dialog,
e Select 55 gallon drum for the container type
e Select matrix type 152
e Enter net weight 6.0.
4) Click on Assay (do not select an Assay type).
5) Click on Close.
Expected Results
File name is accepted and becomes the identification in the waste attributes dialog; waste
attributes appear in the dialog box.
Pass/Fail Criteria
Test passes if the waste attributes dialog contains the attributes that were input.

WA.2
Purpose
This test addresses setting the waste attnbutes which include file name, container identification,
matrix type, and container net weight, requirements 3.1.4.2 M.1 and M.3 and 3.1.4.3 M.1 and
M.3. This test is particularly aimed at testing valid file names.
Input Description
1) In the new file dialog, enter file name 999999.
2) Click on OK.
3) In the waste attributes dialog,
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e Select 55 gallon drum for the container type
e Select matrix type 152
e Enter net weight 6.0.
4) Click on Assay (do not select an Assay type).
5) Click on Close.
Expected Results )
File name is accepted and becomes the identification in the waste attributes dialog; waste
attributes appear in the dialog box.
Pass/Fail Criteria
Test passes if the waste attributes dialog contains the attributes that were input.

WA.3
Purpose
This test addresses setting the waste attributes, which include file name, container identification,
matrix type, and container net weight, requirements 3.1.4.2 M.1 and M.3 and 3.1.4.3 M.1 and
M.3. This test is particularly aimed at testing valid file names.
Input Description
1) Inthe new file dialog, enter file name $&$##H#.
2) Click on OK.
3) In the waste attributes dialog, :
e Select 55 gallon drum for the container type
e Select matrix type 152
¢ Enter net weight 6.0.
4) Click on Assay (do not select an Assay type).
5) Click on Close.
Expected Results
File name is accepted and becomes the identification in the waste attributes dialog; waste
attributes appear in the dialog box.
Pass/Fail Criteria
Test passes if the waste attributes dialog contains the attributes that were input.

WA.4-WA.7
Purpose
This test addresses setting the waste attributes, which include file name, container identification,
matrix type, and container net weight, requirements 3.1.4.2 M.1 and M.3, 3.1.4.3 M.1 and M.3,
and SCR User Interface Problems, Item 3. These tests are particularly aimed at testing valid
matrix types.
Input Description
For each test case in Table 6,
1) In the new file dialog, enter the file name using the identification name from the table.
2) Click on OK.
3) In the waste attributes dialog, using the values from the table,
e Select container type -
e Select matrix type
o Enter net weight.
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4) Click on Assay (do not select an Assay type).
5) Click on Close.

Expected Results _
File name is accepted and becomes the identification in the waste attributes dialog; waste

attributes appear in the dialog box. The matrix type displayed initially should be the same matrix
type as was used in each previous test.

Pass/Fail Criteria
Test passes if the waste attributes dialog contains the attributes that were input, and if the matrix

type displayed initially is the same matrix type as was used in each previous test.

Table 6. Waste attribute input, valid test cases.

Identification Container type Matrix code Net weight
WA_4 55 gallon drum 0 10
WA_S 55 gallon drum 152 70
WA_6 55 gallon drum 292 80
WA_7 55 gallon drum 320 110
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WA.8
Purpose )
This test addresses setting the waste attributes, which include file name, container identification,
matrix type, and container net weight, requirements 3.1.4.2 M.1 and M.3, and 3.1.4.3 M.1 and
M.3; it also addresses SCR User Interface Problems, Item 1. This test is particularly aimed at
testing starting a new assay from the Run menu rather than the File menu.
Input Description
1) Log in as an operator.
2) Pull down Run menu.
3) Select New Assay.
4) The new file dialog is displayed.

b

£ project
(= assaysys

g
g

T 4y 4d

5) When valid file names are entered for specific tests, clicking on OK will display the
waste attributes dialog.
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Expected Results
File name is accepted and becomes the identification in the waste attributes dialog; waste

attributes appear in the dialog box.

Pass/Fail Criteria
This test passes if files can be opened successfully.

WA.9
Purpose3
This test addresses switching between "Waste," "Active," "Passive” and "Results" windows, SCR
User Interface Problems, ftem 1. The PAN system must be functioning for this test.
Input Description
1) In the new file dialog, enter file name WA_9.
2) Click on OK.
3) In the waste attributes dialog,
e Select 55 gallon drum for the container type
e Select matrix type 152
e Enter net weight 6.0.
4) Click on Assay.
5) Select Full.
6) If a warning about no current background appears, select Yes to continue.
7) Wait for the assay to complete (this may take several minutes).
8) Switch between the "Waste," "Active," "Passive” and "Results” windows by clicking
the mouse within any visible part of the target window.
9) Click on Close (in the "Results" window).
Expected Results
Any window can be viewed by clicking the mouse within any visible part of the window.
Pass/Fail Criteria
Test passes if all windows can be viewed by clicking the mouse within any visible part of the
window.
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10.6.5 Invalid Test Cases

WA.10

Purpose
This test addresses setting the waste attributes, which include file name, container identification,
matrix type, and container net weight, requirements 3.1.4.2 M.1 and 3.1.4.3 M.1. This test is
particularly aimed at testing invalid file names.

Input Description
In the new file dialog, click on OK without selecting (or entering) a file name.

Expected Results
The new file dialog remains displayed.

Pass/Fail Criteria
Test passes if the new file dialog remains displayed.

WA.11
Purpose
This test addresses setting the waste attributes, which include file name, container identification,
matrix type, and container net weight, requirements 3.1.4.2 M.1 and 3.1.4.3 M.1. This test is
particularly aimed at testing invalid file names.
Input Description
In the new file dialog, enter file name *.001.
Expected Results
The new file dialog remains displayed; the file list is updated to show only files with the suffix
".001," if any exist. If no files match this criteria, then the list will be empty.
Pass/Fail Criteria
Test passes if the new file dialog remains displayed as described.

WA.I2

Puip(;se
This test addresses setting the waste attributes, which include file name, container identification,
matrix type, and container net weight, requirements 3.1.4.2 M.1 and 3.1.4.3 M.1. This test is
particularly aimed at testing invalid file names.

Input Description
In the new file dialog, enter file name ?.001.

Expected Results
The new file dialog remains displayed; the file list is updated to show only files with a single
character prefix and the suffix ".001," if any exist. If no files match this criteria, then the list will
be empty.

Pass/F ail Criteria
Test passes if the new file dialog remains displayed as described.
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WA.I3
Purpose
This test addresses setting the waste attributes, which include file name, container identification,
matrix type, and container net weight, requirements 3.1.4.2 M.1 and 3.1.4.3 M.1. This test is
particularly aimed at testing invalid file names.
Input Description
In the new file dialog, enter file name (blanks).
Expected Resulls .
The new file dialog remains displayed.
Pass/Fail Criteria
Test passes if the new file dialog remains displayed.

WA.14
Purpose - )
This test addresses setting the waste attributes, which include file name, container identification,
matrix type, and container net weight, requirements 3.1.4.2 M.1 and 3.1.4.3 M.1. This test is
particularly aimed at testing invalid file names.
Input Description
In the new file dialog, enter a file name consisting of more than eight characters.

Expected Results
"An invalid file name was specified” dialog is displayed.

File Name for New Assay

Pass/Fail Criteria
Test passes if the error dialog is displayed.
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WA.15
Purpose
This test addresses setting the waste attributes, which include file name, container identification,
matrix type, and container net weight, requirements 3.1.4.2 M.1 and 3.1.4.3 M.1. This test is
particularly aimed at testing when there is no net weight value entered.
Input Description |
1) Inthe new file dialog, enter the file name WA_15.
2) Click on OK.
3) Inthe waste attributes dialog, click on Assay.
Expected Results
"Weight must be > 0" dialog is displayed.

| Input Error

Pass/Fail Criteria
Test passes if error dialog is displayed.

WA.16
Purpose
This test addresses setting the waste attributes, which include file name, container identification,
matrix type, and container net weight, requirements 3.1.4.2 M.1 and 3.1.4.3 M.1. This testis
particularly aimed at testing net weights that are too small.
Input Description
1) Inthe new file dialog, enter file name WA_16.
2) Click on OK.
3) In the waste attributes dialog,
+ Select 55 gallon drum for the container type
e Select matrix type 152 for the matrix type
e Enter net weight 0.
4) Click on Assay.
Expected Results
"Weight must be > 0" dialog is displayed.
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Pass/Fail Criteria
Test passes if error dialog is displayed.

WA.17

Purpose
This test addresses setting the waste attributes, which include file name, container identification,
matrix type, and container net weight, requirements 3.1.4.2 M.1 and 3.1.4.3 M.1. This test is
particularly aiméd at testing negative net weights.
Input Description
1) In the new file dialog, enter file name WA_17.
2) Click on OK.
3) Inthe waste attributes dialog,
e Select 55 gallon drum for the container type
e Select matrix type 152 for the matrix type
e Enter net weight -10.
4) Click on Assay.

Expected Results
"Weight must be > 0" dialog is displayed.

Pass/Fail Criteria
Test passes if error dialog is displayed.
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WA.18
Purpose :
This test addresses setting the waste attributes, which include file name, container identification,
matrix type, and container net weight, requirements 3.1.4.2 M.1 and 3.1.4.3 M.1. This test is
particularly aimed at testihg non-numeric data in the net weight field.
Input Description ) .
1) Inthe new file dialog, enter file name WA_18.
2) Click on OK. .
3) In the waste attributes dialog,
e Select 55 gallon drum for the container type
e Select matrix type 152 for the matrix type
e Enter net weight $$$.$3.
4) Click on Assay.
Expected Results .
"Weight must be > 0" dialog is displayed

Pass/Fail Criteria
Test passes if error dialog is displayed.
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WA.19
Purpose
This test addresses the requirement to input the container information, requirements 3.1.4.2 M.1
and 3.1.4.3 M.1. This test is particularly aimed at testing net weight values that are too large.
Input Description
1) Inthe new file dialog, enter file name WA_19.
2) Click on OK.
3) In the waste attributes dialog,
e Select 55 gallon drum for the container type
e Select matrix type 152 for the matrix type
e Enter net weight 999999.99.
4) Click on Continue.
Expected Results
"Weight seems excessive" dialog is displayed.

Pass/Fail Criteria
Test passes if wamning dialog is displayed.
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10.7 Toggle Switches

10.7.1 Introduction and Description

10.7.2 Special Requirements

10.7.3 Procedure Steps

Open File for Recalculation

actcrate.dac (= projects

backgrnd = swepp
= demo
[ sas

options.dac i dac
pascrate_dac backg

1) Log in as an operator or physicist, as specified in the test case.
2) Pull down File menu. : -
3) Select Open.

4) The open file dialog is displayed.

INEL-96/0058

These tests address the options Auto Summary Report, Auto Data Save, and Background
Correction.

The open file dialog will be visible. The file for this test is located in the NDAC subdirectory of
the assay system root directory.
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10.7.4 Valid Test Cases

18.1
Purpose
This test addresses the Auto Summary Report and Auto Data Save options, requirements 3.1.3.3
M.1 and M.2.
Input Description

1) Log in as an operator.

2) Inthe open file dialog, change to the DAC subdirectory and select the file 000496.

3) Click on OK.

4) Pull down the Options menu and verify that Auto Summary Report and Auto Data
Save are checked.

5) Inthe Waste Attributes dialog, click on Continue.

6) Active and passive data dialogs will be displayed. Warning messages regarding the
counts may also be displayed. Acknowledge any such messages. The results dialog will
be displayed.

7) In the results dialog, click on Close.

Expected Results

A summary report should be printed automatically. The report identifies date and time of the -
background data acquisition.

Pass/Fail Criteria :
The test passes if the above summary report is printed as described.

Purpose

78.2

This test addresses Auto Summary Report toggling, requirements 3.1.3.3 M.1 and M.2.
Input Description

1)
2)
3)
. 4)
5)
6)

7)

Log in as an operator.

Pull down the Options menu and ensure that Auto Summary Report is toggled off.

In the open file dialog, change to the DAC subdirectory and select the file 000496.
Click on OK.

In the Waste Attributes dialog, click on Continue.

Active and passive data dialogs will be displayed. Warning messages regarding the
counts may also be displayed. Acknowledge any such messages. The results dialog will
be displayed.

In the results dialog, click on Close.

Expected Results

No hardcopy summary report should appear.
Pass/Fail Criteria

Test passes if the summary report is not printed.
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78.3
Purpose
This test addresses the Auto Summary Report and Background Correction options, requirements
3.133M.1and M.2. .
Input Description

1) Login as a physicist.

2) In the open file dialog, change to the DAC subdlrectory and select the file 000496.

3) Click on OK.

4) Pull down the Options menu and verify that both Auto Summary Report and
Background Correction are toggled on.

5) Inthe Waste Attributes dialog, click on Continue.

6) Active and passive data dialogs will be displayed. Warning messages regarding the
counts may also be displayed. Acknowledge any such messages. The results dialog will
be displayed. :

7) In the results dialog, click on Close.

Expected Results
A summary report should be printed automatically. The report identifies date and time of the
background data acquisition.

Pass/Fail Criteria
The test passes if the above summary report is printed as described.

T84
Purpose
This test addresses Auto Summary Report toggling, requirements 3.1.3.3 M.1 and M.2.
Input Description

1) Login as a physicist.

2) Pull down the Options menu and ensure that Auto Summary Report is toggled off.

3) In the open file dialog, change to the DAC subdlrectory and select the file 000496.

4) Click on OK.

5) Inthe Waste Attributes dialog, click on Continue.

6) Active and passive data dialogs will be displayed. Warning messages regarding the
counts may also be displayed. Acknowledge any such messages. The results dlalog will
be displayed.

7) Inthe results dialog, click on Close.

Expected Results

No hardcopy summary report should appear.
Pass/Fail Criteria

Test passes if the summary report is not printed.
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T8.5
Purpose
This test addresses Background Correction toggling, requirements 3.1.3.3 M.1 and M.2.
Input Description ‘

1) Log in as a physicist.

2) Pull down the Options menu and ensure that Auto Summary Report is toggled on and
Background Correction is toggled off.

3) Inthe open file dialog, change to the DAC subdirectory and select the file 000496.

4) Click on OK.

5) Inthe Waste Attributes dialog, click on Continue.

6) Acfive and passive data dialogs will be displayed. Warning messages regarding the
counts may also be displayed. Acknowledge any such messages. The results dialog
will be displayed.

7) Inthe results dialog, click on Close.

Expected Results
A summary report should be automatically printed. The report indicates that the background
correction was not applied.

Pass/Fail Criteria
The test passes if the summary report is printed as described.

10.7.5 Invalid Test Cases

None.
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10.8 Chamber Operation Parameters

10.8.1 Introduction and Description

These tests address the capability to modify the active pulse count limits and passive count time

10.8.2 Special Requirements
The CAMAC crate must be on-line.
10.8.3 Procedure Steps
1) Log in as an operator.
2) Pull down the Options menu.
3) If not checked, select Auto Summary Report to toggle on.

4) Pull down the Options menu and select Assay Times.
5) The chamber operation parameters dialog is displayed.
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10.8.4 Valid Test Cases

CP.1
Purpose
This test addresses setting the background count time limit, requirements 3.1.3.3 M.1 and M.2,
and acquiring and storing passive background data, requirements 3.1.3.4 M.6 and M.7.
Input Description
1) Inthe chamber operation parameters dialog, enter the background count time of
10 sec.
2) Click on OK.
3) Pull down the Run menu and select Background.
4) Wait until the acquisition is completed normally.
5) Press Accept button in the passive background data dialog.
6) Pull down the File menu and select Print.
7) Select the file name BACKGRND from the DAC directory.
8) Click on OK.
Expected Results
The background data file should be printed. The counts from the 10 kHz clock (port 4, station 11
for the drum assay chamber) should be between 100,000 and 102,000 units.
Pass/Fail Criteria
Test passes if the background data file is printed as described.

CP.2
Purpose
This test addresses setting the background count time limit, requirements 3.1.3.3 M.1 and M.2,
and acquiring and storing passive background data, requirements 3.1.3.4 M.6 and M.7.
Input Description
1) Inthe chamber operation parameters dialog, enter the background count time of 300.
2) Click on OK.
3) Pull down the Run menu and select Background.
4) After the acquisition has started, in the acquisition dialog, click on Cancel.
Expected Results
The acquisition is canceled and the system returns to the operator menu bar.

Pass/Fail Criteria
Test passes if the Run menu item is enabled in the menu bar.

CP.3
Purpose
This test addresses setting the background count time limit, requirements 3.1.3.3 M.1 and M.2,
and acquiring and storing passive background data, requirements 3.1.3.4 M.6 and M.7.
Input Description
1) Inthe chamber operation parameters dialog, enter the background count time of 200.
2) Click on OK.
3) Pull down the Run menu and select Background.
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5) Press Accept button in passive background data dialog.
6) Pull down the File menu and select Print.
7) Select the file name BACKGRND from the DAC directory.
8) Click on OK.
Expected Results
The background data file should be printed. The counts from the 10 kHz clock (port 4, station 11
for the drum assay chamber) should be between 2,000,000 and 2,002,000.

Pass/Fail Criteria
Test passes if the background data file is printed as described.

CP4
Purpose
This test addresses setting the active pulse count limit and passive count time limit for verification,
requirements 3.1.3.3 M.1 and M.2.. It also covers acquiring active and passive data, requirements
3.1.3.4 M.3 and M.6, and storing the data, requirements 3.1.3.4 M.4 and M.7.
Input Description

1) In the chamber operation parameters dialog,
¢ Enter passive count time for verification of 10
¢ Enter active pulse count for verification of 100 (this must also be manually entered

in the neutron generator control panel).

2) Click on OK.

3) Select Yes.

4) Click on OK.

5) Pull down the Run menu and select Verification.

6) Wait until both the active and the passive acquisitions are completed normally.

7) Active and passive data dialogs will be displayed. Warning messages regarding the
counts may also be displayed. Acknowledge any such messages. The results dialog
will be displayed.

8) If the Auto Data Save box is selected in the Options menu the results will be
automatically saved; otherwise, in the results dialog, click on Save.

9) Click on Close.

10) Pull down the File menu and select Print.

11) Select the file name 000496 from the DAC directory.

12) Click on OK.

Expected Results
The verification data file should be printed. The counts from the 10 kHz clock (port 4, station 11
for the drum assay chamber) should be between 100,000 and 102,000. The counts for the active
pulse (port 6, station 11 for the drum assay chamber) should be exactly 100.

Pass/Fail Criteria
Test passes if the verification data file is printed as described.
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CP.5

Purpose
This test addresses setting the active pulse count limit and passive count time limit for verification,
requirements 3.1.3.3 M.1 and M.2. It also covers acquiring active and passive data, requirements
3.1.3.4 M.3 and M.6, and storing the data, requirements 3.1.3.4 M.4 and M.7.

Input Description .

1)

2)

3)
4)

5)
6)
7)

8)
9)

In the chamber operation parameters dialog,

o Enter passive count time for verification of 200

o Enter active pulse count for verification of 2,000.

Click on OK.

Pull down the Run menu and select Verification.

Wait until both the active and the passive acquisitions are completed normally.
Active and passive data dialogs will be displayed. Warning messages regarding the
counts may also be displayed. Acknowledge any such messages. The results dialog will
be displayed. '

If the Auto Data Save box is selected in the Options menu the results will be
automatically saved; otherwise, in the results dialog, click on Save.

Click on Close.

Pull down the File menu and select Print.

Select the file name 000496 from the DAC directory.

10) Click on OK.
Expected Results
The verification data file should be printed. The counts from the 10 kHz clock (port 4, station 11
for the drum assay chamber) should be between 2,000,000 and 2,002,000. The counts for the
active pulse (port 6, station 11 for the drum assay chamber) should be exactly 2,000.
Pass/Fail Criteria
Test passes if the verification data file is printed as described.

Purpose

CP.6

This test addresses setting the active pulse count limit and passive count time limit for production,
requirements 3.1.3.3 M.1 and M.2. It also covers acquiring active and passive data, requirements
3.1.3.4 M.3 and M.6, and storing the data, requirements 3.1.3.4 M.4 and M.7.

Input Description

1))

2)
3)
4)
5)
6)
7)
8)

In the chamber operation parameters dialog,

o Enter passive count time for production of 10
o Enter active pulse count for production of 100.
Click on OK.

Click on Yes.

Click on OK.

Pull down the File menu and select New.

In the new file dialog, enter file name CP_6.
Click on OK.

In the waste attributes dialog,

e Select 55-gallon drum for the container type
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e Select matrix type 152
. Enter net weight 6.0.
9) Click on Assay.
10) Select Full.
11) Wait until both the active and the passive acquisitions are completed normally
12) Active and passive data dialogs will be displayed. Warning messages regarding the
counts may also be displayed. Acknowledge any such messages. The results dialog
will be displayed.
13) If the Auto Data Save box i is selected in the Options menu the results will be
automatically saved; otherwise, click on Save.
14) Click on Close.
15) Pull down the File menu and select Prmt
16) Select file name CP_6.001.
17) Click on OK.
Expected Results
The summary report and the production data file should be printed. The counts from the 10 kHz
clock (port 4, station 11 for the drum assay chamber) should be between 100,000 and 102,000.
The counts for the active pulse (port 6, station 11 for the drum assay chamber) should be exactly
100.
Pass/Fail Criteria
Test passes if the production data file is printed as described.
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CP.7
Purpose .
This test addresses setting the active pulse count limit and passive count time limit for production,
requirements 3.1.3.3 M.1 and M.2. It also covers acquiring active and passive data, requirements
3.1.3.4 M.3 and M.6, and storing the data, requirements 3.1.3.4 M.4 and M.7.
Input Description
1) Inthe ¢hamber operation parameters dialog,

e Enter passive count time for production of 300

e Enter active pulse count for production of 5,000.

2) Click on OK.

3) Click on Yes.

4) Click on OK.

5) Pull down the File menu and select New.

6) In the new file dialog, enter file name CP_7.

7) Click on OK.

8) In the waste attributes dialog,

e Select 55-gallon drum for the container type
o Select matrix type 152
e Enter net weight 6.0.

9) Click on Assay.

10) Select Full.

11) Wait until both the active and the passive acquisitions are completed normally.

12) Active and passive data dialogs will be displayed. Warning messages regarding the
counts may also be displayed. Acknowledge any such messages. The results dialog
will be displayed. '

13) If the Auto Data Save box is selected in the Options menu the results will be
automatically saved; otherwise, click on Save.

14) Click on Close.

15) Pull down the File menu and select Print.

16) Select file name CP_7.001.

17) Click on OK..:

Expected Results
The production data file should be printed. The counts from the 10 kHz clock (port 4, station 11
for the drum assay chamber) should be between 3,000,000 and 3,002,000. The counts for the
active pulse (port 6, station 11 for the drum assay chamber) should be exactly 5,000.

Pass/Fail Criteria
Test passes if the production data file is printed as described.
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10.8.5 Imvalid Test Cases

cpP.8

Purpose
This test addresses setting the chamber operation parameters . This test is against requirement
3.1.33M.1.

Special Regquirements
Exit from the assay system. Rename the OPTIONS.DAC file in the DAC subdirectory to
OPTIONS.BAK. At the conclusion of the this test, rename the OPTIONS.BAK file to
OPTIONS.DAC.

Input Descriptidn }
Log in to the assay system as either an operator or physicist.

Expected Resulfs
"File not found" dialog is displayed,

issing Data




INEL-96/0058

Pass/Fail Criteria
The test passes if the error dialog is displayed.

CcP.9

Purpose
This test addresses setting the background count time to invalid values. This test is against

requirement 3.1.3.3 M.2.
Input Description
1) In the chamber operation parameters dialog, enter background count time 0.
2) Click on OK.
Expected Results
"Values must be > 0" dialog is displayed.

Pass/Fail Criteria
The test passes if the error dialog is displayed.

CP.10

Purpose
This test addresses setting the background count time to invalid values. This test is against

requirement 3.1.3.3 M.2.
Input Description
1) In the chamber operation parameters dialog, enter background count time -10.
2) Click on OK. ' ’

Expected Results
"Values must be > 0" dialog is displayed.

Pass/Fail Criteria
The test passes if the error dialog is displayed.
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: CP.11
Purpose
This test addresses setting the background count time to invalid values. This test is against
requirement 3.1.3.3 M.2.
Input Description )
1) Inthe chamber operation parameters dialog, enter background count time 6,000.
2) Click on OK.

Expected Results
"Count time(s) exceed one hour ..." warning dialog is displayed.

%
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Pass/Fail Criteria .
The test passes if the error dialog is displayed.

CP.12
Purpose
This test addresses setting the active pulse count for verification to invalid values. This test is
against requirement 3.1.3.3 M.2.
Input Description
1) Inthe chamber operation parameters dialog, enter active pulse count for
verification 0.
2) Click on OK.
Expected Results
"Values must be > 0

dialog is displayed.

Pass/Fail Criteria
The test passes if the error dialog is displayed.
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CP.13

Purpose
This test addresses setting the active pulse count for verification to invalid values. This test is
against requirement 3.1.3.3 M.2.

Input Description

1) Inthe chamber operation parameters dialog, enter active pulse count for
' verification -10.
2) Click on OK.

Expected Results

"Values must be > 0" dialog is displayed.

Pass/Fail Criteria
The test passes if the error dialog is displayed.

CP.14

Purpose
This test addresses setting the active pulse count for verification to invalid values. This test is
against requirement 3.1.3.3 M.2. :

Input Description
In the chamber operation parameters dialog, attempt to enter more that six digits in the active
pulse count for verification field.

Expected Results
No more than six digits may be entered.

Pass/Fail Criteria
Test passes if no more than six digits can be entered.
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CP.15
Purpose

This test addresses setting the active pulse count for production to invalid values. This test is
Input Description.
Input Description

Expected Results

1) Inthe chamber operation parameters dialog, enter active pulse count for production 0.
2) Click on OK.
"Values must be > 0" dialog is displayed.
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Pass/Fail Criteria

The test passes if the error dialog is displayed.

CP.16
Purpose

This test addresses setting the active pulse count for production to invalid values. This test is
against requirement 3.1.3.3 M.2.
Input Description
1) Inthe chamber operation parameters dialog, enter active pulse count for
production  -10. -
2) Click on OK.
Expected Results

"Values must be > 0" dialog is displayed.

s
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Pass/Fail Criteria

The test passes if the error dialog is displayed.
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CP.17

Purpose
This test addresses setting the active pulse count for production to values that are too large. This
test is against requirement 3.1.3.3 M.2.

Input Description :
In the chamber operation parameters dialog, attempt to enter more that six digits in the active
pulse count for production field.

Expected Results
No more than six digits may be entered.

Pass/Fail Criteria
Test passes if no more than six digits can be entered.

t

CP.18
Purpose
This test addresses setting the passive count time for verification to invalid values. This test is
against requirement 3.1.3.3 M.2.
Input Description
1) Inthe chamber operation parameters dialog, enter passive count time for
verification 0.
2) Click on OK.
Expected Results
"Values must be > 0" dialog is displayed.

Pass/Fail Criteria
The test passes if the error dialog is displayed.

CP.19
Purpose
This test addresses setting the passive count time for verification to invalid values. This test is
against requirement 3.1.3.3 M.2.
Input Description
1) Inthe chamber operation parameters dialog, enter passive count time for
verification -10.
2) Click on OK.
Expected Results
"Values must be > 0" dialog is displayed.
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Pass/Fail Criteria
The test passes if the error dialog is displayed.

CP.20
Purpose
This test addresses setting the passive count time for verification to values that are too large. This ‘
test is against requirement 3.1.3.3 M.2. :
Input Description :
1) Inthe chamber operation parameters dialog, enter passive count time for
verification 9999.
2) Click on OK. :
Expected Results
"Count time(s) exceed one hour ..." dialog is displayed.

YWarning

080000000000

s
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Pass/Fail Criteria
The test passes if the error dialog is displayed.

CP.21
Purpose
This test addresses setting the passive count time for production to invalid values. This test is
against requirement 3.1.3.3 M.2.
Input Description
1) Inthe chamber operation parameters dialog, enter passive count time for
production 0. ‘
2) Click on OK. :
Expected Results
"Values must be > 0" dialog is displayed.
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Entry Error

Pass/Fail Criteria
The test passes if the error dialog is displayed.

CP.22
Purpose
This test addresses setting the passive count time for production to invalid values. This test is
against requirement 3.1.3.3 M.2.
Input Description
1) Inthe chamber operation parameters dialog, enter passive count time for
production -10.
2) Click on OK.
Expected Results
"Values must be > 0" dialog is displayed. -

Pass/Fail Criteria
The test passes if the error dialog is displayed.
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10.9 CAMAUC Interface

10.9.1 Introduction and Description

These tests address whether the CAMAC configuration files are available to SAS and whether the
CAMAC system is operational.

10.9.2 Special Requirements

Auto Summary Report must be enabled. The default processing options, active pulse counts and
passive count time, must be enabled. The CAMAC crate must be on-line.

10.9.3 Procedure Steps
Log in as an operator.

10.9.4 Valid Test Cases

CL1
Purpose :
This test evaluates the SAS interface with the CAMAC system, requirement 3.1.3.4 M.1 and SCR
Requested Enhancements, problem 4.
Input Description
1) Pull down the File menu and select New.
2) Inthe new file dialog, enter file name CI_1.
3) Click on OK.
4) Inthe waste attributes dialog, -

e Select 55-gallon drum for the container type
e Select matrix type 152

e Enter net weight 6.0.

5) Click on Assay.

6) Select Full.

7) Wait until both the active and the passive acquisitions are completed normally.

8) Active and passive data dialogs will be displayed. Warning messages regarding the
counts may also be displayed. Acknowledge any such messages. The results dialog
will be displayed.

9) Ifthe Auto Data Save box is selected in the Options menu the results will be
automatically saved; otherwise, click on Save.

10) Click on Close.

11) Pull down the File menu and select Print.

12) In the print file dialog, enter file name CI_1.001.

13) Click on OK.
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Expected Results
A summary report will be automatically printed. The saved file will be printed when the print file
option is completed.

Pass/Fail Criteria
The test passes if a summary report is printed, and if the save file is printed and all sections are
present in the printout. The sections which should be present are:

- 1) A header section listing file creation date, program ID and file ID.
2) CHAMBER.
3) CONTAINER.
4) MATRIX.
5) PU_MASS_FRACTIONS.
6) An "Active" data.
7) A "Passive Gross".
8) A "Passive Background".
9) A "Chamber Configuration Parameters".
10) A "Net Active Count Rates".
11) A "Net Passive Count Rates".
12) A "Active/Passive Mass Values".
13) A "Reported Mass Values".
14) A "Derived Quantities".
15) A "Calculated Matrix Corrections".
16) A "Recalculated Mass Values".
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10.9.5 Invalid Test Cases

CL2

Purpose
This test evaluates the SAS interface with CAMAC, when power to the CAMAC is not available,
requirement 3.1.3.4 M.1.

Special Requirements
Switch off the power to the CAMAC crate. At the conclusion of this test, switch on the power to
the CAMAC crate.
Input Description
1) Pull down the File menu and select New.
2) Inthe new file dialog, enter file name CI_2.
3) Click on OK.
4) In the waste attributes dialog,
o Select 55-gallon drum for the container type
e Select matrix type 152
e Enter net weight 6.0.
5) Click on Assay.
6) Select Full.

Expected Results
"Check CAMAC crate power ..." dialog is displayed.

Pass/Fail Criteria
The test passes if the error dialog is displayed.

CL3

Purpose
This test evaluates the SAS interface with the CAMAC system when the CAMAC crate

configuration file is not available, requirement 3.1.3.4 M.1.
Special Requirements

Log out from the system. Rename ACTCRATE.DAC in the DAC subdirectory to
ACTCRATE.BAK. Log in to the system as either an operator or a physicist. At the conclusion
of this test, log out from the system and rename ACTCRATE.BAK to ACTCRATE.DAC.
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Input Description

Pull down the File menu and select New.

) In the new file dialog, enter file name CI_3.

) Click on OK.

) In the waste attributes dialog,
e Select 55-gallon drum for the container type
e Select matrix type 152 -
e Enter net weight 6.0.

5) Click on Assay.

6) Select Active.

Expected Results
"Active CAMAC crate configuration file not found" dialog is displayed.

DWW N -

Pass/Fail Criteria
The test passes if the error dialog is displayed.
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ClL4
Purpose
This test evaluates the SAS interface with the CAMAC system when the CAMAC crate
configuration file is not available, requirement 3.1.3.4 M.1.
Special Requirements
Log out from the system. Rename PASCRATE.DAC in the DAC subdirectory to
PASCRATE.BAK. Log in to the system as either an operator or a physicist. At the conclusion
of this test, log out from the system and rename PASCRATE.BAK to PASCRATE.DAC.
Input Description
1) Pull down the File menu and select New.
2) Inthe new file dialog, enter file name CI_4.
3) Click on OK.
4) Inthe waste attributes dialog,
e Select 55-gallon drum for the container type
& Select matrix type 152

e Enter net weight 6.0.
5) Click on Assay.
6) Select Passive.
Expected Results
"Passive CAMAC crate configuration file not found" dialog is displayed.

Pass/Fail Criteria
The test passes if the error dialog is displayed.
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CL5
Purpose
This test evaluates the SAS interface with the CAMAC system when the controller is not
available, requirement 3.1.3.4 M. 1.
Special Requirements
The CAMAC crate power must be on. The configuration filess ACTCRATE DAC and
PASCRATE.DAC must be available. The GPIB controller cable connection from the PC to the
CAMAC crate must be disconnected.
Input Description
1) Pull down the File menu and select New.
2) In the new file dialog, enter file name CI_5. :
3) Click on OK.
4) Inthe waste attributes dialog,
e Select 55-gallon drum for the container type
® Select matrix type 152

e Enter net weight 6.0.
5) Click on Assay.
6) Select Full.

Expected Results
"Check CAMAC crate power ..." dialog is displayed.

CAMAC Error

Pass/Fail Criteria
The test passes if the error dialog is displayed.
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10.10 Time and Date of Data Acquisition

10.10.1 Introduction and Description

These tests address the time and date for the active and passive data acquisition.
10.10.2 Special Requirements

The CAMAC crate must be on-line. Auto Summary Report must be enabled.
10.10.3 Procedure Steps

Log in as an operator.

10.10.4 Valid Test Cases

TDDA.1
Purpose
This test addresses the acquisition of active data, time and date of the acquisition, and storing the
active data on file, as specified by requirement 3.1.3.4 M.2, 3.1.4.2 M 4, and 3.1.4.3 M.27.
Input Description
1) Pull down the File menu and select New.
2) Inthe new file dialog, enter file name TDDA_1.
3) Click on OK.
4) Inthe waste attributes dialog,

o Select 55-gallon drum for the container type
e Select matrix type 152

e Enter net weight 6.0.

5) Click on Assay.

6) Select Active.

7) Using the "clock" window in the lower right-hand corner of the screen, note time in

hours, minutes, and seconds when Active was selected.

8) Wait until the acquisition is completed normally.

9) Select File menu, then click on Save.

10) Click on Close.

11) Pull down the File menu and select Print.

12) In the print file dialog, enter file name TDDA._1.001.

13) Click on OK.

Expected Results

The summary report for TDDA_1 will be printed. The time of active data acquisition on the
report should be within 10 seconds of the noted computer clock time. The saved file will be
printed when the print file option is completed.
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Pass/Fail Criteria
The test passes if a summary report is printed, and if the save file is printed and all sections are
present in the printout.

TDDA.2
Purpose
This test addresses the acquisition of passive data, time and date of the acquisition, and storing
the passive data on file, as specified by requirement 3.1.3.4 M.2, 3.1.4.2 M.4, and 3.1.4.3 M.27.
Input Description .
1) Pull down the File menu and select New.
2) Inthe new file dialog, enter file name TDDA 2.
3) Click on OK.
4) Inthe waste attributes dialog,

e Select 55 gallon drum for the container type
e Select matrix type 152

e Enter net weight 6.0.
5) Click on Assay.
6) Select Passive.
7) Using the "clock" window in the lower right-hand corner of the screen, note time in
hours, minutes, and seconds when Passive was selected.
8) Wait until the acquisition is completed normally.
9) Select File menu, then click on Save.
10) Click on Close.
11) Select File menu, select Print, then enter TDDA 2.001.
Expected Results
The summary report for TDDA_2 will be printed. The time of passive data acquisition on the
report should be within 10 seconds of the noted computer clock time.
Pass/Fail Criteria
This test passes if the summary report appears as indicated.

10.10.5 Invalid Test Cases

None.
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10.11 Passive Signals

10.11.1 Introduction and Description

These tests address the calculation of the passive shielded total, system total, system coincidence,
and shielded coincidence rates and errors. \

10.11.2 Special Requirements

Ensure that Auto Summary Report is enabled. The files needed for these tests should be located
in the \DAC\TEST subdirectory of the assay system root directory.

10.11.3 Procedure Steps
Log in as an operator or physicist, as specified.

10.11.4 Valid Test Cases

PS.1
Purpose
This test addresses passive data acquisition and reduction, requirements 3.1.3.4 M.8, and 3.1.3.6
M.1 through M.8, and SCR Technical Problems, Item 5.
Input Description

1) Login as an operator.

2) Pull down the File menu and select Open.

3) In the open file dialog, select the file name PS.001.

4) Click on OK.

5) Inthe waste attributes dialog, click on Continue.

6) Active and passive data dialogs will be displayed. Warning messages regarding the
counts may also be displayed. Acknowledge any such messages. The results dialog
will be displayed.

7) In the results dialog, click on Close after evaluating if the responses are different from
the values given below.

8) Pull down the File menu and select Print, then select the file name PS.001.

Expected Results
A warning about too large a variation in side detector counts will appear, and the offending data
field in the "Passive Data" window will be highlighted. The values from hand calculations, using
the formulas provided in the SRS [2], are shown below. These values must be independently
verified.

Shielded total net rate = 9.14 £ 0.22 counts/sec

System total net rate = 37.81 £ 0.49 counts/sec
Shielded coincidence net rate = 0.10 & 0.024 counts/sec
System coincidence net rate =2.01 = 0.11 counts/sec
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Pass/Fail Criteria
The test passes if the expected results are attained.

10.11.5 Invalid Test Cases

PS.2 :
Purpose
This test addresses the handling of invalid passive assay data values, requirements 3.1.3.4 M.8 and
3.1.3.6 M.1 through M.8
Input Description
1) Login as an operator.
2) Pull down the File menu and select Open.
3) Inthe open file dialog, select the file name PS.002.
4) Click on OK.
5) Inthe Waste Attributes dialog, click on Continue.
6) Pull down the File menu and select Close.
Expected Results
"Incomplete Data" dialog is displayed.
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Incomplete Data

Pass/Fail Criteria
This test passes if the informational dialog is displayed.

PS.3

Purpose
This test addresses the handling of invalid passive data values, requirements 3.1.3.4 M.8 and
3.1.3.6 M.1 through M.8.

Input Description

1)
2)
3)
4)
5)
6)
7)
8)
9

Login as a physicist.

Pull down the File menu and select Open.

In the open file dialog, select the file name PS.003.

Click on OK.

In the Waste Attributes dialog, click on Edit.

Select "Use current Chamber & Matrix data.”

Change the matrix type to 300.

In the Waste Attributes dialog, click on Continue.

Active and passive data dialogs will be displayed. Warning messages regarding the
counts may also be displayed. Acknowledge any such messages. The results dialog will
be displayed.

10) In the results dialog, click on Close after evaluating the response. Do not save data.
Expected Results
" Assay results may be..." dialog is displayed.

Warning

Pass/Fail Criteria
This test passes if the warning dialog is displayed.
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PS4
Purpose )
This test addresses the handling of invalid passive assay data values, requirements 3.1.3.4 M.8 and

3.1.3.6 M.1 through M.8.
Input Description

1) Login as an operator.

2) Pull down the File menu and select Open.

3) Inthe open file dialog, select the file name PS.004.

4) Click on OK.

5) Inthe Waste Attributes dialog, click on Continue.

6) Active and passive data dialogs will be displayed. Warning messages regarding the
counts may also be displayed. Acknowledge any such messages. The results dialog will
be displayed.

7) Inthe results dialog, click on Close after evaluating the response.

Expected Results .
"Rate < 0" dialog is displayed.

Pass/Fail Criteria
This test passes if the informational dialog is displayed.
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N

10.12 Active Signals

10.12.1 Introduction and Description

These tests address the calculation of active flux monitor, barrel flux monitor, and shielded total
rates and errors.

10.12.2 Special Requirements

Ensure that Auto Summary Report is enabled. The files needed for these tests should be located
in the \DAC\TEST subdirectory of the assay system root directory.

10.12.3 Procedure Steps

Login as an operator.
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10.12.4 Valid Test Cases

AS.1
Purpose
This test addresses active assay data acquisition and reduction, requirements 3.1.3.4 M.5 and
3.1.3.5 M.1 through M.6, and SCR Technical Problems, Item 5.
Input Description ‘

1) Pull down the File menu and select Open.

2) In the open file dialog, select the file name AS.001.

3) Click on OK.

4) Inthe Waste Attributes dialog, click on Continue.

5) Active and passive data dialogs will be displayed. Warning messages regarding the
counts may also be displayed. Acknowledge any such messages. The results dialog will
be displayed.

6) In the results dialog, click on Close after evaluating the response per active data box
shown below.

Expected Results
The values from hand calculations, using the formulas provided in the SRS [2], are shown below.
These values must be independently verified.

Shielded total net rate = 461.25 =+ 11.00 counts/sec

Flux monitor net rate = 5795.05 + 38.07 counts/sec

Barrel flux monitor net rate = 5794.45 =+ 38.07counts/sec

The active data dialog displays the rates.
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Pass/Fail Criteria
The test passes if the expected results are attained, and the proper number of significant figures

are displayed.
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10.12.5 Invalid Test Cases

AS.2
Purpose
This test addresses the handling of invalid active assay data values, requirements 3.1.3.4 M.5 and
3.1.3.5 M.1 through M.6
Input Description

1) Pull down the File menu and select Open.

2) Inthe open file dialog, select the file name AS.002.

3) Click on OK.

4) Inthe Waste Attributes dialog, click on Continue.

5) Active and passive data dialogs will be displayed. Warning messages regarding the
counts should also be displayed. Acknowledge any such messages. The results dialog
will be displayed.

6) In the results dialog, click on Close after evaluating the response.

Expected Results '
"Very low counts..." dialog is displayed.

VWarning [Active]

" Assay results may be invalid!" dialog is displayed.

Pass/Fail Criteria
This test passes if the warning dialogs are displayed.
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AS.3 .

Purpose
This test addresses the handling of invalid active assay data values, requirements 3.1.3.4 M.5 and
3.1.3.5 M.1 through M.6 : '
Input Description
Pull down the File menu and select Open.
In the Open File dialog, select the file name AS.003.
Click on OK.
In the Waste Attributes dialog, click on Continue.
Active and passive data dialogs will be displayed. Warning messages regarding the
counts should also be displayed. Acknowledge any such messages. The results dialog
will be displayed.
6) In the results dialog, click on Close after evaluating the response.
Expected Results
"Very low counts..." dialog is displayed.
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Pass/Fail Criteria
This test passes if the warning dialogs are displayed.
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10.13 Data Reduction

10.13.1 Introduction and Description

These tests address the computation of active Plutonium mass, active Plutonium mass error,
passive Plutonium mass, passive Plutonium mass error, Americium mass, Americium mass €rror,
thermal power, thermal power error, thermal power density, thermal power density error, total
alpha activity, total alpha activity error, activity concentration error, selection of the total
Plutonium mass and error, individual plutonium isotopic masses (238, 239, 240 and 241), the
mass of 2*U when its presence is indicated by gamma ray measurement results, TRU activity,
TRU activity concentration, total activity, plutonium equivalent curies, and fissile gram
equivalent. These tests will also test the assay recalculation from existing signal data and the
production of the measurement summary.

10.13.2 Special Requirements

Ensure that Auto Summary Report is enabled. The files needed for these tests should be located
in the \DAC\TEST subdirectory of the assay system root directory. Open the file AS.INI located
in the root directory of the assay system root directory and verify that "NEUT2_CONVERSION"
is set to "OFF". :

10.13.3 Procedure Steps

Login as an operator.
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10.13.4 Valid Test Cases

DR.1
Purpose
This test addresses computation of Plutonium and Americium masses, thermal power, thermal
power density, total alpha activity, activity concentration, and the associated errors. This test
addresses the requirements 3.1.4.3 M.5 through M.12 and M.15 through M.26.
Input Description :

1) Pull down the File menu and select Open.

2) Inthe Open File dialog, select the file name DR.001.

3) Click on OK. .

4) Inthe Waste Attributes dialog, click on Continue.

5) Active and passive data dialogs will be displayed. Warning messages regarding the
counts may also be displayed. Acknowledge any such messages. The Results dialog
will be displayed. ‘

6) In the Eesults dialog, click on Close after evaluating the response.

Expected Results
The values from hand calculations, using the formulas provided in the SRS [2], are shown below.
These values must be independently verified.

Total Plutonium mass: (0.3411 +0.0086) g

Pu-238 mass: (4.093 +£0.103)E-5 g

Pu-239 mass: (0.3201 +£0.0081) g

Pu-240 mass: (0.01985 +0.00050) g

Pu-241 mass: (1.160 +0.029)E-3 g

Am-241 mass: (4.833+0.138)E-3 g

Thermal power: (1.354 + 0.026)E-3 Watts

Thermal power density: (1.842 % 0.035)E-4 Watts/ft®
Total activity: (0.1628 +0.0037) Ci

Alpha activity: (0.04218 £ 0.00080) Ci

TRU activity: (0.04218 = 0.00080) Ci

TRU activity concentration: (4.218 & 0.080)E+5 nCi/g
Plutonium Equivalent Curies: (0.04211 = 0.00080) Ci
Fissile Gram Equivalent: (0.3232+0.0082) g

" The summary report is printed and the results dialog displays the values.
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Measurement Results

Total Pu {0.3411 + 0.0086) g [Note 1)
Pu-238 {4.093 +D103JE-5 g . [Note 2]
Pu-239 {0.3201 + 0.0081) o

Pu-240 {0.01985 = 0.00050) g

Pu-241 {1.160 = 0.029)E-3 g

Am-241 4.833 = 0.138]E-3

e
SRR

Thermal Power [1.354 = 0.026)E-3 Watts
Thermal Power Dengity [1.842 = 0.035)E-4 Watts/ft==3
Total Activity {0.1628 + 0.0037) Ci

Alpha Activity {0.04218 £ D.0008D) Ci

TRU Activity {0.04218 + D.00080) Ci

TRU Activity Concentration 4.218 = 0.080)E+5 nCi’g

Pass/Fail Criteria
The test passes if the computed values agree with the hand calculations to two significant decimal
digits.

DR.2
Purpose
This test addresses computation of Plutonium and Americium masses, thermal power, thermal
power density, total alpha activity, activity concentration, and the associated errors. This test
addresses the requirements 3.1.4.3 M.5 through M.12 and M.15 through M.26.
Input Description

1) Login as a physicist.

2) Pull down the File menu and select Open.

3) Inthe Open File dialog, select the file name DR.002.

4) Click on OK.

5) Inthe Waste Attributes dialog, click on Edit.

6) Select "Use Current Chamber & Matrix data."

7) Select matrix type 300.

8) Select Continue.

9) Active and passive data dialogs will be displayed. Warning messages regarding the
counts may also be displayed. Acknowledge any such messages. The Results Dialog
will be displayed.

10) In the Results Dialog, click on Close after evaluating the response. Do not save data.

Expected Results
The values from hand calculations, using the formulas provided in the SRS [2], are shown below.
These values must be independently verified.
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Total Plutonium mass: (3.207 +0.180) g

Pu-238 mass: (4.8+2.6)E-4g

Pu-239 mass: (3.013+0.169) g

Pu-240 mass: (0.1883 £0.103) g

Pu-241 mass: (449+194)E-3 g

Am-241 mass: (449+1.94)E-3 g

Thermal power: (8.03 + 0.50) E-3 Watts

Thermal power density: (1.093 + 0.068)E-3 Watts/ft®
Total activity: (0.72 +0.20) Ci

Alpha activity: (0.2567 +0.0157) Ci

TRU activity: (0.2567 +0.0157) Ci

TRU activity concentration: (2.567 + 0.157)E+6 nCi/g
Pu Equivalent Curies: (0.2559 + 0.0156) Ci

Fissile Gram Equivalent: (3.027+0.170) g

The summary report is printed and the results dialog displays the values.

(3.207 x 0.180) g [Note1]
(4.8 26)E-4 g (Note 2)
(3.013 £ 0.169)

(0.1883 + 0.0103] g

(4.49 = 1.94)E-3 g

4.49 + 1.94)E-3

Thermal Power [8.03 £ 0.50]E-3 Watts
Thermal Power Density {1.093 = 0.068)E-3 Watts/ft==3
Total Activity [0.72 £ 0.20) Ci

= Alpha Activity [0.2567 x 0.0157) Ci

1 TRU Activity {0.2567 £ 0.0157]) Ci
TRU Activit Concentratlon

Pass/Fail Criteria
The test passes if the computed values agree with the hand calculations to two significant decimal

digits.

Important Note
This test uses current matrix, calibration, and mass fraction data rather than the values stored in
the data file DR.002. The assay results may therefore not agree with the values shown above, but
must agree with the hand calculated values.
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10.13.5 Imvalid Test Cases

None.

117




INEL-96/0058
10.14 Chi-Square

10.14.1 Introduction and Description

These tests address the function to compute chi-square statistics, requirement 3.1.3.3 M.4.
10.14.2 Special Requirements .

The CAMAC crate must be on-line. The Pika Drum must be in the drum assay chamber.
10.14.3 Proce&ure Steps

Log in as an operator.

10.14.4 Valid Test Cases

CS.1
Purpose
This test addresses the function to compute chi-square statistics, requirement 3.1.3.3 M.4.
Input Description

1) Pull down the Run menu.
2) Select Chi-square.
3) The following notice is displayed.

4) Click on OK.

5) Wait until the specified number of passive acquisitions are completed normally. The
following dialog will be displayed. Click on OK. (The values shown in this dialog box
are sample values only -- numbers in actual tests may be different.)
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Expected Results
The "Chi-Square Results".window will appear and the chi-square report will be printed
automatically.

Pass/Fail Criteria
The test passes if the "Chi-Square Results" window appears and the report is printed.

10.14.5 Invalid Test Cases

CcS.2
Purpose
This test addresses the function to compute Chi-square statistics, requirement 3.1.3.3 M.4.
Special Requirements

Rename the file CHISQ.DAC in the DAC subdirectory to CHISQ.BAK. At the conclusion of the
test, rename the file CHISQ.BAK to CHISQ.DAC.
Input Description
1) Pull down the Run menu.
2) Select Chi-square.

Expected Results
"File not found" dialog is displayed.

Missing Data
- .

and then the "Chi-Square parameters not found!" dialog is displayed.
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10.15 DMS Interface

10.15.1 Introduction and Description

These tests address the SAS interface with the DMS computer. Specifically, these tests address
DMS requesting an assay or recalculation, SAS acknowledging receipt of DMS data, SAS
performing the requested function and transmitting measurement results to the DMS computer,
and SAS receiving an acknowledgment from the DMS computer.

10.15.2 Special Requirements

The CAMAC must be on-line. One of the SWEPP operations personnel must login to the DMS
system.

10.15.3 Procedure Steps

1) Login as an operator.

2) Pull down the Run menu.

3) Select Remote.

4) The Remote Operation dialog is displayed.

Assay System Remote Operation
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10.15.4 Valid Test Cases

DMS.1

Purpose
This test addresses the SAS receiving a request from the DMS to perform an assay, requirements
3.1.52M.1,M2, M3, and M 4.

Special Requirements
If the network link between the SAS PC and SGRS Workstation is operating, check for the
existence of a file named TEST01.GAM on the Workstation logical device PANSRATIOS. If.
this file exists, rename or delete it (note that multiple versions of the same file can exist on the
SGRS Workstation). Gamma ratios files are located on the SGRS logical device PANSRATIOS.

Input Description

1) Have the SWEPP operator place a drum in the assay chamber. Any drum containing
some fissile material including the “Pink Drum” can be used for this test.
2) Ensure that the Remote Dialog window is displayed on the SAS computer screen (see

10.15.3).
3) Have the SWEPP operator request a new assay via the DMS system using the

following:
Container ID: TESTO1
Content Code: 000
Bar Code: TESTO1
Gross Weight: 100

Expected Results

SAS will display a status message in the Remote Dialog window indicating receipt of an assay
request, acknowledgment of the request, and initiation of processing. The Waste Attributes
window will be displayed showing the Container ID (TESTO01), Content Code (matrix type 000)
and Net Weight? received from the DMS, with the title bar showing TESTO1 as the file name.
Active and passive data acquisition and data analysis will be performed automatically. At the
completion of data acquisition and analysis, the Results window will be displayed, a summary
report printed and the assay results will be automatically transmitted to the DMS (the status line
in the Remote Dialog window will indicate when data are being sent to the DMS). After all data
have been received by the DMS (data transmission takes approximately 20 seconds), the DMS
terminal will display selected assay quantities. The values displayed should agree with the
corresponding quantities shown in the SAS Results window and on the SAS summary report.
Pass/Fail Criteria )
The test passes if the derived quantity values displayed on the operator's DMS terminal agree with
the derived values in the printed summary report to the minimum precision printed or displayed.

2 The net weight should be approximately 25kg less than the gross weight; check DMS screen for actual value.
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DMS.2

Purpose
This test addresses the SAS receiving a request from DMS to perform a recalculation,
requirements 3.1.5.2 M.1, M.2, M.3, and M.5.

Special Requirements
If the network link between the SAS PC and SGRS Workstation is operating, check for the
existence of a file named TEST01.GAM on the Workstation logical device PANSRATIOS. If
this file exists, rename or delete it (note that multiple versions of the same file can exist on the
SGRS Workstation). Gamma ratios files are located on the SGRS logical device PANSRATIOS.

Input Description
Have the operator request a recalculation for drum TESTO1 through the DMS system.

Expected Results
SAS will display a status message in the Remote Dialog window indicating receipt of an assay
request, acknowledgment of the request, and initiation of processing. The Waste Attributes
window will be displayed showing the Container ID (TESTO01), Content Code (matrix type 000)
and Net Weight received from the DMS, with the title bar showing TESTO1 as the file name.
Active and passive data acquisition and data analysis will be performed automatically. At the
completion of data acquisition and analysis, the Results window will be displayed, a summary
report printed and the assay results will be automatically transmitted to the DMS (the status line
in the Remote Dialog window will indicate when data are being sent to the DMS). After all data
have been received by the DMS (data transmission takes approximately 20 seconds), the DMS
terminal will display selected assay quantities. The values displayed should agree with the
corresponding quantities shown in the SAS Results window and on the SAS summary report.

Pass/Fail Criteria
The test passes if the values shown in the SAS summary report and displayed.on the DMS
terminal agree with the values obtained during the initial assay of drum TESTO1 (test DMS.1)
within the precision printed or displayed.

DMS.3

Purpose
This test addresses the SAS receiving a request from the DMS to perform a recalculation,
requirement 3.1.5.2 M.1, M.2, M.3 and M.5. Further, this test verifies that the SAS will use
current matrix, calibration and SGRS data during a remote recalculation (Process 4 under 3.1.5.2
M.5), a new requirement added for SAS Version 2.0.

Special Requirements
The SGRS Workstation must be operating, the network link to the SAS PC must be functional
and the PathWorks network software must be running on the SAS PC. This test can be delayed
until after test VM. 5 has been performed, if desired.

Input Description

1) Have someone familiar with the SGRS Workstation make a copy of a gamma ratios
file. The file to be copied must contain a non-zero value for the Am241/Pu239 ratio
and preferably a non-zero value for the U235/Pu239 mass ratio. (The file created
during test VM.5 can be copied for this test.) Name the copy TEST01.GAM.
Gamma ratios files are located on the SGRS logical device PANSRATIOS.
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2) Have the SWEPP operator (or someone with sufficient DMS privileges to change data
values) make the following changes to drum TESTO1 data values on the DMS system:
Content Code: change from 000 to 007
Gross Weight: change from 100 to 250

3) Have the SWEPP operator request a recalculation for drum TESTO1 via the DMS
system.
Expected Results
SAS will display a status message in the Remote Dialog window indicating receipt of an assay
request, acknowledgment of the request, and initiation of processing. The Waste Attributes
window will be displayed showing the Container ID (TESTO1), Content Code (matrix type 007)
and Net Weight received from the DMS, with the title bar showing TESTO1 as the file name.
Active and passive data acquisition and data analysis will be performed automatically. At the
completion of data acquisition and analysis, the Results window will be displayed, a summary
report printed and the assay results will be automatically transmitted .to the DMS (the status line
in the Remote Dialog window will indicate when data are being sent to the DMS). After all data
have been received by the DMS (data transmission takes approximately 20 seconds), the DMS
terminal will display selected assay quantities. The values displayed should agree with the
corresponding quantities shown in the SAS Results window and on the SAS summary report.
Pass/Fail Criteria

1) The SAS summary report must list the Matrix Type as 007 and Net Weight as approximately
225 kg (actual value must agree with that shown on the DMS screen).

2) The summary report must have a note indicating that the Am-241 mass was deterrmned using
either “Pu-239 Mass Ratio” or “U-235 Mass Ratio” information.

3) Ifthe file TEST01.GAM contains a non-zero value for the U235/Pu239 mass ratio, then the
SAS summary report must show a U-235 mass value.

4) The values shown in the SAS summary report and displayed on the DMS terminal must agree
within the precision displayed or printed.
Final Note

After-tests DMS.1 through DMS.3 have been completed successfully, have someone with

“delete” privilege (SWEPP Certification Specialist or DMS System Administrator) delete the data

for drum TESTO1 from the DMS system.

10.15.5 Invalid Test Cases

There are no invalid test cases. DMS performs its own time-out functions, e.g., if the RS-232
cable is disconnected between the DMS and SAS. ‘
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10.16 Version 2.0 Modifications

10.16.1 Introduction and Description

These tests address the operational performance of the modifications made in Version 2.0 of the
SAS software.

10.16.2 Special Requirements

None.

10.16.3 Procedure Steps

Login as an operator or physicist, as indicated in the test case.

10.16.4 Valid Test Cases

VM.1
Purpose
This test addresses the performance of the SAS when a corrupted data file is read, addressing
SCR Operational Problems, Item 3.
Input Description
1) Login as an operator.
2) Pull down the File menu.
3) Select Open.
4) Inthe Open File Dialog, enter file name VM.001.
5) Click on OK.
6) Click on Continue.
7) Click on OK.
8) Click on OK.
Expected Results
"Incomplete Data" dialog is displayed.

Incomplete Data

125




INEL-96/0058

"Saved data file..." warning dialog is displayed.

Pass/Fail Criteria
The test passes if the warning messages are displayed.

VM.2
Purpose
This test addresses the status of background data when a passive-only assay is performed, or if
"Background Correction" is turned off, addressing SCR Operational Problems, Item 4.
Input Description
1) Login as an operator.
2) Pull down the File menu.
3) Select New.
4) Inthe New File Dialog, enter file name VM_2.
5) Click on OK.
6) Inthe Waste Attributes dialog,
e Select 55-gallon drum for the container type
e Select matrix type 001
o Enter net weight 6.0.
7) Click on Assay.
8) Select Passive.
9) After the assay is completed, pull down the File menu.
10) Click on Save.
11) Pull down the File menu.
12) Select Print.
13)In the print file dialog, enter file name VM_2.001.
14) Click on OK.
Expected Results
The program should save the passive background data in the file, and this file will be printed.
Pass/Fail Criteria
The test passes if passive background data are present in the printed copy of the file in a section
labeled "Passive Background."
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, VM.3
Purpose
This test addresses the notification of missing passive background data during a recalculation,
addressing SCR Operational Problems, Item 5.
Input Description '
1) Login as an operator.
2) Pull down the File menu.
3) Select Open.
4) In the Open File Dialog, enter file name VM.003.
5) Click on No in the message window.
6) Click on Continue.
7) Click on OK.
8) Click on Close.
Expected Results
"No background data..." dialog is displayed. :

Missing Data

Pass/Fail Criteria
The test passes if a warning message is displayed.

VM4
Purpose
This test addresses the window size, placement and color information, addressing SCR User
Interface Problems, Item 9.
Input Description
1) Login as an operator.
2) Pull down the Options menu.
3) Select Color.
4) Select the desired color.
5) Click on OK.
6) Resize and reposition one or more windows.
7) Logout and exit the program completely.
8) Restart SAS, and log in as an operator.
Expected Results
The window sizes, positions, and background colors should be the same when the user logs back
in,
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Pass/Fail Criteria

The test passes if the window sizes, positions, and background colors are the same after logging
in the second time as when they were set initially.

V.5

Purpose

This test addresses the ability of a Physicist to reanalyze saved data with new parameters,
requirements 3.1.2.2M.2,3.1.4.3 M.13 and M. 14.

Input Description

Part I:

Part IT:

Part ITT

1) Place a drum containing plutonium, **Am, and Z*U in the assay chamber.
2) Login as an operator.

3)
4)
5)
6)
7)
8)

9

Pull down the File menu.

Select New.

The New File Dialog is displayed.

Enter file name VM 5.

Click on OK.

In the Waste Attributes dialog,

e Select 55 gallon drum for the container type
e Select matrix type 001

e Enter net weight 1.0.

Click on Assay.

10) Select Full.

11) After the assay has completed, click on Save (unless file was saved automatically).
12) Click on Close.
13) Log out.

1)
2)
3)
4)
5)
6)
7
8)
9

1)
2)
3)
4)
5)
6)
7)
8)

Make an SGRS measurement on the same drum using the same file name (VM_5).
Log into SAS as a physicist.

Pull down the File menu.

Select Open.

Enter file name VM_5.

Click on OK.

In the Waste Attributes Dialog, click on Edit.

Select "Use current Chamber & Matrix data."

Click on Continue.

Make an SGRS measurement on the same drum using the same file name (VM_5).
Login as a physicist.

Pull down the File menu.

Select Open.

Enter file name VM_S.

Clickon OK.

Click on Continue.

Wait until the assay is complete, then click on Save.
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Expected Results
Part I:
Expected results not included. Results/values were independently verified.
Part II:
The assay report should now show a >°U mass and reflect the fact that mass ratio values were
used for > Am determination. Results/values were independently verified.
Part IIT:
All values printed on the summary report must agree with the values on the summary report
generated in Part II.
Pass/Fail Criteria
The test passes if the results from Part II are verified by "independent calculation," and if the
summary reports from Parts I and III agree.

VM.6
Purpose
This test addresses the integrity of the background data, SCR Technical Problems, Item 3.
Input Description
1) Place the "Pink Drum" in the assay chamber.
2) Login as an operator.
3) Pull down the Options menu.
4) Select Assay Times.
5) Set Background Count Time to 100.
6) Pull down the Run menu.
7) Select Background.
8) At the conclusion of the run, a warning message will be displayed and the "Passive
Background Data" window will be shown with bad data rates highlighted. Click on
OK.
9) Select Reject in the "Passive Background Data" window.
10) Click on OK.
Expected Results
The Passive Background Data dialog should display a warning message, with bad data rates
highlighted.
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Pass/Fail Criteria
The test passes if the warning message is displayed and the "Passive Background Data" window
will be shown with bad data rates highlighted.

VM.7

Purpose
This test addresses closing the "Waste Description" window after an assay is aborted, SCR User
Interface Problems, Item 7.

Input Description
Login as a physicist.
Pull down the File menu.
Select New. ’
In the new file dialog, enter file name VM_7.
Click on OK.
In the Waste Attributes dialog,
e Select 55-gallon drum for the container type
e Select matrix type 152
o Enter net weight 6.0.
7) Click on Assay. ‘
When the assay starts, click on Cancel in the "Active Data Acquisition" status window.
9) Click on Yes in the "Confirmation Window."

SICRICITS

o0
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10) Click on Close.
Expected Results
The Close buttons in the Waste Attributes window and the File pull-down menu are active after
the assay is aborted.
Pass/Fail Criteria
The test passes if the Close buttons are active after the assay is aborted.

VM.8
Purpose
This test addresses the addition of "keyboard accelerators" for the most commonly used menu
options, SCR User Interface Problems, Item 5.
Input Descn'pftion
1) Login as operator.
2) Pull down the File menu.
3) View the listed keyboard accelerator functions.
4) Exit the window and press Ctrl+N, for "New Assay."
5) Select Cancel.
6) Press Ctrl+O for "Open.”
7) Select Cancel.
8) Press Ctrl+E for "Exit."
9) Select No.
10) Pull down the Run menu.
11) View the listed keyboard accelerator functions.
12) Exit the window and press Ctrl+N, for "New Assay."
13) Select Cancel.
14) Press Ctrl+R, for "Remote."
15) Select Exit Remote.
16) Pull down the Help menu.
17) View the listed keyboard accelerator function.
18) Exit the window and press the F1 key, for "Abort."
19) Select Acknowledge.
Expected Results
Accelerator keys are shown on the described menus and produce the expected results when
entered from the keyboard.
Pass/Fail Criteria
Accelerator keys can be used to activate the described menu functions.

10.16.5 Invalid Test Cases

There are no invalid test cases.
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11. REQUIREMENTS TRACEABILITY

The requirements traceability matrix in Table 7 identifies the requirement name and
paragraph number from the Software Requirements Specification (SRS), Reference [2], the object
where the requirement is designed and coded, and the test case that tests the requirement. The last
column shows that each test passed the criteria specified in the test procedure, section 10.

Table 7. Requirements traceability matrix.

SRS or Requirement SDD / code Test case Pass
RWMCSCR Fail
13623
3.122M1 Login users login_dlg, user, UA.13,58,9  Pass
user_list, main_wnd
3.1.22M.2 Present user menu functions . main_wnd ' UA.1,3,5, Pass
AF.1,
VM.5
3.1.22M3 Logout users . main_wnd : UA24.,6 Pass
3.1.2.2M4 Allow administrator to modify user list users_dlg, user, AF2-22 Pass
user_list, main_wnd
3.132M1 Read default processing options for assay main_wnd, all Pass
system chamber_wnd
3.133M.1 Read default chamber processing options chamber_wnd, - TS.1-5, Pass
options_dlg CP.1-8
3.1.33M2 Allow an operator or physicist to modify the chamber_wnd, TS.1-5, Pass
processing options options_dlg CP.1-7,9-23
3.1.3.3M3 Allow physicist to modify the chamber calibration_dlg, CC1l-5 Pass
calibration chamber_wnd
3.1.3.3M4 Perform Chi-square test chamber_wnd CS1-2 Pass
3.1.34M.1 Read CAMAC crate configuration from file camac crate CL1-5 Pass
3.134M2 Get time and date of data acquisition chamber_wnd, TDDA.1,2 Pass
system_time,
camac_crate
3.1.34M3 Acquire active data from assay chamber chamber, camac_crate, CP.4-7 Pass
acquire_dig
3.134M4 Store active data on file chamber_wnd, - CP4-7 Pass
camac_crate
3.1.34 M5 Read active data from file chamber_wnd, AS1-3 Pass
camac_crate
3.1.3.4M.6 Acquire passive data from assay chamber chamber, camac_crate, CP.1-7 Pass
acquire_dlg
3.1.3.4M.7 Store passive data on file chamber_wnd, Cp.1-7 Pass
camac_crate
3.1.3.4M38 Read passive data from file chamber_wnd, PS.1-4 Pass
) camac_crate
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SRS Requirement SDD / code Test case Pass
Fail
3.1.3.5M.1 Compute flux monitor gross, background, active_signals, detector AS.1-3 Pass
and net rates
3.1.3.5M.2  Compute flux monitor gross, background,  active_signals, detector AS.1-3 Pass
and net rate errors
3.1.3.5M.3 Compute barrel flux monitor gross, active_signals, detector AS.1-3 Pass
background, and net rates
3.13.5M4  Compute barrel flux monitor gross, active _signals, detector AS.1-3 Pass
background, and net rate errors
3.1.35M.5 Compute shielded total gross, background,  active_signals, detector AS.1-3 Pass
and net rates
3.1.3.5M.6 Compute shielded total gross, background,  active_signals, detector AS.1-3 Pass
and net rate errors
3.1.3.6 M.1 Compute shielded total rate passive_signals, detector PS.1 -4 Pass
3.1.3.6M.2  Compute shielded total rate error passive_signals, detector PS.1-4 Pass
3.1.3.6 M.3 Compute system total rate passive_signals, detector PS.1-4 Pass
3.1.3.6 M4 Compute gross, background, and net system  passive_signals, detector PS.1-4 Pass
total rate error
3.1.3.6 M.5 Compute shielded coincidence rate passive_signals, detector PS.1-4 Pass
3.13.6M.6  Compute shielded coincidence rate error passive_signals, detector PS.1 -4 Pass
3.1.3.6 M.7 Compute system coincidence rate passive_signals, detector PS.1-4 Pass
3.1.3.6 M.8 Compute system coincidence rate error passive_signals, detector PS.1 -4 Pass
3.142M.1 Input container attributes waste_dlg, container, CL.1-12, Pass
chamber_wnd WA.1-8,
10-18
3.142M.2 Store container data on file chamber_wnd, ClL1 Pass
container
3.142M.3 Read container data from file chamber_wnd, WA.1-8 Pass
container
3.142M4 Provide container summary report container TDDA.1-2, Pass
others
3.142M5 Allow physicist to modify the container list ~ container_dlg, CL1-12 Pass
container,
container_list,
main_wnd
3.143M.1 Input matrix attributes waste_dlg, matrix, WA.1-8, Pass
chamber_wnd 10-18
3.143M.2 Store matrix data on file chamber_wnd, matrix  CI.1 Pass
3.143M.3 Read matrix data from file chamber_wnd, matrix ~ WA.1-8, Pass
ML.1-9
3.143M4 Allow physicist to modify the matrix list matrix_dlg, matrix, ML.1-9 Pass
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Table 7. Requirements traceability matrix (cont'd).

SRS Requirement SDD / code Test case Pass
Fail

3.143M.5 Compute active Pu mass matrix DR.1-2 Pass
3.143M.6 Calculate active Pu mass error matrix DR.1-2 Pass
3.143M.7 Calculate passive Pu mass matrix DR.1-2 Pass
3.143M.8 Calculate passive Pu mass error matrix DR.1-2 Pass
3.143 M9 Select either the active or passive Pumass  matrix DR.1-2 Pass
3.143M.10  Select either the active or passive Pu mass ~ matrix DR.1-2 Pass

error
3.143M.11  Calculate plutonium isotopic masses matrix DR.1-2 Pass
3.143M.12 Calculate plutonium isotopic mass errors matrix DR.1-2 Pass
3.143M.13  Calculate U-235 mass matrix VM.5 Pass
3.143M.14  Calculate U-235 mass error matrix VM.5 Pass
3.143M.15 Calculate the Am-241 mass matrix DR.1-2 Pass
3.143M.16 Calculate the Am mass error matrix DR.1-2 Pass
3.143M.17 Calculate thermal power matrix DR.1-2 Pass
3.1.43M.18 Calculate the thermal power error matrix DR.1-2 Pass
3.143M.19 Calculate the thermal power density matrix DR.1-2 Pass
3.143M.20 Calculate the thermal power density error matrix " DR.1-2 Pass
3.143M.21 Calculate activity values matrix DR.1-2 Pass
3.143M.22  Calculate the activity errors matrix DR.1-2 Pass
3.143M.23  Calculate the TRU activity concentration matrix DR.1-2 Pass
3.143M.24 Calculate the TRU activity concentration matrix DR.1-2 Pass

error :
3.143M.25 Calculate fissile gram equivalent matrix DR.1-2 Pass
3.143M.26 Calculate fissile gram equivalent error matrix DR.1-2 Pass
3.143M.27 Provide a measurement summary report for chamber_wnd, TDDA.1-2, Pass

the container container others
3.1.52M.1 Send "handshake™ message to DMS dms_dlg DMS.1,2,3 Pass
3.152M.2 Send measurement results to DMS dms_dlg DMS.1,2,3 Pass
3.1.52M3 Receive "handshake" message from DMS dms_dlg DMS.1,2,3 Pass
3.152M4 Receive new assay request from DMS dms_dlg DMS.1 Pass
3.1.52M.5 Receive recalculation request from DMS dms_dlg DMS.2,2 Pass
UL1 Switch between windows chamber_wnd, WA.8,9 Pass

waste_dlg, active_dig,
passive_dlg, resuits_dlg

UL3 Default "Matrix Type" waste_dlg WA 4-7 Pass
ULS "Keyboard accelerators" assaysys.rc, main_wnd VM.8 Pass
UL6 Close "Chamber Window" chamber_wnd UA7 Pass
UL7 Close "Waste Description” window waste_dlg VM.7 Pass
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active_dlg, passive_dlg,
places

SRS Requirement SDD / code Test case Pass
Fail
UL9 Window size, placement and color assay_system, VM4 Pass
information main_wnd,
chamber_wnd
UL10 View matrix parameters matrix_parameter dig ML.1-9 Pass
UL11 Attempts to update write-protected lists matrix_l1dlg, CL.1-12, Pass
matrix_parameter_dlg, ML.1-9,
container_dlg CC.1-5
RE4 Store additional information chamber_wnd, matrix  CL1 Pass
- OP3 Attempt to read corrupted data file chamber_wnd, itstream VM.1 Pass
OP4 Append background data to save file chamber_wnd VM2 Pass
OP.5 Notification of missing passive background chamber_wnd VM.3 .Pass
data during a recalculation
TP.3 Background data integrity chamber_wnd, itstream VM.6 Pass
TP.5 Significant figures displayed chamber_wnd, matrix, PS.1, AS.1 Pass
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12. RESULTS

The first set of tests were conducted on April 2, 1996. The DMS interface tests
were conducted on April 15, 1996, when the DMS programmer's part of that system was
ready. These tests were DMS.1 and DMS.2. Because the software programming for
DMS was not complete the interface between this system and DMS was all that was
checked. These tests were also conducted twice because they initially failed due to
programming problems which were fixed later that same day. Additional tests to validate
the DMS interface were conducted on April 29, 1996; these tests, which were modified
from the original test plan, tested the SAS receiving a request from the DMS to perform
an assay, testing requirements 3.1.5.2 M.1, M.2, M.3, and M.4. These tests were
completed successfully.

Some of the tests that had failed on April 2, 1996 were later re-conducted on April
3, 1996 after some programming modifications were made to the software. The problems
occurred using the mass fractions from the Gamma assay on the recalculation. The test
had to be re-done when the SGRS was available. The test VM.5 (parts I and IT) was re-
tested again on April 15, after additional programming fixes were made, and was
successful. The addition of a Part IIT was also necessary to complete the entire test.

The tests that needed to be re-run on April 3, 1996 included WA.1, where
modifications to the plan had to be made to reflect programming changes. Although
WA.1 was completed successfully on the first test on April 2, 1996, some anomalies in the
test were eliminated by re-testing and validating so that the test, per the modifications
made to the plan, could be run successfully. Test CP.4 was conducted twice on April 2,
because the printer being out of paper caused a general error in the application. This error
was a known software problem related to the fact that the print routines that were
originally developed for the program were not configured to be Windows print routines.
This problem will need to be fixed in the next software update. The clock also failed the
first time, but was subsequently correct in the second test. The problem was that the
count criteria were arbitrarily met the second time and not the first, but the count data was
comrect. This problem existed because the test plan was too stringent, stating that the
counts would be within 100 milliseconds, when in fact the computer interrogates the
CAMAC crate every 100 to 150 milliseconds which can cause times of successive runs to
vary by as much as 150 ms. This is not a problem since the actual CAMAC clock time is
used in the assay calculations. The test plan has been changed to specify the time to be
within 200 ms rather than 100 ms. Based on this information, the results of the CP.7 test
were acceptable.

In tests TDDA.1 and TDDA..2 the clock time was 15.04.05 when started and the
start time was recorded as 15.08.58. There was a disparity in the set time and test time
because of the clock time and assay time being read as unequal. It was probable that the
wrong time was written down during the first test. This test is an arbitrary test in that the
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computer clock is read by the program so there should be no disparity. These tests were
re-run with successful results.

Tests DR.1 and DR.2 did not pass on April 2, 1996 because there was a possible
problem with the Am-241 mass. A program fix was required, and when re-tested on April
15, 1996, the problem was solved. The calculations from these tests, which were verified
by an independent physicist, were validated as correct on April 29, 1996, when the
independent physicist and the quality review met and evaluated the results.

13. ANOMALOUS EVENTS

Several corrections were made to the test plan during the testing conducted over
the three day period. These changes included correcting editorial errors, indicating places
where the proper screen capture in the example was not used, and adding additional steps
or deleting steps that did not fit the test. Additional cases where changes had to be made
were either the addition of new tests which further evaluated what was tested, or that
were needed to test enhancements to this version of the software that were not part of the
original tests conducted on a previous version of this software. Hand calculations were
completed to validate the tests. Where disparities existed that could not be verified, tests
were either re-run or the software programming was adjusted to be correct. In some
cases, additional steps to complete a test were added that were not part of the plan for an
individual test. In cases where examples existed and did not appear to be obvious, a note
was added to prevent any confusion.

An additional correction that had to be made to the plan consisted of changing the
user ID in cases where the wrong one was used. The tester and the programmer also
added steps to test if a test was successful, such as changing a password, which validated
that the computer had actually accepted the change. These instances were added to
validate the test, even though they were not initially part of the test plan.

The problem with the clocks and the arbitrariness of the time between the clock
and the assay system was not seen as a problem in test CP.4. This test, as noted above,
was conducted twice on April 2, because the printer being out of paper caused a general
error in the application. This error did not surprise the programmer, and was a known
software problem which relates to the Windows print routines. This problem will need to
be fixed in the next software update. It was suggested that operators be trained, or a note
provided in the procedures, to indicate that operators need to check the paper level prior
to system operation. The clock also failed the first time, but was subsequently correct in
the second test. The problem was that the count criteria were arbitrarily met the second
time and not the first, but the count data was correct. This problem existed because the
test plan was too stringent, stating that the counts would be within 100 milliseconds, when
in fact the computer interrogates the CAMAC crate every 100 to 150 milliseconds which
can cause times of successive runs to vary by as much as 150 ms. This is not a problem
since the actual CAMAC clock time is used in the assay calculations. The test plan has
been changed to specify the time to be within 200 ms rather than 100 ms. The software
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uses actual time, therefore a slight overrun on the pre-set time is not a problem. The
calculations use actual time so this is not a problem. Based on this information, the results
of the CP.7 test were acceptable.

During test CP.7, it was noted that the clock was 80 counts high. We determined
that this condition was not a problem because the count is arbitrary and does not
necessarily have to be exact. There would have been a concern if the counts were off two
tenths of a second, this would have indicated that there was a problem. The degree of
difference was an acceptable margin of error.

During test UA.1, it was noted that in one of the pull-down menus the available
options to the user ID level were incorrect. The software was correct, it was the screen
capture in the test plan that was not accurate. This problem was noted and the test plan
updated to correct it. This problem occurred in the "Options” section of the pull down
menu under the Physicist ID. )

A problem was noted during test AF.3. Since testing had to conclude for a lunch
break, and the system was shut down, the added password, which was to be deleted in test
AF.16 - AF.18, was not saved. An additional problem was discovered in AF.5 - AF.15,
where the plan stated that the user should enter the valid user ID, and not select it from
the pull down menu. This problem has been corrected as part of the plan updates. In tests
AF-19 - AF.21, the test said to select a user ID but did not define which one. These
elements, it was determined during testing, had to be defined in order for the test to run
correctly. These changes were also made.

During the CP.7 test, it was noted that a potential problem could exist. The plan
states that an operator needs to save the data, but if the auto save feature is selected, this
is not required to be done, but just validated. A note was added to tell users that they
either need to save or make sure that the auto save feature is on and that it works

properly.

Table 2 under test ML.5 was confusing to the tester in that certain sections of the
table had numerous options, but it was not obvious that the user was to select only one for
each group. A more logical grouping was suggested to improve readability and user
clarity. Table 5 under test CC.3 also suffered from a similar problem. The order of the
text was not presented in such a way that the verification would be performed correctly by
a confused user. Improvement was necessary to change textual order so that it reflected
the way a user would read the table and validate the data.

During the WA.1, WA.2, and WA.3 tests the test plan required that the operator
select full assay. It was determined during testing, and validated by the programmer, that
it was not necessary to select full. This correction to the test plan was subsequently made.
In test WA.9, the test plan did not indicate that the window, after completing test step 3,
would ask about running a background. It was noted that this needed to be added, and
that the user needed to select yes in order to continue the test. In tests TS.1 and TS.3, in
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step 2 of each test, an additional step needed to be added to instruct the user to change to
the DAC subdirectory so that the files could be found. This was also added to the plan.

In the test series of CP.1 through CP.3 an additional step "press accept button in
passive background data” was required to be added because this step needed to be
completed. This anomaly was determined during testing. This has been added to the plan.
Test CP.4 also required an additional step which required an operator to select "yes" after
step two, and then confirm. Step 6 required rewording to address the possibility that the
automatic save option may be selected and so the saving step may just be a verification.
The test plan was reworded to provide for this possibility.

Tests DR.1 and DR.2 could not be successfully evaluated on the April 2, 1996, the
original testing date, because the hand calculations to validate the data were not yet
complete. The calculations were completed and validated on April 29, 1996, and the tests
were subsequently determined to be successful.

Additional testing problems consisted of minor word changes which were
corrected as needed. No additional corrections were required, or any subsequent testing
on sequences that were previously tested and found to be successful.

An additional test was added to the test plan because it was necessary to verify
that the latest gamma results were the ones being used by the software and not results that
were previously filed. This test was necessary because in previous tests it was determined
that the latest gamma results were not being captured. Additional tests to validate the
DMS interface were conducted on April 29, 1996. These tests were not part of the
original test plan, and tested the SAS receiving a request from the DMS to perform an
assay, testing requirements 3.1.5.2 M.1, M.2, M.3, and M.4. These tests were completed
successfully. .

14. SUMMARY

At the completion of the fourth set.of tests, all tests were conducted successfully.
Hand calculations, which were unavailable during the testing phase, were also completed
and subsequently validated and signed off as successful completions of test results
generated during the four testing days. The CAO QAPD [15] has been satisfied by this
test plan. This satisfies the Quality Level B testing requirements. The tests described in
Section 10, Test Procedure, have verified that all requirements specified in the SRS are
correctly implemented.

15. EVALUATION

The additional test case that was tested on April 29, 1996 was a good addition to
the testing plan. This test validated that the gamma results being captured were the
correct data and not data just stored in memory. This test also proved the interface would
work between this software and DMS. An addition to operating procedures or training to
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require operators to verify that the printer has enough paper before beginning to run tests
would be a good addition. Since this was a problem during a test, a procedure step to
validate that paper is in the printer should be put in place. Although some problems
existed at the start of testing, they were minor and subsequently corrected by the
programmer to the satisfaction of the quality control person and the tester.
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' Appendix A -- Software Test Execution Log
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