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Rod Impacting Plate Example

Steel_Plate
block_2

Tungsten_Rod
w/ Initial velocity = -1e5
block_1
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Models for
Rod Impacting Plate Example

1. Elastic-plastic material model

a. Rod & Plate mesh w/ Hex8

b. Rod & Plate mesh w/ Tet4

c. a. + different initial velocity

d. c. + contact changes

e. d. + additional I/O

f. Rod & Plate mesh w/ Nodal-Based Tet

g. f. + remeshing
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Models for
Rod Impacting Plate Example

2. Johnson Cook material model

a. w/o Element death

b. w/ Element death

c. w/ Element death, conversion to particles

d. w/ Element death, conversion to particles, 
particle-element interaction

e. w/ SPH rod, w/ element death, conversion to 
particles, particle-element interaction
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Models for
Rod Impacting Plate Example

3. KC-Concrete material model for plate, elastic-plastic 
material model for rod

a. Rod & Plate mesh w/ Hex8, element death

b. w/ rebar using existing mesh edges
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Hands-on Session 1:

Rod-impacting-plate problem

Introduce the problem

New working directory hex_elastic_plastic

Cubit session

Presto: review already created input file

Paraview session
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P016_Penetration_Element_Death

block_3  
Symmetry_Plane block_2

Steel_Plate

block_1
Tungsten_Rod
Initial velocity = -1e5



Sierra solid mechanics training Sandia National Laboratories
Solid Mechanics

New working directory

Create sub-directory in ‘training_rod_impacting_plate’ 
directory

% cd  ~/training_rod_impacting_plate

% mkdir  hex_elastic_plastic

Copy ‘taylor.sat’, ‘taylor_hex.i’ into new directory

% cp  taylor.sat  hex_elastic_plastic

% cp  taylor_hex.i  hex_elastic_plastic

Move into new directory

% cd  hex_elastic_plastic
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Cubit – Begin Session, Import 
Geometry

Start a Cubit session:

% cubit

(helpful but not necessary) Set Cubit’s default directory 
to current working directory:

File > Set Directory > hex_elastic_plastic > OK 

Import sat file (taylor.sat):

File > Import … > taylor.sat > Open > Finish
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Cubit – Geometry Manipulation

Webcut geometry for better mesh control

webcut volume 2 with cylinder radius 0.6 axis x

webcut volume 2 4 3 with plane yplane

Merge Plate to enable a contiguous mesh

merge volume 2 4 6 5

Merge Rod to enable a contiguous mesh

merge volume 3 7
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Cubit – Meshing

Mesh Contact_Plate:

volume 1 size 1

mesh volume 1

Mesh Plate:

volume 2 4 6 5 size 0.084

mesh volume 2 4 6 5

Mesh Rod:

volume 7 3 size 0.047625

mesh volume 7 3
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Cubit – Assign Block ID and Export

Assign Block IDs:

block 1 volume 3 7

block 2 volume 2 5 6 4

block 3 volume 1

Export Genesis mesh:

export mesh "taylor_hex.g" overwrite

or

File > Export … > taylor_hex.g

File Type > Genesis (*.g* *.gen* *.G* *.GEN*) > 
Save > Finish

Quit Cubit

exit
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Simba – Import Mesh File

Start-up Simba session:

% simba

In Assembly View: 

Right click top folder > Import Model … > 
Select new model type > ExodusII

Select > taylor_hex.g > Finish
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Simba – Define Materials (1)

In Model details

expand Materials


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Simba – Define Materials (2)

In Model details

Right Click Materials > New material …

New material name > Tungsten_Rod > OK

Select Tungsten_Rod, change type to elastic-plastic 
> Apply

Density = 16.98

Youngs Modulus = 3.177e12

Poissons Ratio = 0.28

Beta = 1.

Hardening Modulus = 1.564e10

Yield Stress = 1.506e10

Apply
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Simba – Define Materials (3)

In Model details,

Right Click Materials > New material … 

New material name > Steel_Plate > OK

Select Steel_Plate, change type to elastic-plastic > Apply

Density = 7.823

Youngs Modulus = 2.133e12

Poissons Ratio = 0.279

Beta = 1.

Hardening Modulus = 3.972e10

Yield Stress = 7.8e9

Apply
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Simba – Define Materials (4)

In Model details,

Right Click Materials > New material … 

New material name > Symmetry_Plane

Select Symmetry_Plane

Density = 7.823

Youngs Modulus = 2.133e3

Poissons Ratio = 0.3

Apply
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Simba – Assign Materials to Block IDs

Expand Blocks



Right click 1 > Set material properties … > 

Tungsten_Rod > Apply

Right click 2 > Set material properties … > 
Steel_Plate > Apply

Right click 3 > Set material properties … > 
Symmetry_Plane > Apply

(note: red color 
indicates 
incomplete 
data)
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Simba – Create Nodesets for B/Cs  (1)

In Assembly View

right click taylor_hex > View model

Click radio button on block 3 to hide

Mouse Mode > Selects surfaces         > shift click 
planes of symmetry on rod and plate > Create new 
node set        > z_sym > OK
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Simba – Create Nodesets for B/Cs (2)

In Assembly View

Click radio button on block 3 to show

Select surfaces        > shift click front and rear faces 
of block 3 > Create new node set      > fixed > OK

File > Close



Sierra solid mechanics training Sandia National Laboratories
Solid Mechanics

Simba – Assign B/C

Select z_sym (1000) > boundary – no displacement > Z
> Apply

Select fixed (1001) > boundary – no displacement > XYZ 
> Apply
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Simba - Initial Velocities

Select Block 1 > Initial velocity direction > 1 0 0

Magnitude = -1.e5 > Apply
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Simba - Contact

Right click Contacts > New contact

Contact type > Frictionless

Surface 1 > Select Block > 1

Surface 2 > Select Block > 2

Normal Tolerance = 0.015

Tangential Tolerance = 0.015 > Apply

Right click Contact Checks [Needs update] > 
Update QA Checks
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Simba - Define Problem Time and
Time Step Parameters

Right click OtherAnalysisInfo > Add analysis method > 
Presto

Expand OtherAnalysisInfo and sierra-presto

OtherAnalysisInfo > sierra-presto > TimestepControl > 
termination time = 60e-6 > Apply

OtherAnalysisinfo > sierra-presto > TimestepControl > 
New_Time_stepping_block

Start time = 0

Step interval = 1 > Apply
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Simba - Results Output

OtherAnalysisinfo > sierra-presto > presto > OutputControl 
> Other text for scope

at time 0, increment = 6.e-7

nodal variables = ACCELERATION as ACCL

nodal variables = VELOCITY as VEL

nodal variables = DISPLACEMENT as DISPL

element variables = VON_MISES as VONMISES

Apply
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Simba – Export Genesis and Input File

In Assembly view

Right click taylor_hex > Export > Export Presto 

Select > hex_elastic-plastic > Save

File > Quit

Note: This will overwrite the existing taylor_hex.g file
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Presto: A peek at the input file

Verify in sierra scope:  finite element model block 

must refer to ‘taylor_hex.g’ 

Begin finite element model \# 

rod_impacting_plate

database name = taylor_hex.g
…

end 

Run Presto

% sierra presto –i taylor_hex.i –V 2.7beta4
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Paraview 3.02

Run Paraview

% paraview

File > Open > taylor_hex.e > OK

In Object Inspector > Properties 
Select VONMISES
Turn off Block 3 > Apply

Last Frame

Use Active Variable Control to select VONMISES 
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Paraview 3.02

To plot mesh on contour plot
Filters > Alphabetical > Extract Edges > Apply
Click on greyed out eye next to taylor_hex.e

Click Play to animate 

Adjust contours & legend
Object Inspector > Display > Rescale to Data Range
Toggle Color Legend Visibility

Click Play to animate
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Hands-on Session 2:

Rod-impacting-plate problem

New working directory: tet_elastic_plastic

Cubit: change element type from hex to tet

Presto: copy & modify ‘taylor_hex.i’

Paraview session
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New Working Directory

Create sub-directory in ‘training_rod_impacting_plate’ 
directory

% cd  ~/training_rod_impacting_plate

% mkdir  tet_elastic_plastic

Copy ‘taylor_hex.g’, ‘taylor_hex.i’ (& rename) from 
‘hex_elastic_plastic’ directory into new directory

% cp hex_elastic_plastic/taylor_hex.g  \#
tet_elastic_plastic

% cp  hex_elastic_plastic/taylor_hex.i  \#
tet_elastic_plastic/taylor_tet.i

Move into new directory

% cd  tet_elastic_plastic
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Cubit – Import Geometry

Start a Cubit session:

% cubit

Import hex genesis mesh into Cubit

File > Import…

File Type:  Genesis/Exodus 

select taylor_hex.g > Open

check Smooth Curves/Surfaces box > Finish

Delete hex mesh from volume 1 & 2 (but not volume 3)

reset vol 1 2
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Cubit – Mesh with Tets

Mesh Plate

volume 2 size 0.084

volume 2 scheme tetmesh

mesh volume 2

Mesh Rod

volume 1 size 0.047625

volume 1 scheme tetmesh

mesh volume 1

Assign new element types to blocks

block 1 2 element type tetra
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Cubit – Export

Export Genesis mesh:

export mesh "taylor_tet.g" overwrite

or

File > Export …

File name: taylor_tet.g 

File type:  Genesis (*.g* *.gen* *.G* *.GEN*)

Save

Finish

Quit Cubit session:

File > Exit
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Presto

Sierra scope: database name must now refer to 
‘taylor_tet.g’ in the  finite element model block

Begin finite element model \# 
rod_impacting_plate

database name = taylor_tet.g
…

end 

Presto region scope: change output database name

Begin results output rod_impacting_plate

database name = taylor_tet.e
…

End
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Presto

Run Presto

% sierra presto –i taylor_tet.i –V 2.7beta4
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Hands-on Session 3:

Rod-impacting-plate problem

New working directory: hex_elastic_plastic_iv

Presto: Changing the initial velocity

Paraview session
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New Working Directory

Create sub-directory in ‘training_rod_impacting_plate’ 
directory

% cd  ~/training_rod_impacting_plate

% mkdir  hex_elastic_plastic_iv

Copy ‘taylor_hex.g’, ‘taylor_hex.i’ from ‘hex_elastic_plastic’ 
directory into new directory

% cp hex_elastic_plastic/taylor_hex.g 
hex_elastic_plastic_iv

% cp  hex_elastic_plastic/taylor_hex.i  
hex_elastic_plastic_iv

Move into new directory

% cd  hex_elastic_plastic_iv
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Presto

Define a new direction in the sierra scope:

Define direction glancing_blow \#

with vector 1 1 0

Use direction glancing_blow, change initial 
velocity magnitude in Presto region scope: 

Begin initial velocity

block = block_1

direction = glancing_blow

magnitude = -0.5e5

End
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Presto

Run Presto

% sierra presto –i taylor_hex.i –V 2.7beta4
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Hands-on Session 4:

Rod-impacting-plate problem

New working directory:
hex_elastic_plastic_contact

Presto: Changing contact options

Paraview session
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New Working Directory

Create sub-directory in ‘training_rod_impacting_plate’ 
directory

% cd  ~/training_rod_impacting_plate

% mkdir  hex_elastic_plastic_contact

Copy ‘taylor_hex.g’, ‘taylor_hex.i’ from 
‘hex_elastic_plastic_iv’ directory into new directory

% cp hex_elastic_plastic_iv/taylor_hex.g 
hex_elastic_plastic_contact

% cp  hex_elastic_plastic_iv/taylor_hex.i  
hex_elastic_plastic_contact

Move into new directory

% cd  hex_elastic_plastic_contact
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Presto: Modifying Contact Definition

Replace surface definition w/ block skinning in contact 
definition block: 

Begin contact definition acme

contact surface block_1 contains block_1
contact surface block_2 contains block_2

Skin all blocks = on exclude block_3

… friction models … 

…

End contact definition acme



Sierra solid mechanics training Sandia National Laboratories
Solid Mechanics

Presto: Modifying Contact Definition

Add constant friction model in contact definition
block: 

Begin contact definition acme

… surface definitions …

begin frictionless model nofriction
end

begin constant friction model half
friction coefficient = 0.5

end

…

End contact definition acme



Sierra solid mechanics training Sandia National Laboratories
Solid Mechanics

Presto: Modifying Contact Definition

Invoke contact tracking in contact search options: 

Begin contact definition acme

…

… friction models …

begin search options
global search increment = 5

end

…

End contact definition acme
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Presto: Modifying Contact Definitions

Use friction model ‘half’ in place of ‘nofriction’ in 
interaction definition: 

Begin contact definition acme
…
Begin interaction rod_plate
surfaces = block_1 block_2

friction model = half

kinematic partition = 0.5

normal tolerance = 0.015

tangential tolerance = 0.015

end

End contact definition acme
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Presto

Run Presto

% sierra presto –i taylor_hex.i –V 2.7beta4
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Hands-on Session 5:

Rod-impacting-plate problem

New working directory: hex_elastic_plastic_io

Presto: Requesting nodal and element output

Changing the frequency of output, restart

Paraview session
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New Working Directory

Create sub-directory in ‘training_rod_impacting_plate’ 
directory

% cd  ~/training_rod_impacting_plate

% mkdir  hex_elastic_plastic_io

Copy ‘taylor_hex.g’, ‘taylor_hex.i’ from 
‘hex_elastic_plastic_contact’ directory into new directory

% cp hex_elastic_plastic_contact/taylor_hex.g 
hex_elastic_plastic_io

% cp  hex_elastic_plastic_contact/taylor_hex.i  
hex_elastic_plastic_io

Move into new directory

% cd  hex_elastic_plastic_io
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Presto

Request nodal contact force, element stresses in 

results output block in Presto region scope: 

Begin results output results

database name = taylor_hex.e

...

nodal variables = force_contact as fcon

element variables = rotated_stress \# 
as sig

End
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Hands-on Session 6:

Rod-impacting-plate problem

New working directory: nbtet_elastic_plastic

Presto: Using the nodal-based tet element

Paraview session
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New Working Directory

Create sub-directory in ‘training_rod_impacting_plate’ 
directory

% cd  ~/training_rod_impacting_plate

% mkdir  nbtet_elastic_plastic

Copy ‘taylor_tet.g’, ‘taylor_tet.i’ from tet_elastic_plastic
directory into new directory

% cp  tet_elastic_plastic/taylor_tet.g  \#
nbtet_elastic_plastic

% cp  tet_elastic_plastic/taylor_tet.i  \#
nbtet_elastic_plastic

Move into new directory

% cd  nbtet_elastic_plastic
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Presto - Node Based Tet Model

Add a ‘solid section’ in the sierra scope
(before the finite element model block)

Begin solid section nodal_tet

Strain incrementation = node_based

Node based alpha factor = 0.1

Node based beta factor = 0.25

End
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Presto - Node Based Tet Model

Use the solid section nodal_tet for block 1 and 2 in the
finite element model

Begin finite element model \#
rod_impacting_plate

begin parameters for block block_1
…
section = nodal_tet

end

begin parameters for block block_2
…
section = nodal_tet

end

End
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Hands-on Session 7:

Rod-impacting-plate problem

New working directory: 
nbtet_elastic_plastic_remesh

Presto: Using the nodal-based tet element 
w/ remeshing
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New Working Directory

Create sub-directory in ‘training_rod_impacting_plate’ 
directory

% cd  ~/training_rod_impacting_plate

% mkdir  nbtet_elastic_plastic_remesh

Copy ‘taylor_tet.g’, ‘taylor_tet.i’ from nbtet_elastic_plastic 
directory into new directory

% cp  nbtet_elastic_plastic/taylor_tet.g  \#
nbtet_elastic_plastic_remesh

% cp  nbtet_elastic_plastic/taylor_tet.i  \#
nbtet_elastic_plastic_remesh

Move into new directory

% cd  nbtet_elastic_plastic_remesh
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Presto - Node Based Tet Model
w/ Remeshing

Turn on remeshing in the Presto region scope

Begin remesh

Block = block_1

End

Begin remesh

Block = block_2

End
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Hands-on Session 8:

Rod-impacting-plate problem

New working directory: hex_johnson_cook

Presto: Using Johnson-Cook material model

Paraview session
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New Working Directory

Create sub-directory in ‘training_rod_impacting_plate’ 
directory

% cd  ~/training_rod_impacting_plate

% mkdir  hex_johnson_cook

Copy ‘taylor_hex.g’, ‘taylor_hex.i’ from ‘hex_elastic_plastic’ 
directory into new directory

% cp hex_elastic_plastic/taylor_hex.g 
hex_johnson_cook

% cp  hex_elastic_plastic/taylor_hex.i  
hex_johnson_cook

Move into new directory

% cd  hex_johnson_cook
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Presto: Use Johnson Cook Material 
Model

Add stress-strain model for  material Tungsten_Rod

Begin parameters for model johnson_cook
shear modulus = 1.241E12

hardening constant = 1.765e9 

hardening exponent = 1.200e-1               

yield stress = 1.506e10

melt temperature = 1.723e3

poissons ratio = .28

rate constant = 1.6e-2

reference temperature = 2.943e2

thermal exponent = 1

rhocv = 4.e11

End
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Presto: Use Johnson Cook Material 
Model

Add stress-strain model for  material Steel_Plate

Begin parameters for model johnson_cook

youngs modulus = 2.132922145E12

poissons ratio = 0.279

yield stress = 7.8e9

hardening constant = 7.8e9

hardening exponent = 0.106

rhocv = 4.0645086E11

rate constant = 0.004

thermal exponent = 1

reference temperature = 298

melt temperature = 1783.000093

End
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Presto: Use Johnson Cook Material 
Model

Use the johnson_cook stress-strain model for the material 
Rod and Plate in the finite element model block

Begin finite element model \#
rod_impacting_plate

begin parameters for block block_1
material tungsten_rod
solid mechanics use model johnson_cook

end

begin parameters for block block_2
material steel_plate
solid mechanics use model johnson_cook

end
…

End 
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Hands-on Session 9:

Rod-impacting-plate problem

New working directory: 
hex_johnson_cook_death

Presto: Using Johnson-Cook material model 
w/ element death

Paraview session
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New Working Directory

Create sub-directory in ‘training_rod_impacting_plate’ 
directory

% cd  ~/training_rod_impacting_plate

% mkdir  hex_johnson_cook_death

Copy ‘taylor_hex.g’, ‘taylor_hex.i’ from ‘hex_johnson_cook’ 
directory into new directory

% cp hex_johnson_cook/taylor_hex.g 
hex_johnson_cook_death

% cp  hex_johnson_cook/taylor_hex.i  
hex_johnson_cook_death

Move into new directory

% cd  hex_johnson_cook_death
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Add element death block for Rod in Presto region scope:

Begin element death rod
block = block_1
death steps = 5

criterion is element value of \#
state_johnson_cook(2) >= .5

death on inversion = on
End

Note: state_johnson_cook(2) refers to the 2nd state 
variable of the johnson-cook material model (which is eqps)

See Presto manual for lists of material model state variables

Presto: Hex model with Johnson Cook 
Material Model, element death, no particles
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Add element death block for Plate in Presto region scope:

Begin element death plate
block = block_2
death steps = 5

criterion is element value of \#
state_johnson_cook(2) >= .5

death on inversion = on

End

Presto: Hex model with Johnson Cook 
Material Model, element death, no particles
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Update the contact definition for element death

update all surfaces for element death = on

Request “equivalent plastic strain” and “death status” in results 
output

element variables = mat%johnson_cook(2) \# 
as eqps

element variables = death_dummy_var \#

as death_status

Presto: Hex model with Johnson Cook 
Material Model, element death, no particles
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Paraview 3.02

File > Open > taylor_hex.e > OK

In Object Inspector > Properties 
Select DEATH_STATUS and VONMISES
Turn off Block 3 > Apply

Last Frame

Use Active Variable Control to select VONMISES 
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Paraview 3.02

Plot active elements only

Filters > Alphabetical > Threshold 

Scalars DEATH_STATUS

Lower Threshold = 0.5

> Apply

Click Play        to animate
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Hands-on Session 10:

Rod-impacting-plate problem

New working directory: 
hex_johnson_cook_death_particles

Presto: Using Johnson-Cook material model 
w/ element death, conversion to particles

Ensight session
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New Working Directory

Create sub-directory in ‘training_rod_impacting_plate’ 
directory

% cd  ~/training_rod_impacting_plate

% mkdir  hex_johnson_cook_death_particles

Copy ‘taylor_hex.g’, ‘taylor_hex.i’ from 
‘hex_johnson_cook_death’ directory into new directory

% cp hex_johnson_cook_death/taylor_hex.g 
hex_johnson_cook_death_particles

% cp  hex_johnson_cook_death/taylor_hex.i  
hex_johnson_cook_death_particles

Move into new directory

% cd  hex_johnson_cook_death_particles
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Add ‘sph sections’ in sierra scope

(before the finite element model block)

Begin sph section sph_1
formulation = mass_particle
problem dimension = 3

End

Begin sph section sph_2
formulation = mass_particle
problem dimension = 3

End

Presto: Hex model with Johnson Cook 
Material Model, element death, particles
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Add particle conversion to element death block for 

Tungsten_Rod in Presto region scope:

Begin element death rod
block = block_1
death steps = 5

criterion is element value of \#
state_johnson_cook(2) >= .5

death on inversion = on

convert elements to particles with \# 
section = sph_1 material \#
tungsten_rod johnson_cook

End

Presto: Hex model with Johnson Cook 
Material Model, element death, particles
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Add particle conversion to element death block for 

Steel_Plate in Presto region scope

Begin element death plate
block = block_2
death steps = 5

criterion is element value of \#
state_johnson_cook(2) >= .5

death on inversion = on

convert elements to particles with \# 
section = sph_2 material \# 
steel_plate johnson_cook

End

Presto: Hex model with Johnson Cook 
Material Model, element death, particles
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Ensight8

Delete any spread results files

Post process in Ensight8 

File > Open … > taylor_hex.e* > OK

Select Block ID 3 – hex8, toggle visibility

Select Node sets and Side sets, toggle visibility

Select Case 1

Select Displacements       > Displace by displ_vec > 
Close

Select Failed Elements       > Element variable > 
death_status < 0.5      > Apply

Flipbook Animation        > Load

Note: Paraview and/or Presto could be enhanced to view a 
series of results files (on the list of things-to-do)
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Hands-on Session 11:

Rod-impacting-plate problem

New working directory: 
hex_johnson_cook_death_particles_interaction

Presto: Using Johnson-Cook material model w/ 
element death, conversion to particles, particle-
to-element interaction

Ensight session
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New Working Directory

Create sub-directory in ‘training_rod_impacting_plate’ 
directory

% cd  ~/training_rod_impacting_plate

% mkdir hex_johnson_cook_death_particles_interaction

Copy ‘taylor_hex.g’, ‘taylor_hex.i’ from 
‘hex_johnson_cook_death_particles’ directory into new 
directory

% cp hex_johnson_cook_death_particles/taylor_hex.g 
hex_johnson_cook_death_particles_interaction

% cp  hex_johnson_cook_death_particles/taylor_hex.i  
hex_johnson_cook_death_particles_interaction

Move into new directory

% cd  hex_johnson_cook_death_particles_interaction



Sierra solid mechanics training Sandia National Laboratories
Solid Mechanics

Replace surface definition w/ block skinning in contact 
definition block: 

Begin contact definition acme

contact surface block_1 contains block_1
contact surface block_2 contains block_2

Skin all blocks = on

…

End contact definition acme

Presto: Hex model with Johnson Cook Material 
Model, element death, particles, interaction
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Presto: Hex model with Johnson Cook Material 
Model, element death, particles, interaction

Add particles to be automatically skinned & add to 
contact definition as a node set

Begin contact definition acme

Skin all blocks = on

contact node set sph_nodes1 contains \# 
block_1_particles_nodes sphere \#
radius = 0.01 icosahedron

contact node set sph_nodes2 contains \# 
block_2_particles_nodes sphere \# 
radius = 0.01 icosahedron

…

End contact definition acme
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Presto: Hex model with Johnson Cook Material 
Model, element death, particles, interaction

Invoke contact search tolerances in contact 
definition block: 

Begin contact definition acme

…

begin search options

normal tolerance = 0.002

tangential tolerance = 0.002

end 

…

End contact definition acme
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Presto: Hex model with Johnson Cook Material 
Model, element death, particles, interaction

Invoke higher accuracy for contact enforcement in 
contact definition block: 

Begin contact definition acme
…

begin search options

normal tolerance = 0.002

tangential tolerance = 0.002

end
begin enforcement options

momentum balance iterations = 10

end 
…

End contact definition acme
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Presto: Hex model with Johnson Cook Material 
Model, element death, particles, interaction

Add contact interactions to be considered for block_1

Begin contact definition acme

…
Begin interaction
master = block_1
slave = sph_nodes1

end
begin interaction

master = block_1
slave = sph_nodes2

end interaction

End contact definition acme
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Presto: Hex model with Johnson Cook Material 
Model, element death, particles, interaction

Add contact interactions to be considered for block_2

Begin contact definition acme

…
Begin interaction
master = block_2
slave = sph_nodes1

end
begin interaction

master = block_2
slave = sph_nodes2

end interaction

End contact definition acme
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Presto: Hex model with Johnson Cook Material 
Model, element death, particles, interaction

Add contact interactions to be considered for block_3

Begin contact definition acme

…
Begin interaction
master = block_3
slave = sph_nodes1

end
begin interaction

master = block_3
slave = sph_nodes2

end interaction

End contact definition acme

Here is where the 
symmetry_plane 
is needed
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Ensight8

Delete any spread results files

Post process in Ensight8 

 File > Open … > taylor_hex.e* > OK

 Select Block ID 3 – hex8, toggle visibility

 Select Node sets and Side sets, toggle visibility

 Select Case 1

 Select Displacements        > Displace by displ_vec > 
Close

 Select Failed Elements      > Element variable > 
death_status < 0.5      > Apply

 Flipbook Animation         > Load

To display shaded contours and mesh use the following  
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Solid Mechanics

Hands-on Session 12:

Rod-impacting-plate problem

New working directory: hex_johnson_cook_sph

SEACAS mesh tools: Generate SPH particles

Presto: Using SPH model for the rod

Ensight session
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New Working Directory

Create sub-directory in ‘training_rod_impacting_plate’ 
directory

% cd  ~/training_rod_impacting_plate

% mkdir hex_johnson_cook_sph

Copy ‘taylor_hex.g’, ‘taylor_hex.i’ (& rename) from 
‘hex_johnson_cook_death_particles_interaction’ directory 
into new directory

% cp hex_johnson_cook_death_particles_interaction/ 
taylor_hex.g  hex_johnson_cook_sph

% cp hex_johnson_cook_death_particles_interaction/ 
taylor_hex.i   hex_johnson_cook_sph/ 
taylor_hex_sph.i 

Move into new directory: % cd  hex_johnson_cook_sph
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SEACAS meshing tools: Rod as SPH

Create genesis file of rod only

% grepos  taylor_hex.g  b1.g
list blocks
delete mat 2 3
exit

Create genesis file of plate and contact_plate

% grepos  taylor_hex.g  b23.g
list blocks
delete mat 1
exit
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SEACAS meshing tools: Rod as SPH

Create SPH “mesh” for Rod 
note: b1.sph1 will be an exodusI file (hence the conversion),
nodeset 1 gets automatically created (matches block 1)

% sphgen3d   b1.g   b1.sph1

% ex1ex2v2   b1.sph1   b1sph.g

Combine genesis files

% gjoin2

First input file > b1sph.g
Second input file > b23.g
Equivalance or Command (Enter Help for info) ? End
Finish
Output file > taylor_hex_sph.g
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Presto: Rod as SPH

Add an SPH section in the sierra scope 
(before the finite element model block):

Begin sph section sph_rod
sphere initial radius = 0.05
problem dimension = 3
constant sphere radius

End
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Presto: Rod as SPH

Sierra scope:  database name must now refer to 
‘taylor_hex_sph.g’ in the  finite element model block:

Begin finite element model \# 
rod_impacting_plate

database name = taylor_hex_sph.g
…

End 

Presto region scope: change output database name

Begin results output rod_impacting_plate

database name = taylor_hex_sph.e
…

End
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Presto: Rod as SPH

Use the SPH section in the parameters for block 1 in the 
finite element model block :

Begin finite element model \#
rod_impacting_plate

…

begin parameters for block block_1
material johnson_cook(or Tungsten_Rod)
section = sph_rod
Solid Mechanics use model johnson_cook

end
…

End 
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Presto: Rod as SPH

Comment out  (or delete) element death block for 
Tungsten_Rod in Presto region scope:

# Begin element death rod
#  block = block_1
#  death steps = 5

#  criterion is element value of \#
#    state_johnson_cook(2) >= .5
#  death on inversion = on

#  convert elements to particles with \#
# section = sph_1 material \# 
# tungsten_rod johnson_cook

#  End



Sierra solid mechanics training Sandia National Laboratories
Solid Mechanics

Presto: Rod as SPH

Add SPH to contact definition :

Begin contact definition acme

Contact node set sph_nodes contains \#   
nodelist 1 (or nodelist_1)

…

Begin interaction 
master = block_2
slave = sph_node (or sph_nodes)

End

Begin interaction 
master = block_3
slave = sph_node (or sph_nodes)

End
…

End contact definition acme
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Presto: Rod as SPH

Comment out (or delete) any reference to ’sph_nodes1’ in 
the contact definition :

Begin contact definition acme

contact node set sph_nodes1 contains \#    
block_1_particles_nodes sphere \#  
radius = 0.01 icosahedron

Begin interaction
master = block_1
slave = sph_nodes1

end

…

End contact definition acme

etc…
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Presto: Rod as SPH

Run Presto

% sierra presto –i taylor_hex_sph.i –V presto_2.7beta
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Solid Mechanics

Hands-on Session 13:

Rod-impacting-plate problem

New working directory: hex_concrete

Cubit session: using journal file

Presto: verify already existing input file w/ KC-
concrete model, element death

Ensight session
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New Working Directory

Create sub-directory in ‘training_rod_impacting_plate’ 
directory

% cd  ~/training_rod_impacting_plate

% mkdir hex_concrete

Copy ‘concrete_no_rebar.jou’, ‘concrete_no_rebar.i’ into 
new directory

% cp concrete_no_rebar.jou  hex_concrete

% cp  concrete_no_rebar.i   hex_concrete

Move into new directory

% cd  hex_concrete
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Rod Impacting Concrete Panel

Steel rod
w/ Prescribed Displacement
Block_1

Concrete
6″ x 6″ x ¾ ″
Block_2 

Back side of Plate is simply-supported along the 
perimeter of a 4″ x 4″ square (centered)

Reinforcement
Block_3 
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Cubit: Creating mesh of Rod & Plate  
using Journal File

Create genesis file w/ Cubit journal file:

% cubit concrete_no_rebar.jou
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Verify in sierra scope:  finite element model block 

must refer to ‘concrete_no_rebar.g’ 

Begin finite element model \#
rod_impacting_plate

database name = concrete_no_rebar.g
…

end 

Run Presto

% sierra presto –i concrete_no_rebar.i –V 2.7beta

Presto: Rod Impacting Concrete Panel
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Ensight

Delete any spread results files

% Ensight8

 File > Open … > concrete_no_rebar.e > Set file > 
concrete_no_rebar.e* > Load All

 Select Node sets and Side sets, toggle visibility

 Select Case 1

 Select Displacements > Displace by displ_vec > Close

 Select Failed Elements > Element variable > 
death_status < 1.0 > Apply

 Flipbook Animation > Load
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Solid Mechanics

Hands-on Session 14:

Rod-impacting-plate problem

New working directory: hex_concrete_rebar

Cubit session: using journal file w/ rebar along 
mesh edges

Presto: modify input file for rebar

Ensight session
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New Working Directory

Create sub-directory in ‘training_rod_impacting_plate’ 
directory

% cd  ~/training_rod_impacting_plate

% mkdir hex_concrete_rebar

Copy ‘concrete_rebar.jou’, 
‘hex_concrete/concrete_no_rebar.i’ into new directory

% cp concrete_rebar.jou  hex_concrete_rebar

% cp hex_concrete/concrete_no_rebar.i   
hex_concrete_rebar/concrete_rebar.i

Move into new directory

% cd  hex_concrete_rebar
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Cubit: Creating mesh of Rod, Plate & 
Coincident Rebar using Journal File

Create genesis file w/ Cubit journal file:

% cubit concrete_rebar.jou
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Add rod_block section in sierra scope:

Begin beam section rod_block

…

end 

Add parameters for block 3 in finite element 
model block:

Begin parameters from(for) block block_3

Material steel

Solid mechanics use model 
elastic_plastic

Section = rod_block

End parameters from(for) block block_3

Presto: Rod Impacting Concrete Panel 
w/ coincident rebar
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Run Presto

% sierra presto –i concrete_rebar.i –V 2.7beta

Presto: Rod Impacting Concrete Panel 
w/ coincident rebar
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Ensight

Delete any spread results files

% Ensight8

 File > Open … > concrete_rebar.e > Set file > 
concrete_rebar.e* > Load All

 Select Node sets and Side sets, toggle visibility

 Select Case 1

 Select Displacements > Displace by displ_vec > Close

 Select Failed Elements > Element variable > 
death_status < 1.0 > Apply

 Flipbook Animation > Load
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Solid Mechanics

Hands-on Session 15:

Rod-impacting-plate problem

New working directory: 
hex_concrete_rebar_embedded

SEACAS mesh tools: rebar embedded in 
concrete mesh

Presto: modify input file for rebar-concrete bond 
model

Ensight session
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New Working Directory

Create sub-directory in ‘training_rod_impacting_plate’ 
directory

% cd  ~/training_rod_impacting_plate

% mkdir hex_concrete_rebar_embedded

Copy ‘concrete_rebar.g’, ‘concrete_rebar.i’ (& rename) from 
hex_concrete directory into new directory

% cp hex_concrete/concrete_rebar.g   
hex_concrete_rebar_embedded

% cp hex_concrete/concrete_rebar.i   
hex_concrete_rebar_embedded/ 
concrete_rebar_embedded.i

Move into new directory
% cd  hex_concrete_rebar_embedded
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SEACAS meshing tools: Rebar 
Embedded in Concrete

Create genesis file of rebar only

% grepos concrete_rebar.g b3.g
list blocks
delete mat 1 2
exit

Create genesis file of Concrete plate and rod

% grepos concrete_rebar.g b12.g
list blocks
delete mat 3
exit
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SEACAS meshing tools: Rebar 
Embedded in Concrete

Combine genesis files

% gjoin2

First input file > b12.g
Second input file > b3.g
Equivalance or Command (Enter Help for info) ? End
Finish
Output file > concrete_rebar_embedded.g



Sierra solid mechanics training Sandia National Laboratories
Solid Mechanics

Add to rod_block section in sierra scope:

Begin beam section rod_block

bond model = rebar_concrete

End

Modify finite element model block in sierra scope 

to refer to ‘concrete_rebar_embedded.g’ 

Begin finite element model \#
rod_impacting_plate

database name = \#  
concrete_rebar_embedded.g

…
end 

Presto: Rod Impacting Concrete Panel 
w/ Embedded Rebar
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Add to bond model type in Presto region scope:

Begin bond model rebar_concrete

model type = NO_SLIP

End bond model rebar_concrete

Add rebar-concrete interaction in Presto region scope:

Begin reinforcement interaction rc

matrix = block_2

reinforcement = block_3

End reinforcement interaction rc

Presto: Rod Impacting Concrete Panel 
w/ Embedded Rebar
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Presto region scope: Change output database name & 

request bond force in  results output block

Begin results output <name>

database name = \# 
concrete_rebar_embedded.e

nodal variables = BOND_FORCE as FBOND

element variables = BOND_TRACTION \# 
as BOND_STRESS

…
End

Presto: Rod Impacting Concrete Panel 
w/ Embedded Rebar
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Run Presto

% sierra presto –i concrete_rebar_embedded.i  \#        
–V 2.7beta

Presto: Rod Impacting Concrete Panel 
w/ rebar coincident
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Ensight

Delete any spread results files

% Ensight8

 File > Open … > concrete_rebar.e > Set file > 
concrete_rebar.e* > Load All

 Select Node sets and Side sets, toggle visibility

 Select Case 1

 Select Displacements > Displace by displ_vec > Close

 Select Failed Elements > Element variable > 
death_status < 1.0 > Apply

 Flipbook Animation > Load


