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To Follow Along…

•Install ParaView 3.2.

–http://www.paraview.org/New/download.html

•Get example material.

– http://www.paraview.org/Wiki/SC07_ParaView_Tutorial

–Also available on tutorial CD.

http://www.paraview.org/Wiki/SC07_ParaView_Tutorial
http://www.paraview.org/New/download.html


Introduction



What is ParaView?

•An open-source, scalable, multi-
platform visualization application.

•Support for distributed computation 
models to process large data sets.

•An open, flexible, and intuitive user 
interface.

•An extensible, modular architecture 
based on open standards.

•Commercial maintenance and support.



Current ParaView Usage

•Used by academic, government, and 
commercial institutions worldwide.

–Downloaded 5K-10K times/month.

•Used for all ranges of data size.

•Current landmarks of SNL usage:

–6 billion structured cells.

–250 million unstructured cells.



ParaView Application Architecture

MPIOpenGL IceT Etc.

VTK

ParaView Server

ParaView Client pvpython Custom App

UI (Qt Widgets, Python Wrappings)



ParaView Development

•Started in 2000 as collaborative effort 
between Los Alamos National Laboratories 
and Kitware Inc. (lead by James Ahrens).

–ParaView 0.6 released October 2002.

•September 2005: collaborative effort between 
Sandia National Laboratories, Kitware Inc. 
and CSimSoft to rewrite user interface to be 
more user friendly and develop quantitative 
analysis framework.

–ParaView 3.0 released in May 2007.



Current Funding

• Army SBIR

• ERDC Contract

• US NSF SBIR

• Other contributors

– Swiss National 
Supercomputing Centre

• Support Contracts

– Electricity de France

– Mirarco

– Oil Industry



Basics of Visualization



Data Types

Uniform Rectilinear
(Image Data)

Non-Uniform Rectilinear
(Rectilinear Data)

Curvilinear
(Structured Data)

Polygonal
(Poly Data)

Unstructured Grid

Multi-block
Hierarchical Adaptive 

Mesh Refinement 
(AMR)

Hierarchical Uniform 
AMR

Octree



More Information

•Online Help

•The ParaView Guide

•The ParaView web page

–www.paraview.org

http://www.paraview.org/


Basic Usage



User Interface

Menu Bar

Toolbars

Pipeline Browser

Object Inspector

3D View



Getting Back GUI Components



Creating a Cylinder Source

1. Go to the Source menu and select 
Cylinder.

2. Click the Apply button to accept the 
default parameters.



Simple Camera Manipulation

•Drag left, middle, right buttons for 
rotate, pan, zoom.

–Also use Shift, Ctrl, Alt modifiers.



Creating a Cylinder Source

1. Go to the Source menu and select 
Cylinder.

2. Click the Apply button to accept the 
default parameters.

3. Increase the Resolution parameter.

4. Click the Apply button again.



Pipeline Object Controls



Undo Redo

Undo Redo

Camera
Undo

Camera
Redo



Render View Options



Display Tab



Creating a Cylinder Source

1. Go to the Source menu and select 
Cylinder.

2. Click the Apply button to accept the 
default parameters.

3. Increase the Resolution parameter.

4. Click the Apply button again.

5. Delete the Cylinder.



Supported Data Types
• ParaView Data (.pvd)
• VTK (.vtp, .vtu, .vti, .vts, .vtr)
• VTK Multi Block (.vtm, .vtmb, 

.vtmg, .vthd, .vthb)
• Partitioned VTK (.pvtu, .pvti, 

.pvts, .pvtr)
• VTK Legacy (.vtk)
• Exodus
• XDMF (.xmf, .xdmf)
• LS-DYNA
• SpyPlot CTH
• EnSight (.case, .sos)
• BYU (.g)
• Protein Data Bank (.pdb)
• XMol Molecule

• PLOT3D
• Digital Elevation Map (.dem)
• VRML (.wrl)
• PLY Polygonal File Format
• Stereo Lithography (.stl)
• Gaussian Cube File (.cube)
• POP Ocean Files
• AVS UCD (.inp)
• Meta Image (.mhd, .mha)
• Facet Polygonal Data
• Phasta Files (.pht)
• PNG Image Files
• Raw Image Files
• Comma Separated Values 

(.csv)



Load disk_out_ref.ex2

1. Open the file disk_out_ref.ex2.

2. Load all data variables.

3. Click 



Data Representation

Toggle Color
Legend Choose Variable Choose Representation



Calculator

Contour

Clip

Slice

Threshold

Extract Subset

Common Filters

Glyph

Stream Tracer

Warp (vector)

Group Datasets

Extract Group



Filters Menu



Apply a Filter

1. Make sure that disk_out_ref.ex2 is 
selected in the pipeline browser.

2. Select the contour filter.



Apply a Filter

3. Change parameters to create an 
isosurface at Temp = 400K.

Change to Temp

Change to 400



Apply a Filter

1. Make sure that disk_out_ref.ex2 is 
selected in the pipeline browser.

2. Select the contour filter.

3. Change parameters to create an 
isosurface at Temp = 400K.

4.



Create a Cutaway Surface

1. Select disk_out_ref.ex2 in the
pipeline browser.

2. From the menu bar, select Filters →
Alphabetical → Extract Surface.

3.



Create a Cutaway Surface

1. Select disk_out_ref.ex2 in the
pipeline browser.

2. From the menu bar, select Filters →
Alphabetical → Extract Surface.

3.

4. Create a clip filter.

5. Uncheck Show Plane.

6.



Pipeline Browser Structure

Disk_out_ref.ex2

Contour1DataSetSurfaceFilter1

Clip1



Multiview



Multiview

1. Split the view horizontally.

2. Make disk_out_ref.ex2 visible.

3. Color surface by Temp.



Multiview

1. Split the view horizontally.

2. Make disk_out_ref.ex2 visible.

3. Color surface by Temp.

4. Add clip filter.

5. Uncheck Show Plane.

6.



Multiview

1. Split the view horizontally.

2. Make disk_out_ref.ex2 visible.

3. Color surface by Temp.

4. Add clip filter.

5. Uncheck Show Plane.

6.

7. Right-click view, Link Camera…

8. Click other view.



Multiview

1. Split the view horizontally.

2. Make disk_out_ref.ex2 visible.

3. Color surface by Temp.

4. Add clip filter.

5. Uncheck Show Plane.

6.

7. Right-click view, Link Camera…

8. Click other view.

9. Click 



Modifying Views



Modifying Views



Streamlines

1. Split view vertically,      maximize

2. Make disk_out_ref.ex2 visible

3. Select disk_out_ref.ex2.

4. Add stream tracer.

5.



Streamlines

1. Split view vertically,      maximize

2. Make disk_out_ref.ex2 visible

3. Select disk_out_ref.ex2.

4. Add stream tracer.

5.

6. Select Filters → Alphabetical → Tube

7.



Getting Fancy

1. Select StreamTracer1.

2. Add glyph filter.

3. Change Glyph Type to Cone.

4.



Getting Answers

•Where is the air moving the fastest?  
Near the disk or away from it?  At the 
center of the disk or near its edges?

•Which way is the plate spinning?

•At the surface of the disk, is air moving 
toward the center or away from it?



Selection

Surface Cell Selection

Surface Point Selection

Through Cell Selection

Through Point Selection



Selection Inspector



Extracting a Selection

1. Perform a through cell selection.

2. Filters → Data Analysis → Extract 
Selection

3. Click the Copy Active Selection 

4.



Extracting a Selection

1. Perform a through cell selection.

2. Filters → Data Analysis → Extract 
Selection

3. Click the Copy Active Selection.

4.

5. Delete ExtractSurface1 when done.



Geometry Representations

Points Wireframe Surface Surface
with Edges

Volume



Volume Rendering

1. Select view with temp on clipped 
mesh.

2. Delete visible clip filter.

3. Make sure disk_out_ref.ex2 selected.

4. Change variable viewed to Temp.

5. Change representation to Volume.



Volume Rendering +
Surface Geometry

1. Select view showing streamlines.

2. Make disk_out_ref.ex2 visible.

3. Change variable viewed to Temp.

4. Change representation to Volume.



Transfer Function Editor



Plotting

1. Select disk_out_ref.ex2

2. Filters → Data Analysis → Plot Over 
Line 



3D Widgets



Plotting

1. Select disk_out_ref.ex2

2. Filters → Data Analysis → Plot Over 
Line.

3. Once line satisfactorily located,



Interacting with Plots

•Left, middle, right buttons to pan, zoom.

•Reset view to plot ranges.



Plots are Views

•Move them like Views.

•Save screenshots (+ vector pdf).



Histogram / Bar Chart

1. Select disk_out_ref.ex2.

2. Filters → Data Analysis → Histogram

3.



Reset ParaView



Loading Data with Time

1. Open the file can.ex2.

2. Select all variables.

3.

4.

5.



Animation Toolbar

First
Frame

Previous
Frame

Play
Next

Frame
Last

Frame
Loop

Animation
Current

Time
Current

Time Step



Animation Pitfall

1. Go to first time step.

2. Turn on EQPS variable.

3. Turn on color legend.

4. Play     (or skip to last time step     ).



Animation Pitfall

1. Go to first time step.

2. Turn on EQPS variable.

3. Turn on color legend.

4. Play     (or skip to last time step     ).

5. Fix with Rescale to Data Range in 
Display tab.



Animation View

View → Animation View 



Animation View

View → Animation View 

Animation Modes: Sequence, Real Time, 
and Snap To TimeSteps



Changing Animation Timing

1. Change animation mode to Real 
Time.  

• Default animation time is 10 sec.

2.



Changing Animation Timing

1. Change animation mode to Real 
Time.  

• Default animation time is 10 sec.

2.

3. Change animation time to 30 sec.

4. again.



Smoothing the Animation

1. Filters → Alphabetical → Temporal 
Interpolator

2.



Adding Text Annotation

1. Sources → Text 

2. Type a message in text edit box

3.



Text Position



Annotate Time

1. Sources → Annotate Time 

2.



Annotate Time

1. Sources → Annotate Time 

2.

3. Select can.ex2

4. Filters → Alphabetical → Annotate 
Time 

5.

6. Move annotation around.



Reset ParaView



Make an Animation

1. Sources → Sphere, 

2. Make animation view visible.

3. Change No. Frames to 50.

4. Select SphereSource1, Start Theta



Make an Animation

1. Sources → Sphere, 

2. Make animation view visible.

3. Change No. Frames to 50.

4. Select SphereSource1, Start Theta

5. Double-click SphereSource1 – Start Theta 

6. Make New keyframe.

7. First keyframe→360, second keyframe→0.

8. Click OK.



Animating Two Properties

1. Open SphereSource1 – Start Theta.

2. Delete the first track (at time step 0).

3. Click OK.

4. Create SphereSource1 – End Theta.

5. Open SphereSource1 – End Theta.

6. Change second key frame time to 
0.5.



Scripting Options

•Tools → Python Shell 

•Filters → Data Analysis → 
Programmable Filter 

•pvpython, pvbatch



Visualizing Large Models



Golevka Asteroid vs. 
10 Megaton Explosion

•CTH shock physics, over 1 billion cells



Polar Vortex Breakdown

•SEAM Climate Modeling, 1 billion cells 
(500 million cells visualized).



Objects-in-Crosswind Fire

•Coupled SIERRA/Fuego/Syrinx/Calore, 
10 million unstructured hexahedra



ParaView Architecture

•Three tier

–Data Server

–Render Server

–Client



Standalone

Client

Data
Server

Render
Server



Client-Server

Client
Data

Server
Render
Server



Client-Render Server-Data Server

Client
Data

Server
Render
Server



Requirements for
Installing ParaView Server

•C++

•CMake (www.cmake.org)

•MPI

•OpenGL (or Mesa3D www.mesa3d.org)

•Qt 4.2.3 (optional)

•Python (optional)
• http://www.paraview.org/Wiki/Setting_up_a_ParaView_Server#Compiling

http://www.paraview.org/Wiki/Setting_up_a_ParaView_Server#Compiling
http://www.mesa3d.org/
http://www.cmake.org/


Connecting to a ParaView Server

http://www.paraview.org/Wiki/Setting_up_a_ParaView_Server#Running_the_Server

http://www.paraview.org/Wiki/Setting_up_a_ParaView_Server#Running_the_Server


Data Parallel Pipelines

•Duplicate pipelines run independently 
on different partitions of data.



Data Parallel Pipelines

•Duplicate pipelines run independently 
on different partitions of data.



Data Parallel Pipelines

•Some operations will work regardless.

–Example: Clipping.



Data Parallel Pipelines

•Some operations will work regardless.

–Example: Clipping.



Data Parallel Pipelines

•Some operations will work regardless.

–Example: Clipping.



Data Parallel Pipelines

•Some operations will have problems.

–Example: External Faces



Data Parallel Pipelines

•Some operations will have problems.

–Example: External Faces



Data Parallel Pipelines

•Ghost cells can solve most of these 
problems.



Data Parallel Pipelines

•Ghost cells can solve most of these 
problems.



Data Partitioning

•Partitions should be load balanced and 
spatially coherent.



Data Partitioning

•Partitions should be load balanced and 
spatially coherent.



Data Partitioning

•Partitions should be load balanced and 
spatially coherent.



Load Balancing/Ghost Cells

•Automatic for Structured Meshes.

•Partitioning/ghost cells for unstructured 
is “manual.”

•Use the D3 filter for unstructured

– (Filters → Alphabetical → D3)



Job Size Rules of Thumb

•Structured Data

–Try for max 20 M cell/processor.

–Shoot for 5 – 10 M cell/processor.

•Unstructured Data

–Try for max 1 M cell/processor.

–Shoot for 250 – 500 K cell/processor.



Avoiding Data Explosion

•Pipeline may cause data to be copied, 
created, converted.

•This advice only for dealing with very 
large amounts of data.

–Remaining available memory is low.



Topology Changing, No Reduction
• Append Datasets

• Append Geometry

• Clean

• Clean to Grid

• Connectivity

• D3

• Delaunay 2D

• Extract Edges

• Linear Extrusion

• Loop Subdivision

• Reflection

• Rotational Extrusion

• Shrink

• Smooth

• Subdivide

• Tessellate

• Tetrahedralize

• Triangle Strips

• Triangulate



Topology Changing,
Moderate Reduction

•Clip 

•Decimate

•Extract Cells by 
Region

•Extract Selections

•Extract Thresholds

•Quadric Clustering

•Threshold 

Similar: Extract Subset



Topology Changing,
Dimension Reduction

•Cell Centers

•Contour 

•Extract CTH Parts

•Extract Surface

•Feature Edges

•Mask Points

•Outline (curvilinear)

•Slice 

•Stream Tracer 



Adds Field Data
• Calculator 

• Cell Data to Point Data

• Curvature

• Elevation

• Gradient

• Gradient (Unstructured)

• Gradient Magnitude

• Level Scalars

• Median

• Mesh Quality

• Normals Generation

• Octree Depth Limit

• Octree Depth Scalars

• Point Data to Cell Data

• Process Id Scalars

• Random Vectors

• Resample with dataset

• Surface Flow

• Surface Vectors

• Transform

• Warp (scalar)

• Warp (vector)



Total Shallow Copy or
Output Independent of Input

• Annotate Time

• Append Attributes

• Extract Datasets

• Extract Group 

• Glyph 

• Group Datasets 

• Histogram

• Integrate Variables

• Outline

• Outline Corners

• Plot Cell over Time

• Plot Field Variable over 
Time

• Plot Over Line

• Plot Point over Time

• Probe Location

• Probe Location over 
Time

• Temporal Shift Scale



Special Cases

•Temporal Filters

–Temporal Interpolator

–Particle Tracer

–Temporal Cache

•Programmable Filter



Culling Data

•Reduce dimensionality early.

–Contour and slice “see” inside volumes.

•Prefer data reduction of extraction.

–Slice instead of Clip.

–Contour instead of Threshold.

•Only extract when reducing an order of 
magnitude or more.

–Can still run into troubles.



Culling Data

•Experiment with subsampled data.

–Extract Subset

•Use caution.

–Subsampled data may be lacking.

–Use full data to draw final conclusions.



Rendering Modes

•Still Render

–Full detail render.

•Interactive Render

–Sacrifices detail for speed.

–Provides quick rendering rate.

–Used when interacting with 3D view.



Level of Detail (LOD)

•Geometric decimation.

•Used only with Interactive Render

Original Data Divisions: 50x50x50 Divisions: 10x10x10



3D Rendering Parameters

Edit → Settings, Render View → General 



Parallel Rendering



Parallel Rendering



Tiled Displays



Parallel Rendering Parameters

Edit → Settings, Render View → Server 



Parameters for Large Data

•Use Immediate Mode Rendering on.

•Use Triangle Strips off.

•Try LOD Threshold off.

–Also try LOD Resolution 10x10x10.

•Always have remote rendering on.

•Turn on subsampling.

–Try larger subsampling rates.

•Squirt Compression on.



Further Reading

•Amy Henderson Squillacote.  The 
ParaView Guide.  Kitware, Inc., 2006.

•http://www.paraview.org/Wiki/ParaView

• http://www.paraview.org/Wiki/Setting_up_a_ParaView_Server

http://www.paraview.org/Wiki/Setting_up_a_ParaView_Server
http://www.paraview.org/Wiki/Setting_up_a_ParaView_Server
http://www.paraview.org/Wiki/ParaView


Further Reading
Visualization and Customization

•Will Schroeder, Ken Martin, and Bill 
Lorensen.  The Visualization Toolkit.  
Kitware, Inc., fourth edition, 2006. 

•Kitware Inc.  The VTK User’s Guide.  
Kitware, Inc., 2006.

•Jasmin Blanchette and Mark 
Summerfield.  C++ GUI Programming 
with Qt 4.  Prentice Hall, 2006.



Further Reading
Parallel VTK Topics

• James Ahrens, Charles Law, Will Schroeder, Ken 
Martin, and Michael Papka.  “A Parallel Approach for 
Efficiently Visualizing Extremely Large, Time-Varying 
Datasets.”  Technical Report #LAUR-00-1620, Los 
Alamos National Laboratory, 2000.

• James Ahrens, Kristi Brislawn, Ken Martin, Berk 
Geveci, C. Charles Law, and Michael Papka.  “Large-
Scale Data Visualization Using Parallel Data 
Streaming.”  IEEE Computer Graphics and 
Applications, 21(4): 34–41, July/August 2001.

• Andy Cedilnik, Berk Geveci, Kenneth Moreland, 
James Ahrens, and Jean Farve.  “Remote Large 
Data Visualization in the ParaView Framework.”  
Eurographics Parallel Graphics and Visualization 
2006, pg. 163–170, May 2006.



Further Reading
Advanced Pipeline Execution

• James P. Ahrens, Nehal Desai, Patrick S. McCormic, 
Ken Martin, and Jonathan Woodring.  “A Modular, 
Extensible Visualization System Architecture for 
Culled, Prioritized Data Streaming.”  Visualization 
and Data Analysis 2007, Proceedings of SPIE-IS&T 
Electronic Imaging, pg 64950I-1–12, January 2007.

• John Biddiscombe, Berk Geveci, Ken Martin, 
Kenneth Moreland, and David Thompson.  “Time 
Dependent Processing in a Parallel Pipeline 
Architecture.” IEEE Visualization 2007.  October 
2007. 



Further Reading
Parallel Rendering

• Kenneth Moreland, Brian Wylie, and Constantine 
Pavlakos.  “Sort-Last Parallel Rendering for Viewing 
Extremely Large Data Sets on Tile Displays.”  
Proceedings of IEEE 2001 Symposium on Parallel 
and Large-Data Visualization and Graphics, pg. 85–
92, October 2001.

• Kenneth Moreland and David Thompson.  “From 
Cluster to Wall with VTK.”  Proceddings of IEEE 2003 
Symposium on Parallel and Large-Data Visualization 
and Graphics, pg. 25–31, October 2003.

• Kenneth Moreland, Lisa Avila, and Lee Ann Fisk.  
“Parallel Unstructured Volume Rendering in 
ParaView.”  Visualization and Data Analysis 2007, 
Proceedings of SPIE-IS&T Electronic Imaging, pg. 
64950F-1–12, January 2007.


