
Large Scale Visualization with ParaView

Supercomputing 09 Tutorial

November 15, 2009

Kenneth Moreland  John Greenfield  W. Alan Scott

Sandia National Laboratories

Utkarsh Ayachit  Berk Geveci

Kitware Inc.

Sandia is a multiprogram laboratory operated by Sandia Corporation, a Lockheed Martin Company,
for the United States Department of Energy’s National Nuclear Security Administration

under contract DE-AC04-94AL85000.

SAND2009-6208P



Outline

•Introduction

•Basic Usage

•Visualizing Large Models



To Follow Along…

•Install ParaView 3.6.
–http://www.paraview.org  Download

•Get example material.
– http://www.paraview.org/Wiki/The_ParaView_Tutorial

–Data also available on tutorial handout 
USB stick.

http://www.paraview.org/Wiki/The_ParaView_Tutorial
http://www.paraview.org


Introduction



What is ParaView?

•An open-source, scalable, multi-
platform visualization application.

•Support for distributed computation 
models to process large data sets.

•An open, flexible, and intuitive user 
interface.

•An extensible, modular architecture 
based on open standards.

•Commercial maintenance and support.



Current ParaView Usage

•Used by academic, government, and 
commercial institutions worldwide.

–Downloaded ~3K times/month.

•Used for all ranges of data size.

•Current landmarks of SNL usage:

–6 billion structured cells.

–Billions of AMR cells.

–250 million unstructured cells.



ParaView Application Architecture

MPIOpenGL IceT Etc.

VTK

ParaView Server

ParaView Client pvpython Custom App

UI (Qt Widgets, Python Wrappings)



ParaView Development

•Started in 2000 as collaborative effort 
between Los Alamos National Laboratories 
and Kitware Inc. (lead by James Ahrens).

–ParaView 0.6 released October 2002.

•September 2005: collaborative effort between 
Sandia National Laboratories, Kitware Inc. 
and CSimSoft to rewrite user interface to be 
more user friendly and develop quantitative 
analysis framework.

–ParaView 3.0 released in May 2007.



Current Funding

• ARL

• ERDC

• US Army (SBIR)

• US Air Force (STTR)

• ONR

• Support Contracts

– Electricity de France

– Microsoft

• Other contributors

– Swiss National 
Supercomputing Centre

– DOE SLAC

– Ohio State

– Mississippi State

– RPI



Basics of Visualization



Data Types

Uniform Rectilinear
(Image Data)

Non-Uniform Rectilinear
(Rectilinear Data)

Curvilinear
(Structured Data)

Polygonal
(Poly Data)

Unstructured Grid

Multi-block
Hierarchical Adaptive 

Mesh Refinement 
(AMR)

Hierarchical Uniform 
AMR

Octree



More Information

•Online Help

•The ParaView Guide

•The ParaView web page

–www.paraview.org

•ParaView mailing list

–paraview@paraview.org

mailto:paraview@paraview.org
http://www.paraview.org/


Basic Usage



User Interface

Menu Bar

Toolbars

Pipeline Browser

Object Inspector

3D View



Getting Back GUI Components



Creating a Cylinder Source

1. Go to the Source menu and select 
Cylinder.

2. Click the Apply button to accept the 
default parameters.



Simple Camera Manipulation

•Drag left, middle, right buttons for 
rotate, pan, zoom.

–Also use Shift, Ctrl, Alt modifiers.



Creating a Cylinder Source

1. Go to the Source menu and select 
Cylinder.

2. Click the Apply button to accept the 
default parameters.

3. Increase the Resolution parameter.

4. Click the Apply button again.



Pipeline Object Controls



Undo Redo

RedoUndo

Camera
Redo

Camera
Undo



Render View Options



Display Tab



Creating a Cylinder Source

1. Go to the Source menu and select 
Cylinder.

2. Click the Apply button to accept the 
default parameters.

3. Increase the Resolution parameter.

4. Click the Apply button again.

5. Delete the Cylinder.



Supported Data Types
• ParaView Data (.pvd)
• VTK (.vtp, .vtu, .vti, .vts, .vtr)
• VTK Multi Block (.vtm, .vtmb, 

.vtmg, .vthd, .vthb)
• Partitioned VTK (.pvtu, .pvti, 

.pvts, .pvtr)
• VTK Legacy (.vtk)
• Exodus
• XDMF (.xmf, .xdmf)
• LS-DYNA
• SpyPlot CTH
• EnSight (.case, .sos)
• netCDF (.ncdf, .nc)
• BYU (.g)
• Protein Data Bank (.pdb)
• XMol Molecule
• PLOT3D
• Digital Elevation Map (.dem)

• VRML (.wrl)
• PLY Polygonal File Format
• Stereo Lithography (.stl)
• Gaussian Cube File (.cube)
• POP Ocean Files
• AVS UCD (.inp)
• Meta Image (.mhd, .mha)
• Facet Polygonal Data
• Phasta Files (.pht)
• SESAME Tables
• MFIX (.RES)
• Fluent Case Files (.cas)
• OpenFOAM Files (.foam)
• Cosmology Files (.cosmo)
• PNG Image Files
• TIFF Image Files
• Raw Image Files
• Comma Separated Values 

(.csv)



Load disk_out_ref.ex2

1. Open the file disk_out_ref.ex2.

2. Load all data variables.

3. Click 



Data Representation
Toggle Color

Legend
Mapped
Variable

Representation
Vector

Component

Edit Colors

Reset Scalar
Range



Geometry Representations

Points Wireframe Surface Surface
with Edges

Volume



Calculator

Contour

Clip

Slice

Threshold

Extract Subset

Common Filters

Glyph

Stream Tracer

Warp (vector)

Group Datasets

Extract Group



Filters Menu



Quick Launch



Apply a Filter

1. Make sure that disk_out_ref.ex2 is 
selected in the pipeline browser.

2. Select the contour filter.



Apply a Filter

3. Change parameters to create an 
isosurface at Temp = 400K.

Change to Temp

Change to 400



Apply a Filter

1. Make sure that disk_out_ref.ex2 is 
selected in the pipeline browser.

2. Select the contour filter.

3. Change parameters to create an 
isosurface at Temp = 400K.

4.



Create a Cutaway Surface

1. Select disk_out_ref.ex2 in the
pipeline browser.

2. From the menu bar, select Filters →
Alphabetical → Extract Surface.

3.



Create a Cutaway Surface

1. Select disk_out_ref.ex2 in the
pipeline browser.

2. From the menu bar, select Filters →
Alphabetical → Extract Surface.

3.

4. Create a clip filter.

5. Uncheck Show Plane.

6.



Pipeline Browser Structure

Disk_out_ref.ex2

Contour1DataSetSurfaceFilter1

Clip1



Multiview



Reset ParaView



Multiview

1. Open disk_out_ref.ex2.  Load all 
variables.

2. Add clip filter.

3. Uncheck Show Plane.

4.

5. Color surface by Pres.



Multiview

1. Split the view horizontally.

2. Make Clip1 visible.

3. Color surface by Temp.



Multiview

1. Split the view horizontally.

2. Make Clip1 visible.

3. Color surface by Temp.

4. Right-click view, Link Camera…

5. Click other view.



Multiview

1. Split the view horizontally.

2. Make Clip1 visible.

3. Color surface by Temp.

4. Right-click view, Link Camera…

5. Click other view.

6. Click 



Modifying Views



Modifying Views



Streamlines

1. Split view vertically,      maximize

2. Make disk_out_ref.ex2 visible

3. Select disk_out_ref.ex2.

4. Add stream tracer.

5.



Streamlines

1. Split view vertically,      maximize

2. Make disk_out_ref.ex2 visible

3. Select disk_out_ref.ex2.

4. Add stream tracer.

5.

6. Select Filters → Alphabetical → Tube

7.



Getting Fancy

1. Select StreamTracer1.

2. Add glyph filter.

3. Change Vectors to V.

4. Change Glyph Type to Cone.

5.



Getting Answers

•Where is the air moving the fastest?  
Near the disk or away from it?  At the 
center of the disk or near its edges?

•Which way is the plate spinning?

•At the surface of the disk, is air moving 
toward the center or away from it?



Plotting

1. Select disk_out_ref.ex2

2. Filters → Data Analysis → Plot Over 
Line. 



3D Widgets



Plotting

1. Select disk_out_ref.ex2

2. Filters → Data Analysis → Plot Over 
Line.

3. Once line satisfactorily located,



Interacting with Plots

•Left, middle, right buttons to pan, zoom.

•Reset view to plot ranges.



Plots are Views

•Move them like Views.

•Save screenshots (+ vector pdf).



Adjusting Plots

1. Place plot with view split, delete, 
resize, and swap.

2. In Display tab, turn off all variables 
except Temp and Pres.

3. Select Pres in the Display tab.

4. Change Chart Axis to Bottom – Right.



Adjusting Plots

1. Place plot with view split, delete, 
resize, and swap.

2. In Display tab, turn off all variables 
except Temp and Pres.

3. Select Pres in the Display tab.

4. Change Chart Axis to Bottom – Right.

Bonus Exercise: Use the streamlines filter
for vector visualization (handouts section 2.6).



Histogram / Bar Chart

1. Select disk_out_ref.ex2.

2. Filters → Data Analysis → Histogram

3. Change scalars to Temp.

4.



Geometry Representations

Points Wireframe Surface Surface
with Edges

Volume



Volume Rendering

1. Select view with temp on clipped 
mesh.

2. Delete visible clip filter.

3. Make sure disk_out_ref.ex2 selected.

4. Change variable viewed to Temp.

5. Change representation to Volume.



Volume Rendering +
Surface Geometry

1. Select view showing streamlines.

2. Make disk_out_ref.ex2 visible.

3. Change variable viewed to Temp.

4. Change representation to Volume.



Transfer Function Editor



Reset ParaView



Loading Data with Time

1. Open the file can.ex2.

2. Select all variables.

3.

4.

5.



Animation Toolbar

First
Frame

Previous
Frame

Play
Next

Frame
Last

Frame
Loop

Animation
Current

Time
Current

Time Step



Animation Pitfall

1. Go to first time step.

2. Turn on EQPS variable.

3. Turn on color legend.

4. Play     (or skip to last time step     ).



Animation Pitfall

1. Go to first time step.

2. Turn on EQPS variable.

3. Turn on color legend.

4. Play     (or skip to last time step     ).

5. Fix with Rescale to Data Range.



Selection

Surface Cell Selection

Surface Point Selection

Through Cell Selection

Through Point Selection

Block Selection

http://www.paraview.org/Wiki/Setting_up_a_ParaView_Server
http://www.mesa3d.org/
http://www.cmake.org/


Selection Inspector

Create new selection

Active selection
properties

Selected cells ids

Selection type

Selection display
Properties/Labeling

http://www.paraview.org/Wiki/Setting_up_a_ParaView_Server


Selections

1. Open the Selection Inspector (View →  
Selection Inspector).

2. Make various rubber-band selections.

3. Observe results in Selection 
Inspector.

4. Play with the Invert Selection and 
Show Frustum options.



Frustum vs. Id Selections

1. Make a Select Cells Through 

2. Turn on Show Frustum in Selection 
Inspector.  Rotate 3D view.

3. Play

4. Change the Selection Type to IDs.

5. Play 



Spreadsheet View

1. Split the view (    or    ).

2. In new view, click Spreadsheet View.



Spreadsheet View

Show only 
selected items

Select block 
to inspect

What is 
shown in 
the view

Attribute shown



Spreadsheet View

1. Split the view (    or    ).

2. In new view, click Spreadsheet View.

3. For Attribute, select Cell Data.

4. Find selected rows in spreadsheet.

5. In Display panel, turn on Show only 
selected elements.



Selecting in Spreadsheet View

1. Uncheck Show only selected 
elements.

2. Select a few rows in the spreadsheet.

3. Find selection in 3D view.

4. Click Cell Label tab in Selection 
Inspector.

5. Check Visible.

6. Change Label Mode to EQPS.



Plot Selection Over Time

1. Filters → Data Analysis → Plot 
Selection Over Time

2. Click Copy Active Selection in Object 
Inspector.

3.

4. In Display panel, select different 
blocks to plot.



Extracting a Selection

1. Turn off cell labels.

2. Perform a sizeable selection.

3. Filters → Data Analysis → Extract 
Selection

4. Click Copy Active Selection.

5.



Cleanup

1. Close the Selection Inspector.

2. Delete the Plot and Spreadsheet 
views.

3. Delete the PlotSelectionOverTime1 
and ExtractSelection1.



Animation View

View → Animation View 



Animation View

View → Animation View 

Animation Modes: Sequence, Real Time, 
and Snap To TimeSteps



Changing Animation Timing

1. Change animation mode to Real 
Time.  

• Default animation time is 10 sec.

2.



Changing Animation Timing

1. Change animation mode to Real 
Time.  

• Default animation time is 10 sec.

2.

3. Change animation time to 60 sec.

4. again.



Smoothing the Animation

1. Filters → Alphabetical → Temporal 
Interpolator

2. Change mode back to Real Time.

3. Split view.  Show can.ex2 in one and 
TemporalInterpolator1 in the other.  
Link the cameras.

4.



Adding Text Annotation

1. Sources → Text 

2. Type a message in text edit box

3.



Text Position



Annotate Time

1. Sources → Annotate Time 

2.



Annotate Time

1. Sources → Annotate Time 

2.

3. Select can.ex2

4. Filters → Alphabetical → Annotate 
Time 

5.

6. Move annotation around.



Reset ParaView



Make an Animation

1. Sources → Sphere, 

2. Make animation view visible.

3. Change No. Frames to 50.

4. Select Sphere1, Start Theta, press



Make an Animation

1. Sources → Sphere, 

2. Make animation view visible.

3. Change No. Frames to 50.

4. Select Sphere1, Start Theta, press

5. Double-click Sphere1 – Start Theta 

6. Make New keyframe.

7. First keyframe→360, second keyframe→0.

8. Click OK.



Animating Two Properties

1. Open Sphere1 – Start Theta.

2. Delete the first keyframe (at time 0).

3. Click OK.

4. Create Sphere1 – End Theta.

5. Open Sphere1 – End Theta.

6. Change second key frame time to 
0.5.



Visualizing Large Models



Golevka Asteroid vs. 
10 Megaton Explosion

•CTH shock physics, over 1 billion cells



Polar Vortex Breakdown

•SEAM Climate Modeling, 1 billion cells 
(500 million cells visualized).



Objects-in-Crosswind Fire

•Coupled SIERRA/Fuego/Syrinx/Calore, 
10 million unstructured hexahedra



Large Scale AMR



ParaView Architecture

•Three tier

–Data Server

–Render Server

–Client



Standalone

Client

Data
Server

Render
Server



Client-Server

Client
Data

Server
Render
Server



Client-Render Server-Data Server

Client
Data

Server
Render
Server



Requirements for
Installing ParaView Server

•C++

•CMake (www.cmake.org)

•MPI

•OpenGL (or Mesa3D www.mesa3d.org)

•Qt 4.3 (optional)

•Python (optional)
• http://www.paraview.org/Wiki/Setting_up_a_ParaView_Server#Compiling



Connecting to a ParaView Server

http://www.paraview.org/Wiki/Setting_up_a_ParaView_Server#Running_the_Server

http://www.paraview.org/Wiki/Setting_up_a_ParaView_Server
http://www.paraview.org/Wiki/Setting_up_a_ParaView_Server
http://www.paraview.org/Wiki/ParaView


Data Parallel Pipelines

•Duplicate pipelines run independently 
on different partitions of data.



Data Parallel Pipelines

•Duplicate pipelines run independently 
on different partitions of data.



Data Parallel Pipelines

•Some operations will work regardless.

–Example: Clipping.



Data Parallel Pipelines

•Some operations will work regardless.

–Example: Clipping.



Data Parallel Pipelines

•Some operations will work regardless.

–Example: Clipping.



Data Parallel Pipelines

•Some operations will have problems.

–Example: External Faces



Data Parallel Pipelines

•Some operations will have problems.

–Example: External Faces



Data Parallel Pipelines

•Ghost cells can solve most of these 
problems.



Data Parallel Pipelines

•Ghost cells can solve most of these 
problems.



Data Partitioning

•Partitions should be load balanced and 
spatially coherent.



Data Partitioning

•Partitions should be load balanced and 
spatially coherent.



Data Partitioning

•Partitions should be load balanced and 
spatially coherent.



Load Balancing/Ghost Cells

•Automatic for Structured Meshes.

•Partitioning/ghost cells for unstructured 
is “manual.”

•Use the D3 filter for unstructured

– (Filters → Alphabetical → D3)



Job Size Rules of Thumb

•Structured Data

–Try for max 20 M cell/processor.

–Shoot for 5 – 10 M cell/processor.

•Unstructured Data

–Try for max 1 M cell/processor.

–Shoot for 250 – 500 K cell/processor.



Avoiding Data Explosion

•Pipeline may cause data to be copied, 
created, converted.

•This advice only for dealing with very 
large amounts of data.

–Remaining available memory is low.



Topology Changing, No Reduction
• Append Datasets

• Append Geometry

• Clean

• Clean to Grid

• Connectivity

• D3

• Delaunay 2D/3D

• Extract Edges

• Linear Extrusion

• Loop Subdivision

• Reflect

• Rotational Extrusion

• Shrink

• Smooth

• Subdivide

• Tessellate

• Tetrahedralize

• Triangle Strips

• Triangulate



Topology Changing,
Moderate Reduction

•Clip 

•Decimate

•Extract Cells by 
Region

•Extract Selection

•Quadric Clustering

•Threshold 

Similar: Extract Subset



Topology Changing,
Dimension Reduction

•Cell Centers

•Contour 

•Extract CTH 
Fragments

•Extract CTH Parts

•Extract Surface

•Feature Edges

•Mask Points

•Outline (curvilinear)

•Slice 

•Stream Tracer 



Adds Field Data
• Block Scalars

• Calculator 

• Cell Data to Point Data

• Compute Derivatives

• Curvature

• Elevation

• Generate Ids

• Gen. Surface Normals

• Gradient

• Level Scalars

• Median

• Mesh Quality

• Octree Depth Limit

• Octree Depth Scalars

• Point Data to Cell Data

• Process Id Scalars

• Random Vectors

• Resample with dataset

• Surface Flow

• Surface Vectors

• Texture Map to…

• Transform

• Warp (scalar)

• Warp (vector)



Total Shallow Copy or
Output Independent of Input

• Annotate Time

• Append Attributes

• Extract Block

• Extract Datasets

• Extract Level 

• Glyph 

• Group Datasets 

• Histogram

• Integrate Variables

• Normal Glyphs

• Outline

• Outline Corners

• Plot Global Variables 
Over Time

• Plot Over Line

• Plot Selection Over 
Time

• Probe Location

• Temporal Shift Scale

• Temporal Snap-to-
Time-Steps

• Temporal Statistics



Special Cases

•Temporal Filters

–Temporal Interpolator

–Particle Tracer

–Temporal Cache

•Programmable Filter



Culling Data

•Reduce dimensionality early.

–Contour and slice “see” inside volumes.

•Prefer data reduction of extraction.

–Slice instead of Clip.

–Contour instead of Threshold.

•Only extract when reducing an order of 
magnitude or more.

–Can still run into troubles.



Culling Data

•Experiment with subsampled data.

–Extract Subset

•Use caution.

–Subsampled data may be lacking.

–Use full data to draw final conclusions.



Rendering Modes

•Still Render

–Full detail render.

•Interactive Render

–Sacrifices detail for speed.

–Provides quick rendering rate.

–Used when interacting with 3D view.



Level of Detail (LOD)

•Geometric decimation.

•Used only with Interactive Render

Original Data Divisions: 50x50x50 Divisions: 10x10x10



3D Rendering Parameters

Edit → Settings, Render View → General 



Parallel Rendering



Parallel Rendering



Tiled Displays



Image Size LOD

•ParaView’s parallel rendering overhead 
proportional to image size.

•Can use smaller images for interactive 
rendering.

Original Data Subsample Rate: 2 pixels Subsample Rate: 4 pixels Subsample Rate: 8 pixels



Parallel Rendering Parameters

Edit → Settings, Render View → Server 



Parameters for Large Data

•Use Immediate Mode Rendering on.

•Use Triangle Strips off.

•Try LOD Threshold off.

–Also try LOD Resolution 10x10x10.

•Always have remote rendering on.

•Turn on subsampling.

–Try larger subsampling rates.

•Squirt Compression on.



Further Reading

•Amy Henderson Squillacote.  The 
ParaView Guide.  Kitware, Inc., 2006.

•http://www.paraview.org/Wiki/ParaView

• http://www.paraview.org/Wiki/Setting_up_a_ParaView_Server



Further Reading
Visualization and Customization

•Will Schroeder, Ken Martin, and Bill 
Lorensen.  The Visualization Toolkit.  
Kitware, Inc., fourth edition, 2006. 

•Kitware Inc.  The VTK User’s Guide.  
Kitware, Inc., 2006.

•Jasmin Blanchette and Mark 
Summerfield.  C++ GUI Programming 
with Qt 4.  Prentice Hall, 2006.



Further Reading
Parallel VTK Topics

• James Ahrens, Charles Law, Will Schroeder, Ken 
Martin, and Michael Papka.  “A Parallel Approach for 
Efficiently Visualizing Extremely Large, Time-Varying 
Datasets.”  Technical Report #LAUR-00-1620, Los 
Alamos National Laboratory, 2000.

• James Ahrens, Kristi Brislawn, Ken Martin, Berk 
Geveci, C. Charles Law, and Michael Papka.  “Large-
Scale Data Visualization Using Parallel Data 
Streaming.”  IEEE Computer Graphics and 
Applications, 21(4): 34–41, July/August 2001.

• Andy Cedilnik, Berk Geveci, Kenneth Moreland, 
James Ahrens, and Jean Farve.  “Remote Large 
Data Visualization in the ParaView Framework.”  
Eurographics Parallel Graphics and Visualization 
2006, pg. 163–170, May 2006.



Further Reading
Advanced Pipeline Execution

• James P. Ahrens, Nehal Desai, Patrick S. McCormic, 
Ken Martin, and Jonathan Woodring.  “A Modular, 
Extensible Visualization System Architecture for 
Culled, Prioritized Data Streaming.”  Visualization 
and Data Analysis 2007, Proceedings of SPIE-IS&T 
Electronic Imaging, pg 64950I-1–12, January 2007.

• John Biddiscombe, Berk Geveci, Ken Martin, 
Kenneth Moreland, and David Thompson.  “Time 
Dependent Processing in a Parallel Pipeline 
Architecture.” IEEE Visualization 2007.  October 
2007. 



Further Reading
Parallel Rendering

• Kenneth Moreland, Brian Wylie, and Constantine 
Pavlakos.  “Sort-Last Parallel Rendering for Viewing 
Extremely Large Data Sets on Tile Displays.”  
Proceedings of IEEE 2001 Symposium on Parallel 
and Large-Data Visualization and Graphics, pg. 85–
92, October 2001.

• Kenneth Moreland and David Thompson.  “From 
Cluster to Wall with VTK.”  Proceddings of IEEE 2003 
Symposium on Parallel and Large-Data Visualization 
and Graphics, pg. 25–31, October 2003.

• Kenneth Moreland, Lisa Avila, and Lee Ann Fisk.  
“Parallel Unstructured Volume Rendering in 
ParaView.”  Visualization and Data Analysis 2007, 
Proceedings of SPIE-IS&T Electronic Imaging, pg. 
64950F-1–12, January 2007.


